Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 23 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 23 Rev 27
Line 21... Line 21...
21
21
22
ifeq (,$(DEB_BUILD_ARCH))
22
ifeq (,$(DEB_BUILD_ARCH))
23
DEB_BUILD_ARCH=$(shell dpkg-architecture -qDEB_BUILD_ARCH)
23
DEB_BUILD_ARCH=$(shell dpkg-architecture -qDEB_BUILD_ARCH)
24
endif
24
endif
25
25
-
 
26
DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-
 
27
DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
 
28
26
CFLAGS_EXTRA = -g
29
CFLAGS_EXTRA = -g
27
CPPFLAGS_EXTRA = -DDEBIAN
30
CPPFLAGS_EXTRA = -DDEBIAN
28
31
29
ifdef SSP
32
ifdef SSP
30
SSP_FLAGS=-fstack-protector
33
SSP_FLAGS=-fstack-protector
Line 84... Line 87...
84
ifneq ($(VERSION),$(DEBVERSION))
87
ifneq ($(VERSION),$(DEBVERSION))
85
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
88
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
86
endif
89
endif
87
90
88
CFARGS=$(CFARGSEXTRA) \
91
CFARGS=$(CFARGSEXTRA) \
-
 
92
       --host=$(DEB_HOST_GNU_TYPE) \
-
 
93
       --build=$(DEB_BUILD_GNU_TYPE) \
89
       --with-cflags=\\'$(CFLAGS_EXTRA)\\' \
94
       --with-cflags='$(CFLAGS_EXTRA)' \
90
       --with-cppflags=\\'$(CPPFLAGS_EXTRA)\\' \
95
       --with-cppflags='$(CPPFLAGS_EXTRA)' \
91
       --with-bignums \
96
       --with-bignums \
92
       --with-gmp \
97
       --with-gmp \
93
       --with-poll \
98
       --with-poll \
94
       --with-zlib \
99
       --with-zlib \
95
       --with-freetype \
100
       --with-freetype \