Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 2 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#! /bin/sh /usr/share/dpatch/dpatch-run
41 magnus 2
## 02_smartlink_rpath.dpatch
2 magnus 3
##
4
## All lines beginning with `## DP:' are a description of the patch.
5
## DP: Make smartlink not use -rpath
6
 
7
@DPATCH@
8
 
41 magnus 9
--- 7.7.orig/bin/smartlink	2006-03-19 18:01:51.000000000 +0100
10
+++ 7.7/bin/smartlink	2006-08-09 02:07:32.940847999 +0200
11
@@ -162,9 +162,8 @@ if test x$# != x0 ; then
2 magnus 12
      LDOPTS="$LDOPTS -R$RPATH"
13
    ;;
14
    Linux\ 2.*)
15
-     if test x$LINKING != xno -a "x$RPATH" != x ; then
16
-      LDOPTS="$LDOPTS -Wl,-rpath,$RPATH"
17
-     fi
18
+     LD_LIBRARY_PATH="$RPATH"
19
+     export LD_LIBRARY_PATH
20
    ;;
21
    UnixWare\ 7.*)
22
      if test x$LINKING != xno -a "x$RPATH" != x ; then
41 magnus 23
--- 7.7.orig/src/smartlink.c	2006-08-09 01:30:57.000000000 +0200
24
+++ 7.7/src/smartlink.c	2006-08-09 02:07:32.940847999 +0200
25
@@ -151,7 +151,7 @@ int main(int argc, char **argv)
2 magnus 26
   full_rpath = rpath;
27
 
28
 #ifdef USE_Wl
29
-  strcat(rpath, "-Wl,-rpath,");
30
+  /* strcat(rpath, "-Wl,-rpath,"); */
31
 #elif defined(USE_Wl_R)
32
   strcat(rpath, "-Wl,-R");
33
 #elif defined(USE_R)
41 magnus 34
@@ -293,7 +293,7 @@ int main(int argc, char **argv)
2 magnus 35
     }
36
     rpath_in_use |= add_path(rpath, ld_lib_path);
37
   }
38
-
39
+#if 0
40
   if (rpath_in_use) {
41
     /* Delete the terminating ':' */
42
     rpath[strlen(rpath) - 1] = 0;
41 magnus 43
@@ -340,6 +340,7 @@ int main(int argc, char **argv)
2 magnus 44
 #error Unknown method
45
 #endif
46
   }
47
+#endif
48
 
49
   new_argv[new_argc++] = NULL;
50