Rev 2 | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 2 | Rev 41 | ||
---|---|---|---|
Line 1... | Line 1... | ||
1 | #! /bin/sh /usr/share/dpatch/dpatch-run |
1 | #! /bin/sh /usr/share/dpatch/dpatch-run |
2 | ## 02_smartlink_rpath.dpatch by <magnus@proffe.kibibyte.se> |
2 | ## 02_smartlink_rpath.dpatch |
3 | ## |
3 | ## |
4 | ## All lines beginning with `## DP:' are a description of the patch. |
4 | ## All lines beginning with `## DP:' are a description of the patch. |
5 | ## DP: Make smartlink not use -rpath |
5 | ## DP: Make smartlink not use -rpath |
6 | 6 | ||
7 | @DPATCH@ |
7 | @DPATCH@ |
8 | 8 | ||
9 | --- pike7.3-7.3.51.orig/bin/smartlink |
9 | --- 7.7.orig/bin/smartlink 2006-03-19 18:01:51.000000000 +0100 |
10 | +++ pike7.3-7.3.51/bin/smartlink |
10 | +++ 7.7/bin/smartlink 2006-08-09 02:07:32.940847999 +0200 |
11 | @@ -147,9 +147,8 @@ |
11 | @@ -162,9 +162,8 @@ if test x$# != x0 ; then |
12 | LDOPTS="$LDOPTS -R$RPATH" |
12 | LDOPTS="$LDOPTS -R$RPATH" |
13 | ;; |
13 | ;; |
14 | Linux\ 2.*) |
14 | Linux\ 2.*) |
15 | - if test x$LINKING != xno -a "x$RPATH" != x ; then |
15 | - if test x$LINKING != xno -a "x$RPATH" != x ; then |
16 | - LDOPTS="$LDOPTS -Wl,-rpath,$RPATH" |
16 | - LDOPTS="$LDOPTS -Wl,-rpath,$RPATH" |
Line 18... | Line 18... | ||
18 | + LD_LIBRARY_PATH="$RPATH" |
18 | + LD_LIBRARY_PATH="$RPATH" |
19 | + export LD_LIBRARY_PATH |
19 | + export LD_LIBRARY_PATH |
20 | ;; |
20 | ;; |
21 | UnixWare\ 7.*) |
21 | UnixWare\ 7.*) |
22 | if test x$LINKING != xno -a "x$RPATH" != x ; then |
22 | if test x$LINKING != xno -a "x$RPATH" != x ; then |
23 | --- pike7.5-7.5.3/src/smartlink.c.orig 2003-01-17 20:13:38.000000000 +0100 |
23 | --- 7.7.orig/src/smartlink.c 2006-08-09 01:30:57.000000000 +0200 |
24 | +++ pike7.3-7.5.3/src/smartlink.c 2003-03-20 16:58:02.000000000 +0100 |
24 | +++ 7.7/src/smartlink.c 2006-08-09 02:07:32.940847999 +0200 |
25 | @@ -146,7 +146,7 @@ |
25 | @@ -151,7 +151,7 @@ int main(int argc, char **argv) |
26 | full_rpath = rpath; |
26 | full_rpath = rpath; |
27 | 27 | ||
28 | #ifdef USE_Wl |
28 | #ifdef USE_Wl |
29 | - strcat(rpath, "-Wl,-rpath,"); |
29 | - strcat(rpath, "-Wl,-rpath,"); |
30 | + /* strcat(rpath, "-Wl,-rpath,"); */ |
30 | + /* strcat(rpath, "-Wl,-rpath,"); */ |
31 | #elif defined(USE_Wl_R) |
31 | #elif defined(USE_Wl_R) |
32 | strcat(rpath, "-Wl,-R"); |
32 | strcat(rpath, "-Wl,-R"); |
33 | #elif defined(USE_R) |
33 | #elif defined(USE_R) |
34 | @@ -258,7 +258,7 @@ |
34 | @@ -293,7 +293,7 @@ int main(int argc, char **argv) |
35 | } |
35 | } |
36 | rpath_in_use |= add_path(rpath, ld_lib_path); |
36 | rpath_in_use |= add_path(rpath, ld_lib_path); |
37 | } |
37 | } |
38 | - |
38 | - |
39 | +#if 0 |
39 | +#if 0 |
40 | if (rpath_in_use) { |
40 | if (rpath_in_use) { |
41 | /* Delete the terminating ':' */ |
41 | /* Delete the terminating ':' */ |
42 | rpath[strlen(rpath) - 1] = 0; |
42 | rpath[strlen(rpath) - 1] = 0; |
43 | @@ -305,6 +305,7 @@ |
43 | @@ -340,6 +340,7 @@ int main(int argc, char **argv) |
44 | #error Unknown method |
44 | #error Unknown method |
45 | #endif |
45 | #endif |
46 | } |
46 | } |
47 | +#endif |
47 | +#endif |
48 | 48 |