Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## 03_language.yacc_bison_fix.dpatch by  <magnus@proffe.kibibyte.se>
3
##
4
## All lines beginning with `## DP:' are a description of the patch.
5
## DP: Disable fix for Bison apparently using too small ints
6
 
7
@DPATCH@
8
 
9
diff -U3 -Narp pike7.6-7.6.27/src/language.c pike7.6-7.6.27.new/src/language.c
10
--- pike7.6-7.6.27/src/language.c	2005-06-18 02:46:36.000000000 +0200
11
+++ pike7.6-7.6.27.new/src/language.c	2005-06-18 02:53:45.009538576 +0200
12
@@ -326,7 +326,7 @@ typedef union YYSTYPE {
13
 #include <stdio.h>
14
 int yylex(YYSTYPE *yylval);
15
 /* Bison is stupid, and tries to optimize for space... */
16
-#ifdef YYBISON
17
+#if defined(YYBISON) && !defined(DEBIAN)
18
 #define short int
19
 #endif /* YYBISON */
20