Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 3 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## 05_install.pike.dpatch by  <magnus@proffe.kibibyte.se>
3
##
4
## All lines beginning with `## DP:' are a description of the patch.
5
## DP: Allow include_prefix to be separately overridden in install.pike
6
 
7
@DPATCH@
41 magnus 8
diff -urNad pike7.8-7.8.116~/src/Makefile.in pike7.8-7.8.116/src/Makefile.in
9
--- pike7.8-7.8.116~/src/Makefile.in	2008-11-18 15:16:56.000000000 -0400
10
+++ pike7.8-7.8.116/src/Makefile.in	2009-05-04 21:50:17.000000000 -0300
11
@@ -57,7 +57,7 @@
2 magnus 12
 # TESTARGS = -F -a
13
 
14
 # Arguments for install.pike used by the install targets.
15
-INSTALLARGS = --new-style
16
+INSTALLARGS ?= --new-style
17
 
18
 #
19
 # use bison please, yacc isn't good enough.
41 magnus 20
@@ -658,7 +658,7 @@
2 magnus 21
 	man_prefix="$(man_prefix)" pike_name=$(pike_name) \
22
 	fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \
41 magnus 23
 	cflags="@DYNAMIC_MODULE_FLAGS@" ldflags="" \
2 magnus 24
-	$(INSTALLARGS)
25
+	include_prefix="$(include_prefix)" $(INSTALLARGS)
26
 
41 magnus 27
 install_interactive: pike-complete-stamp tools
2 magnus 28
 	@$(RUNPIKE) $(TMP_BINDIR)/install.pike --interactive \