Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 3 | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 3 Rev 41
Line 3... Line 3...
3
##
3
##
4
## All lines beginning with `## DP:' are a description of the patch.
4
## All lines beginning with `## DP:' are a description of the patch.
5
## DP: Allow include_prefix to be separately overridden in install.pike
5
## DP: Allow include_prefix to be separately overridden in install.pike
6
6
7
@DPATCH@
7
@DPATCH@
8
diff -urNad trunk~/src/Makefile.in trunk/src/Makefile.in
8
diff -urNad pike7.8-7.8.116~/src/Makefile.in pike7.8-7.8.116/src/Makefile.in
9
--- trunk~/src/Makefile.in	2006-10-20 15:40:28.000000000 +0200
9
--- pike7.8-7.8.116~/src/Makefile.in	2008-11-18 15:16:56.000000000 -0400
10
+++ trunk/src/Makefile.in	2007-09-26 09:51:13.000000000 +0200
10
+++ pike7.8-7.8.116/src/Makefile.in	2009-05-04 21:50:17.000000000 -0300
11
@@ -53,7 +53,7 @@
11
@@ -57,7 +57,7 @@
12
 # TESTARGS = -F -a
12
 # TESTARGS = -F -a
13
 
13
 
14
 # Arguments for install.pike used by the install targets.
14
 # Arguments for install.pike used by the install targets.
15
-INSTALLARGS = --new-style
15
-INSTALLARGS = --new-style
16
+INSTALLARGS ?= --new-style
16
+INSTALLARGS ?= --new-style
17
 
17
 
18
 #
18
 #
19
 # use bison please, yacc isn't good enough.
19
 # use bison please, yacc isn't good enough.
20
@@ -506,7 +506,7 @@
20
@@ -658,7 +658,7 @@
21
 	MANDIR_SRC="$(MANDIR_SRC)" \
-
 
22
 	man_prefix="$(man_prefix)" pike_name=$(pike_name) \
21
 	man_prefix="$(man_prefix)" pike_name=$(pike_name) \
23
 	fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \
22
 	fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \
-
 
23
 	cflags="@DYNAMIC_MODULE_FLAGS@" ldflags="" \
24
-	$(INSTALLARGS)
24
-	$(INSTALLARGS)
25
+	include_prefix="$(include_prefix)" $(INSTALLARGS)
25
+	include_prefix="$(include_prefix)" $(INSTALLARGS)
26
 
26
 
27
 install_interactive: pike tools
27
 install_interactive: pike-complete-stamp tools
28
 	@$(RUNPIKE) $(TMP_BINDIR)/install.pike --interactive \
28
 	@$(RUNPIKE) $(TMP_BINDIR)/install.pike --interactive \