Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 8 | Rev 39 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# Sample debian/rules that uses debhelper.
3
# GNU copyright 1997 by Joey Hess.
4
#
5
# This version is for a hypothetical package that builds an
6
# architecture-dependant package, as well as an architecture-independent
7
# package.
8
#
9
# $Id: rules,v 1.64 2006/08/05 15:49:18 grendel Exp $
10
#
11
 
12
# Uncomment this to turn on verbose mode.
13
#export DH_VERBOSE=1
14
include /usr/share/dpatch/dpatch.make
15
 
16
ifdef CCVER
17
CC=gcc-$(CCVER)
18
else
19
CC=gcc
20
endif
21
 
22
ifeq (,$(DEB_BUILD_ARCH))
23
DEB_BUILD_ARCH=$(shell dpkg-architecture -qDEB_BUILD_ARCH)
24
endif
25
 
12 magnus 26
CFLAGS_EXTRA = -g
2 magnus 27
CPPFLAGS_EXTRA = -DDEBIAN
28
 
29
ifdef SSP
30
SSP_FLAGS=-fstack-protector
31
endif
32
 
12 magnus 33
CFARGSEXTRA = --with-cdebug
34
 
2 magnus 35
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
12 magnus 36
CFARGSEXTRA += --without-copt
2 magnus 37
else
12 magnus 38
CFARGSEXTRA += --with-copt
2 magnus 39
endif
40
 
41
ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
12 magnus 42
CFARGSEXTRA += --with-rtldebug
43
else
44
CFARGSEXTRA += --without-rtldebug
2 magnus 45
endif
46
 
47
CFLAGS_EXTRA += $(SSP_FLAGS)
48
# Temporary workaround for hppa linker issues
49
ifeq ($(DEB_BUILD_ARCH),hppa)
50
CFLAGS_EXTRA += -ffunction-sections
51
endif
52
 
53
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
54
	INSTALL_PROGRAM += -s
55
endif
56
 
57
EXTRA_ARGS=--with-security
58
 
59
DO_MACHINE_CODE=no
60
ifeq ($(DEB_BUILD_ARCH),i386)
61
DO_MACHINE_CODE=yes
62
endif
63
ifeq ($(DEB_BUILD_ARCH),powerpc)
64
DO_MACHINE_CODE=yes
65
endif
66
ifeq ($(DEB_BUILD_ARCH),sparc)
67
DO_MACHINE_CODE=no
68
endif
69
 
70
ifeq ($(DO_MACHINE_CODE),yes)
71
MACHINE_OPTS=--with-machine-code
72
else
73
MACHINE_OPTS=--without-machine-code
74
endif
75
 
3 magnus 76
DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
77
MAJOR:=$(shell sed -ne 's/major://p' buildid.txt)
78
MINOR:=$(shell sed -ne 's/minor://p' buildid.txt)
79
BUILD:=$(shell sed -ne 's/build://p' buildid.txt)
80
PIKEV:=$(MAJOR).$(MINOR)
81
VERSION:=$(MAJOR).$(MINOR).$(BUILD)
82
PIKE:=pike$(PIKEV)
83
 
84
ifneq ($(VERSION),$(DEBVERSION))
85
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
86
endif
87
 
2 magnus 88
CFARGS=$(CFARGSEXTRA) \
12 magnus 89
       --with-cflags=\\'$(CFLAGS_EXTRA)\\' \
90
       --with-cppflags=\\'$(CPPFLAGS_EXTRA)\\' \
2 magnus 91
       --with-bignums \
92
       --with-gmp \
93
       --with-poll \
94
       --with-zlib \
95
       --with-freetype \
3 magnus 96
       --without-ttflib \
2 magnus 97
       --with-libnettle \
98
       --without-sybase \
3 magnus 99
       --without-java \
2 magnus 100
       --with-odbc \
101
       --with-sane \
102
       --with-postgres \
12 magnus 103
       --with-postgres-include-dir=`pg_config --includedir` \
2 magnus 104
       --with-libpq-dir=/usr/lib \
105
       --with-perl \
106
       --without-ffmpeg \
12 magnus 107
       --without-fftw \
2 magnus 108
       --without-libpdf \
3 magnus 109
       --without-libpanda \
2 magnus 110
       --without-GTK \
3 magnus 111
       --without-GTK2 \
12 magnus 112
       --without-bundles \
3 magnus 113
       $(MACHINE_OPTS) $(EXTRA_ARGS)
2 magnus 114
 
3 magnus 115
include_prefix=/usr/include/pike/$(VERSION)
116
lib_prefix=/usr/lib/pike/$(VERSION)
2 magnus 117
 
3 magnus 118
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core -N $(PIKE)-dev)
119
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
120
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
121
 
12 magnus 122
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase Gnome GTK GDK DVB Java TTF
3 magnus 123
# This is tricky. Note that it's only possible for an exclusion to match the last
124
# component specified in an .install file or on the command line, and below.
125
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
126
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
127
	      find debian/$$p/usr/lib/pike/*/* -type f -printf "-X%P "; done`
128
 
129
TMP=$(CURDIR)/debian/tmp
130
 
12 magnus 131
#export CFLAGS CC PIKE VERSION
132
export CC
2 magnus 133
 
134
build-arch: build-arch-stamp
135
build-arch-stamp: $(DPATCH_STAMPFN)
136
	dh_testdir
137
 
138
	# Add here command to compile/build the package.
139
	$(MAKE) compile CONFIGUREARGS="$(CFARGS)"
140
	touch build-arch-stamp
141
 
142
build-indep: build-indep-stamp
143
build-indep-stamp: $(DPATCH_STAMPFN)
144
	dh_testdir
145
 
146
	# Add here command to compile/build the arch indep package.
147
	$(MAKE) documentation CONFIGUREARGS="$(CFARGS)"
148
	touch build-indep-stamp
149
 
150
build: build-arch build-indep
151
 
152
clean: clean-patched unpatch
153
	dh_clean
154
 
155
clean-patched:
156
	dh_testdir
157
	dh_testroot
158
	rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp
159
 
160
	# Add here commands to clean up after the build process.
12 magnus 161
	$(MAKE) distclean
2 magnus 162
	rm -rf refdoc/modref refdoc/traditional_manual
163
 
164
install: DH_OPTIONS=
3 magnus 165
install: build-arch
2 magnus 166
	dh_testdir
167
	dh_testroot
168
	dh_clean -k
169
 
3 magnus 170
	$(MAKE) INSTALLARGS=--traditional \
171
		buildroot=$(TMP) \
172
	        prefix=/usr \
173
	        man_prefix=/usr/share/man \
174
	        lib_prefix="$(lib_prefix)" \
175
		include_prefix="$(include_prefix)" \
2 magnus 176
		pike_name=/usr/bin/$(PIKE) \
3 magnus 177
	        install_nodoc
2 magnus 178
 
3 magnus 179
#	Some cleaning
180
	find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';'
2 magnus 181
 
3 magnus 182
	install -d -m755 $(TMP)/usr/share/pixmaps
183
	install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm
184
	mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE)
185
	mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1
2 magnus 186
 
3 magnus 187
#	Fix permissions and shebang lines
188
	-for f in `find $(TMP)/usr/bin $(TMP)/usr/lib -type f`; do \
189
	  if file $$f | grep -q "script"; then \
190
	    chmod a+x $$f; \
191
	    sed -ri -e 's@#!.*NOMODULE@#!/usr/bin/$(PIKE)@' \
192
	            -e 's@#! */usr/local/bin/pike@#!/usr/bin/$(PIKE)@' \
193
	            -e 's@#! */usr/bin/env.*pike@#!/usr/bin/$(PIKE)@' \
194
	        $$f; \
195
	  fi; \
2 magnus 196
	done
197
 
12 magnus 198
#	Don't install our own specs file - the ordinary one is not that bad really
199
#	sed -e 's/@PIKEVERSION@/$(VERSION)/g' \
2 magnus 200
	    -e 's;@CONFIGURE_ARGS@;$(CFARGS);g' \
12 magnus 201
	    debian/specs.in > $(TMP)$(include_prefix)/specs
2 magnus 202
 
3 magnus 203
#	Install pike-config
12 magnus 204
	sed -e "s#@CFLAGS@#-I$(include_prefix)#;s/@LDFLAGS@//" \
3 magnus 205
	    -e "s/@MAJOR@/$(MAJOR)/;s/@MINOR@/$(MINOR)/;s/@BUILD@/$(BUILD)/" \
206
	    debian/pike-config.in > $(TMP)/usr/bin/$(PIKE)-config
2 magnus 207
 
3 magnus 208
# 	# pike -x module fix
209
	sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/dynamic_module_makefile;g' \
210
		$(TMP)$(include_prefix)/dynamic_module_makefile
2 magnus 211
 
212
# Build architecture-independent files here.
213
# Pass -i to all debhelper commands in this target to reduce clutter.
3 magnus 214
binary-indep: build-indep
2 magnus 215
	dh_testdir -i
216
	dh_testroot -i
3 magnus 217
	# install the docs
218
	dh_install -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual
219
	dh_install -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference
220
	dh_install -i -N$(PIKE)-manual -N$(PIKE)-reference --sourcedir=$(TMP)
2 magnus 221
	dh_installdocs -i
12 magnus 222
	dh_installchangelogs -i -k CHANGES
2 magnus 223
	dh_link -i
224
	dh_compress -i
225
	dh_fixperms -i
226
	dh_installdeb -i
227
	dh_gencontrol -i
228
	dh_md5sums -i
229
	dh_builddeb -i
230
 
231
# Build architecture-dependent files here.
232
binary-arch: build-arch install
233
	dh_testdir -a
234
	dh_testroot -a
235
#	dh_installdebconf -a
12 magnus 236
	dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE)
3 magnus 237
	dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY)
12 magnus 238
	for p in $(MODULE_PACKAGES) $(PIKE)-dev; do \
3 magnus 239
		dh_link -p$$p usr/share/doc/$(PIKE)-core usr/share/doc/$$p; \
240
	done
2 magnus 241
	dh_installdocs -a
3 magnus 242
	dh_installmenu -a
243
#	dh_installman -a
12 magnus 244
	dh_installchangelogs -a -k CHANGES
2 magnus 245
	dh_strip -a
246
	dh_compress -a
3 magnus 247
	dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite
2 magnus 248
	dh_installdeb -a
249
	dh_shlibdeps -a
250
	dh_gencontrol -a
251
	dh_md5sums -a
252
	dh_builddeb -a
253
 
254
binary: binary-indep binary-arch
255
.PHONY: build clean binary-indep binary-arch binary install configure