Subversion Repositories pike-old

Compare Revisions

Ignore whitespace Rev 30 → Rev 31

/tags/7.6.116-1/debian/patches/11_pthread_stub.dpatch
File deleted
Property changes:
Deleted: svn:executable
## -1 +0,0 ##
-*
\ No newline at end of property
Index: 7.6.116-1/debian/patches/04_make_variables_fpic.dpatch
===================================================================
--- 7.6.116-1/debian/patches/04_make_variables_fpic.dpatch (revision 30)
+++ 7.6.116-1/debian/patches/04_make_variables_fpic.dpatch (nonexistent)
@@ -1,21 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 04_make_variables_fpic.dpatch by <magnus@proffe.kibibyte.se>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Add -fPIC to OTHERFLAGS and NOOPTFLAGS in src/make_variables.in
-
-@DPATCH@
-
---- pike7.6-7.6.27/src/make_variables.in 2004-04-23 17:41:33.000000000 +0200
-+++ pike7.6-7.6.27.new/src/make_variables.in 2005-06-18 04:19:00.278899432 +0200
-@@ -26,8 +26,8 @@ RUNPIKE=$(@RUNPIKE@)
- OPTIMIZE=@OPTIMIZE@
- INSTALL=@INSTALL@
- WARN=@WARN@
--OTHERFLAGS=@CFLAGS@ $(OSFLAGS) $(OPTIMIZE) $(WARN) $(PROFIL)
--NOOPTFLAGS=@CFLAGS@ @CPPFLAGS@ $(OSFLAGS) $(WARN) $(PROFIL)
-+OTHERFLAGS=@CFLAGS@ $(OSFLAGS) $(OPTIMIZE) $(WARN) $(PROFIL) -fPIC
-+NOOPTFLAGS=@CFLAGS@ @CPPFLAGS@ $(OSFLAGS) $(WARN) $(PROFIL) -fPIC
- AR=@AR@
- SRCDIR=@srcdir@
- PMOD_TARGETS=@PMOD_TARGETS@
/7.6.116-1/debian/patches/04_make_variables_fpic.dpatch
Property changes:
Deleted: svn:executable
## -1 +0,0 ##
-*
\ No newline at end of property
Index: 7.6.116-1/debian/patches/00list
===================================================================
--- 7.6.116-1/debian/patches/00list (revision 30)
+++ 7.6.116-1/debian/patches/00list (nonexistent)
@@ -1,7 +0,0 @@
-01_master.in
-02_smartlink_rpath
-#04_make_variables_fpic
-05_install.pike
-07_dynamic_module_makefile.in-libgcc
-10_misplaced_MAXPATHLEN
-11_pthread_stub
Index: 7.6.116-1/debian/patches/01_master.in.dpatch
===================================================================
--- 7.6.116-1/debian/patches/01_master.in.dpatch (revision 30)
+++ 7.6.116-1/debian/patches/01_master.in.dpatch (nonexistent)
@@ -1,25 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 01_master.in.dpatch by <magnus@kibibyte.se>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Add local site-pike directories to master.pike.in
-
-@DPATCH@
-diff -urNad trunk~/lib/master.pike.in trunk/lib/master.pike.in
---- trunk~/lib/master.pike.in 2007-01-01 01:28:04.000000000 +0100
-+++ trunk/lib/master.pike.in 2007-10-02 14:04:02.000000000 +0200
-@@ -1111,6 +1111,14 @@
- add_module_path("¤lib_prefix¤/modules");
- #endif
-
-+ // Debian paths
-+ add_include_path("/usr/local/include/pike");
-+ add_include_path("/usr/local/include/pike"+__REAL_MAJOR__+"."+__REAL_MINOR__);
-+ add_module_path("/usr/local/lib/pike/site_pike");
-+ add_module_path("/usr/local/lib/pike"+__REAL_MAJOR__+"."+__REAL_MINOR__+"/site_pike");
-+ add_module_path("/usr/local/share/pike/site_pike");
-+ add_module_path("/usr/local/share/pike"+__REAL_MAJOR__+"."+__REAL_MINOR__+"/site_pike");
-+
- #if "¤include_prefix¤"[0]!='¤'
- include_prefix = "¤include_prefix¤";
- #endif
/7.6.116-1/debian/patches/01_master.in.dpatch
Property changes:
Deleted: svn:executable
## -1 +0,0 ##
-*
\ No newline at end of property
Index: 7.6.116-1/debian/patches/05_install.pike.dpatch
===================================================================
--- 7.6.116-1/debian/patches/05_install.pike.dpatch (revision 30)
+++ 7.6.116-1/debian/patches/05_install.pike.dpatch (nonexistent)
@@ -1,28 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 05_install.pike.dpatch by <magnus@proffe.kibibyte.se>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Allow include_prefix to be separately overridden in install.pike
-
-@DPATCH@
-diff -urNad trunk~/src/Makefile.in trunk/src/Makefile.in
---- trunk~/src/Makefile.in 2006-10-20 15:40:28.000000000 +0200
-+++ trunk/src/Makefile.in 2007-09-26 09:51:13.000000000 +0200
-@@ -53,7 +53,7 @@
- # TESTARGS = -F -a
-
- # Arguments for install.pike used by the install targets.
--INSTALLARGS = --new-style
-+INSTALLARGS ?= --new-style
-
- #
- # use bison please, yacc isn't good enough.
-@@ -506,7 +506,7 @@
- MANDIR_SRC="$(MANDIR_SRC)" \
- man_prefix="$(man_prefix)" pike_name=$(pike_name) \
- fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \
-- $(INSTALLARGS)
-+ include_prefix="$(include_prefix)" $(INSTALLARGS)
-
- install_interactive: pike tools
- @$(RUNPIKE) $(TMP_BINDIR)/install.pike --interactive \
/7.6.116-1/debian/patches/05_install.pike.dpatch
Property changes:
Deleted: svn:executable
## -1 +0,0 ##
-*
\ No newline at end of property
Index: 7.6.116-1/debian/patches/07_dynamic_module_makefile.in-libgcc.dpatch
===================================================================
--- 7.6.116-1/debian/patches/07_dynamic_module_makefile.in-libgcc.dpatch (revision 30)
+++ 7.6.116-1/debian/patches/07_dynamic_module_makefile.in-libgcc.dpatch (nonexistent)
@@ -1,19 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 07_dynamic_module_makefile.in-libgcc.dpatch by <magnus@proffe.kibibyte.se>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Figure out LIBGCC name.
-
-@DPATCH@
-
---- 7.6/src/modules/dynamic_module_makefile.in 2005-12-30 14:33:50.110303750 +0100
-+++ 7.6.fix/src/modules/dynamic_module_makefile.in 2005-12-30 14:50:03.367128500 +0100
-@@ -2,7 +2,7 @@
- # $Id: 07_dynamic_module_makefile.in-libgcc.diff,v 1.1 2006/01/03 16:03:38 grendel Exp $
- #
-
--LIBGCC=@LIBGCC@
-+LIBGCC=$(shell gcc -print-libgcc-file-name)
- LC_REQ=@LC_REQ@
-
- LINKAGE_CPPFLAGS=
/7.6.116-1/debian/patches/07_dynamic_module_makefile.in-libgcc.dpatch
Property changes:
Deleted: svn:executable
## -1 +0,0 ##
-*
\ No newline at end of property
Index: 7.6.116-1/debian/patches/10_misplaced_MAXPATHLEN.dpatch
===================================================================
--- 7.6.116-1/debian/patches/10_misplaced_MAXPATHLEN.dpatch (revision 30)
+++ 7.6.116-1/debian/patches/10_misplaced_MAXPATHLEN.dpatch (nonexistent)
@@ -1,31 +0,0 @@
-#!/bin/sh /usr/share/dpatch/dpatch-run
-## 10_misplaced_MAXPATHLEN.dpatch by Samuel Thibault <samuel.thibault@ens-lyon.org>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Move reserve MAXPATHLEN definition up.
-
-@DPATCH@
-
---- pike7.6-7.6.112.orig/src/modules/files/efuns.c 2007-07-24 23:08:26.932458000 +0000
-+++ pike7.6-7.6.112/src/modules/files/efuns.c 2007-07-24 23:09:58.626801000 +0000
-@@ -106,6 +106,10 @@
-
- #endif
-
-+#ifndef MAXPATHLEN
-+#define MAXPATHLEN 32768
-+#endif
-+
- struct array *encode_stat(PIKE_STAT_T *s)
- {
- struct array *a;
-@@ -1113,9 +1117,6 @@
- size*=2;
- } while (size < 10000);
- #else
--#ifndef MAXPATHLEN
--#define MAXPATHLEN 32768
--#endif
- tmp=xalloc(MAXPATHLEN+1);
- THREADS_ALLOW_UID();
- e = getwd(tmp);
Index: 7.6.116-1/debian/patches/02_smartlink_rpath.dpatch
===================================================================
--- 7.6.116-1/debian/patches/02_smartlink_rpath.dpatch (revision 30)
+++ 7.6.116-1/debian/patches/02_smartlink_rpath.dpatch (nonexistent)
@@ -1,50 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 02_smartlink_rpath.dpatch by <magnus@proffe.kibibyte.se>
-##
-## All lines beginning with `## DP:' are a description of the patch.
-## DP: Make smartlink not use -rpath
-
-@DPATCH@
-
---- pike7.3-7.3.51.orig/bin/smartlink
-+++ pike7.3-7.3.51/bin/smartlink
-@@ -147,9 +147,8 @@
- LDOPTS="$LDOPTS -R$RPATH"
- ;;
- Linux\ 2.*)
-- if test x$LINKING != xno -a "x$RPATH" != x ; then
-- LDOPTS="$LDOPTS -Wl,-rpath,$RPATH"
-- fi
-+ LD_LIBRARY_PATH="$RPATH"
-+ export LD_LIBRARY_PATH
- ;;
- UnixWare\ 7.*)
- if test x$LINKING != xno -a "x$RPATH" != x ; then
---- pike7.5-7.5.3/src/smartlink.c.orig 2003-01-17 20:13:38.000000000 +0100
-+++ pike7.3-7.5.3/src/smartlink.c 2003-03-20 16:58:02.000000000 +0100
-@@ -146,7 +146,7 @@
- full_rpath = rpath;
-
- #ifdef USE_Wl
-- strcat(rpath, "-Wl,-rpath,");
-+ /* strcat(rpath, "-Wl,-rpath,"); */
- #elif defined(USE_Wl_R)
- strcat(rpath, "-Wl,-R");
- #elif defined(USE_R)
-@@ -258,7 +258,7 @@
- }
- rpath_in_use |= add_path(rpath, ld_lib_path);
- }
--
-+#if 0
- if (rpath_in_use) {
- /* Delete the terminating ':' */
- rpath[strlen(rpath) - 1] = 0;
-@@ -305,6 +305,7 @@
- #error Unknown method
- #endif
- }
-+#endif
-
- new_argv[new_argc++] = NULL;
-
/7.6.116-1/debian/patches/02_smartlink_rpath.dpatch
Property changes:
Deleted: svn:executable
## -1 +0,0 ##
-*
\ No newline at end of property
Index: 7.6.116-1/debian/pike7.6-gl.install
===================================================================
--- 7.6.116-1/debian/pike7.6-gl.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-gl.install (nonexistent)
@@ -1,2 +0,0 @@
-usr/lib/pike/*/modules/*GL*
-usr/share/pike/*/modules/*GL*
Index: 7.6.116-1/debian/pike7.6-perl.install
===================================================================
--- 7.6.116-1/debian/pike7.6-perl.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-perl.install (nonexistent)
@@ -1,2 +0,0 @@
-usr/lib/pike/*/modules/*Perl.*
-usr/share/pike/*/modules/*Perl.*
Index: 7.6.116-1/debian/docs
===================================================================
--- 7.6.116-1/debian/docs (revision 30)
+++ 7.6.116-1/debian/docs (nonexistent)
@@ -1,3 +0,0 @@
-README-CVS
-README
-COMMITTERS
Index: 7.6.116-1/debian/pike.xpm
===================================================================
--- 7.6.116-1/debian/pike.xpm (revision 30)
+++ 7.6.116-1/debian/pike.xpm (nonexistent)
@@ -1,38 +0,0 @@
-/* XPM */
-static char * pike_xpm[] = {
-"32 32 3 1",
-" c None",
-". c #000000",
-"+ c #FFFFFF",
-" .......................... ",
-" .++++++++++++++++++++++++. ",
-" .+++.....+..+..+..+.....+. ",
-" .+++.....+..+.....+.....+. ",
-" .+++..+..........+...++++. ",
-" .++........+....++.....++. ",
-" .++.....+..+....++.....++. ",
-" .++..+++........+...+++++. ",
-" .+...+++..+..+.........++. ",
-" .+..++++..+..+........+++. ",
-" .++++++++++++++++++++++++. ",
-" .+++++++++++++++++++++++.... ",
-" .+++++..++++++++...++....... ",
-" .++++.....+++++...........+. ",
-" .+++................++..++.. ",
-" .+++.....+.........++..++.. ",
-" .++++........++..+++..++.. ",
-" .++++++......++++++..++... ",
-" .++++......+++++++..+++... ",
-" .+++.....++..+++++...+++.... ",
-" .++.....++..++++++++...++.+. ",
-" .+....++++.++++++++++....... ",
-" ....++..+..+++..+........... ",
-" ....+..+.......++++..++++. ",
-"......+....+...++++++++++++. ",
-".+...+.....++++++++++++++++. ",
-"...++......++++++++++++++++. ",
-" ..++.....+++++++++++++++++. ",
-" .++++++++++++++++++++++++. ",
-" .......................... ",
-" ",
-" "};
Index: 7.6.116-1/debian/pike7.6-core.postinst
===================================================================
--- 7.6.116-1/debian/pike7.6-core.postinst (revision 30)
+++ 7.6.116-1/debian/pike7.6-core.postinst (nonexistent)
@@ -1,62 +0,0 @@
-#! /bin/sh
-# postinst script for pike7.6
-#
-# see: dh_installdeb(1)
-#
-# $Id: pike7.6-core.postinst,v 1.1 2005/11/21 20:21:48 grendel Exp $
-#
-
-set -e
-
-PIKE=7.6
-PIKEBIN=pike${PIKE}
-
-# summary of how this script can be called:
-# * <postinst> `configure' <most-recently-configured-version>
-# * <old-postinst> `abort-upgrade' <new version>
-# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
-# <new-version>
-# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
-# <failed-install-package> <version> `removing'
-# <conflicting-package> <version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-#
-# quoting from the policy:
-# Any necessary prompting should almost always be confined to the
-# post-installation script, and should be protected with a conditional
-# so that unnecessary prompting doesn't happen if a package's
-# installation fails and the `postinst' is called with `abort-upgrade',
-# `abort-remove' or `abort-deconfigure'.
-LOCAL_DIRS="share/pike/site_pike share/pike${PIKE}/site_pike lib/pike/site_pike lib/pike${PIKE}/site_pike include/pike include/pike${PIKE}"
-
-case "$1" in
- configure)
- /usr/sbin/update-alternatives --install /usr/bin/pike pike /usr/bin/${PIKEBIN} 10 \
- --slave /usr/share/man/man1/pike.1.gz pike.1.gz /usr/share/man/man1/${PIKEBIN}.1.gz
- #
- # If the creation fails, so be it, user might have the filesystem mounted r/o
- #
- for d in $LOCAL_DIRS; do
- if [ ! -d /usr/local/$d ]; then
- install -d -m 755 -o root -g root /usr/local/$d || true
- fi
- done
- ;;
-
- abort-upgrade|abort-remove|abort-deconfigure)
-
- ;;
-
- *)
- echo "postinst called with unknown argument \`$1'" >&2
- exit 1
- ;;
-esac
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
-exit 0
Index: 7.6.116-1/debian/pike7.6-odbc.install
===================================================================
--- 7.6.116-1/debian/pike7.6-odbc.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-odbc.install (nonexistent)
@@ -1,4 +0,0 @@
-usr/lib/pike/*/modules/*Odbc.*
-usr/share/pike/*/modules/*Odbc.*
-usr/lib/pike/*/modules/Sql.pmod/odbc*
-usr/share/pike/*/modules/Sql.pmod/odbc*
Index: 7.6.116-1/debian/pike7.6-core.prerm
===================================================================
--- 7.6.116-1/debian/pike7.6-core.prerm (revision 30)
+++ 7.6.116-1/debian/pike7.6-core.prerm (nonexistent)
@@ -1,44 +0,0 @@
-#! /bin/sh
-# prerm script for pike7.6
-#
-# see: dh_installdeb(1)
-#
-# $Id: pike7.6-core.prerm,v 1.1 2005/11/21 20:21:48 grendel Exp $
-#
-
-set -e
-
-PIKE=7.6
-PIKEBIN=pike${PIKE}
-
-# summary of how this script can be called:
-# * <prerm> `remove'
-# * <old-prerm> `upgrade' <new-version>
-# * <new-prerm> `failed-upgrade' <old-version>
-# * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
-# * <deconfigured's-prerm> `deconfigure' `in-favour'
-# <package-being-installed> <version> `removing'
-# <conflicting-package> <version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-
-case "$1" in
- remove|upgrade|deconfigure)
- update-alternatives --remove pike /usr/bin/${PIKEBIN}
- ;;
- failed-upgrade)
- ;;
- *)
- echo "prerm called with unknown argument \`$1'" >&2
- exit 1
- ;;
-esac
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
-exit 0
-
-
Index: 7.6.116-1/debian/pike7.6-dev.dirs
===================================================================
--- 7.6.116-1/debian/pike7.6-dev.dirs (revision 30)
+++ 7.6.116-1/debian/pike7.6-dev.dirs (nonexistent)
@@ -1,2 +0,0 @@
-usr/bin/
-usr/include/pike/
Index: 7.6.116-1/debian/pike7.6-gdbm.install
===================================================================
--- 7.6.116-1/debian/pike7.6-gdbm.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-gdbm.install (nonexistent)
@@ -1,2 +0,0 @@
-usr/lib/pike/*/modules/*Gdbm.*
-usr/share/pike/*/modules/*Gdbm.*
Index: 7.6.116-1/debian/pike7.6-manual.install
===================================================================
--- 7.6.116-1/debian/pike7.6-manual.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-manual.install (nonexistent)
@@ -1,2 +0,0 @@
-
-
Index: 7.6.116-1/debian/pike7.6-dev.install
===================================================================
--- 7.6.116-1/debian/pike7.6-dev.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-dev.install (nonexistent)
@@ -1,2 +0,0 @@
-usr/include/pike/*/*
-usr/bin/pike*-config
Index: 7.6.116-1/debian/menu
===================================================================
--- 7.6.116-1/debian/menu (revision 30)
+++ 7.6.116-1/debian/menu (nonexistent)
@@ -1,4 +0,0 @@
-?package(pike7.6-core):needs="text" section="Applications/Programming"\
- title="Pike 7.6 HILFE" \
- command="/usr/bin/pike7.6" \
- icon="/usr/share/pixmaps/pike7.6.xpm"
Index: 7.6.116-1/debian/watch
===================================================================
--- 7.6.116-1/debian/watch (revision 30)
+++ 7.6.116-1/debian/watch (nonexistent)
@@ -1,4 +0,0 @@
-version=3
-
-http://pike.ida.liu.se/download/pub/pike/beta/7.6.116/ .*/Pike-v(.*)\.tar\.gz
-http://pike.ida.liu.se/download/pub/pike/beta/(7\.6\.\d+)/ .*/Pike-v(.*)\.tar\.gz
Index: 7.6.116-1/debian/pike7.6-sane.install
===================================================================
--- 7.6.116-1/debian/pike7.6-sane.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-sane.install (nonexistent)
@@ -1,2 +0,0 @@
-usr/lib/pike/*/modules/*SANE.*
-usr/share/pike/*/modules/*SANE.*
Index: 7.6.116-1/debian/pike7.6-bzip2.install
===================================================================
--- 7.6.116-1/debian/pike7.6-bzip2.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-bzip2.install (nonexistent)
@@ -1,2 +0,0 @@
-usr/lib/pike/*/modules/*Bz2.*
-usr/share/pike/*/modules/*Bz2.*
Index: 7.6.116-1/debian/NEWS
===================================================================
--- 7.6.116-1/debian/NEWS (revision 30)
+++ 7.6.116-1/debian/NEWS (nonexistent)
@@ -1,7 +0,0 @@
-pike7.6 (7.6.112-1) unstable; urgency=low
-
- * The Image.TTF module uses the deprecated freetype1 library that is
- being phased out. It has therefore been removed. The Image.FreeType
- module should be used instead.
-
- -- Magnus Holmgren <magnus@kibibyte.se> Tue, 25 Sep 2007 20:21:17 +0200
Index: 7.6.116-1/debian/pike7.6-core.install
===================================================================
--- 7.6.116-1/debian/pike7.6-core.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-core.install (nonexistent)
@@ -1,8 +0,0 @@
-usr/bin/pike7.6
-usr/lib/pike/*/?.?
-usr/lib/pike/*/include
-usr/lib/pike/*/modules
-usr/lib/pike/*/master.pike
-usr/lib/pike/*/master.pike.o
-usr/share/pixmaps
-usr/share/man
Index: 7.6.116-1/debian/specs.in
===================================================================
--- 7.6.116-1/debian/specs.in (revision 30)
+++ 7.6.116-1/debian/specs.in (nonexistent)
@@ -1,7 +0,0 @@
-CC=gcc
-CFLAGS=-O2 -DDEBIAN
-LDFLAGS=-L/usr/lib -L/usr/X11R6/lib
-CPPFLAGS=-I/usr/include/pike/@PIKEVERSION@/ -I/usr/include
-CPP=gcc -E
-LDSHARED=gcc -shared
-configure_args=@CONFIGURE_ARGS@
Index: 7.6.116-1/debian/compat
===================================================================
--- 7.6.116-1/debian/compat (revision 30)
+++ 7.6.116-1/debian/compat (nonexistent)
@@ -1 +0,0 @@
-4
Index: 7.6.116-1/debian/pike7.6-reference.install
===================================================================
--- 7.6.116-1/debian/pike7.6-reference.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-reference.install (nonexistent)
@@ -1,2 +0,0 @@
-
-
Index: 7.6.116-1/debian/changelog
===================================================================
--- 7.6.116-1/debian/changelog (revision 30)
+++ 7.6.116-1/debian/changelog (nonexistent)
@@ -1,1190 +0,0 @@
-pike7.6 (7.6.116-1) experimental; urgency=low
-
- * The latest downloadable "beta" release of the 7.6 branch.
- * Modify debian/watch to track the beta download directory.
- * Update debian/copyright.
- * debian/rules: Handle DEB_*_GNU_TYPE and modify quoting of strings
- inside the long string of configure arguments.
- * debian/control: Adjust Vcs-Svn field.
-
- -- Magnus Holmgren <holmgren@debian.org> Fri, 16 May 2008 23:41:39 +0200
-
-pike7.6 (7.6.112-2) unstable; urgency=low
-
- * Increase Standards-Version to 3.7.3:
- * debian/menu: change section from Apps/Programming to
- Applications/Programming.
- * Fix capitalization issues in package descriptions and remove
- superfluous occurrences of upstream homepage URL.
- * New maintainer email address.
- * Work around build failures on alpha by removing build-indep from the
- prerequisites of build.
- * Drop the versioned dependency on freeglut3-dev (>= 2.2.0-6.1) for
- alpha and hppa since even sarge has 2.2.0-8.
- * Correct doc-base section according to new section list.
- * 11_pthread_stub.dpatch: Make sure configure doesn't think
- pthread_atfork() works just because it exists, when it's in fact a
- stub. (Closes: #462998). Thanks to Samuel Thibault.
-
- -- Magnus Holmgren <holmgren@debian.org> Fri, 09 May 2008 21:11:28 +0200
-
-pike7.6 (7.6.112-1) unstable; urgency=low
-
- [ Henrik Andreasson ]
- * The latest upstream release
-
- [ Magnus Holmgren ]
- * New maintainers (Closes: #411684).
- * Use dpatch to apply patches.
- * really apply the following patches from the .93-4 release:
- * Removed Image TTF module to drop the dependency on oldlibs
- `freetype1'. (Closes: #431784)
- * Added a patch by Samuel Thibault to fix a FTBFS bug on hurd-i386.
- (Closes: #434581)
- * Radically clean up debian/rules (Closes: #424334).
- * Manuals are again built during the binary build process so that
- official tarballs can be used to build the package.
- * Delete redundant dhelp files (dhelp uses doc-base metadata since
- long ago).
- * Change directory structure and get rid of an unnecessary directory level
- (by installing with --traditional instead of --new-style):
- - Pike modules and include files, and master.pike are now in
- /usr/lib/pike/<version> instead of /usr/lib/pike/<version>/lib.
- - The pike executable is now in /usr/bin itself, instead of in
- /usr/lib/pike/<version>/bin with a symlink in /usr/bin.
- - .pike and .pmod files are no longer moved to /usr/share/pike. It's
- not that important that all files in /usr/lib are actually
- platform-specific. All the symlinks are thus eliminated.
- * Move modules GLU and GLUE to pike7.6-gl, where they belong.
- GLUE.Drivers.GTK removed since it depends on GTK, which was dropped
- previously.
- * Make pike7.6-dev Architecture: any.
- * No longer use own version of specs.in - fix the configure parameters
- instead.
- * Fix 01_master.in.dpatch - the Debian-specific add_*_path() calls were
- completely off.
- * Add debian/watch (checking for latest official stable release).
- * Drop 03_language.yacc_bison_fix.dpatch; it no longer has any effect.
- * Add Mird to the module exclusion list.
- * Add Vcs fields to debian/control.
-
- -- Magnus Holmgren <magnus@kibibyte.se> Fri, 21 Dec 2007 09:29:03 +0100
-
-pike7.6 (7.6.93-4) unstable; urgency=low
-
- * QA upload.
- * Removed Image TTF module to drop the dependency on oldlibs
- `freetype1'. (Closes: #431784)
- * Added a patch by Samuel Thibault to fix a FTBFS bug on hurd-i386.
- (Closes: #434581)
- * Converted `debian/copyright' to UTF-8.
- * Make the package binNMU-able by appropriately replacing `Source-Version'
- in `debian/control'.
- * Added a `Homepage' field.
-
- -- Philipp Kern <pkern@debian.org> Sun, 16 Dec 2007 18:55:16 +0100
-
-pike7.6 (7.6.93-3) unstable; urgency=low
-
- * QA upload.
- * Set maintainer to QA Group; Orphaned: #411684
- * Conforms with latest Standards Version 3.7.2
- * Remove duplicate build-dependency on debhelper
- * Add quotes to debian/menu
-
- -- Michael Ablassmeier <abi@debian.org> Thu, 15 Mar 2007 10:29:51 +0100
-
-pike7.6 (7.6.93-2) unstable; urgency=low
-
- * Please change postgresql-dev build dependency to libpq-dev (Closes:
- #409770)
-
- -- Marek Habersack <grendel@debian.org> Tue, 13 Feb 2007 18:41:28 +0100
-
-pike7.6 (7.6.93-1) unstable; urgency=low
-
- * The latest cvs snapshot
- * Please don't ship pike7.6-gtk (Closes: #387503)
- gtk1 modules removed because of debian dropping support for gtk1.
- At the same time, the pike7.6-gtk module is disabled, since gtk2
- stuff in it doesn't seem to compile without gtk1 devel packages
- around.
- * pike epoll not included. (Closes: #264206)
- This can only be fixed by making sure that the debian autobuilders
- all support epoll, which is beyond the pike maintainer's powers :)
-
- -- Marek Habersack <grendel@debian.org> Wed, 4 Oct 2006 13:11:55 +0200
-
-pike7.6 (7.6.92-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Mon, 2 Oct 2006 15:20:43 +0200
-
-pike7.6 (7.6.91-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Thu, 14 Sep 2006 14:44:33 +0200
-
-pike7.6 (7.6.90-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Thu, 14 Sep 2006 14:42:53 +0200
-
-pike7.6 (7.6.89-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Tue, 22 Aug 2006 18:26:40 +0200
-
-pike7.6 (7.6.88-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Tue, 22 Aug 2006 18:16:59 +0200
-
-pike7.6 (7.6.87-2) unstable; urgency=low
-
- * Shortened the long descriptions of several binary packages
- * Added short description of pike, plus an url, to the description of
- the pike modules binary packages
-
- -- Marek Habersack <grendel@debian.org> Sun, 9 Aug 2006 01:28:37 +0200
-
-pike7.6 (7.6.87-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Sun, 4 Jun 2006 22:21:07 +0200
-
-pike7.6 (7.6.86-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Sun, 4 Jun 2006 22:17:43 +0200
-
-pike7.6 (7.6.85-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Sun, 4 Jun 2006 15:33:52 +0200
-
-pike7.6 (7.6.84-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Sun, 4 Jun 2006 15:29:49 +0200
-
-pike7.6 (7.6.83-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Thu, 1 Jun 2006 10:29:09 +0200
-
-pike7.6 (7.6.82-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Thu, 1 Jun 2006 10:26:10 +0200
-
-pike7.6 (7.6.81-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Thu, 1 Jun 2006 9:42:41 +0200
-
-pike7.6 (7.6.80-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Thu, 1 Jun 2006 9:38:38 +0200
-
-pike7.6 (7.6.79-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Fri, 26 May 2006 8:03:10 +0200
-
-pike7.6 (7.6.78-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Fri, 26 May 2006 7:53:46 +0200
-
-pike7.6 (7.6.77-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Wed, 17 May 2006 10:58:45 +0200
-
-pike7.6 (7.6.76-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Wed, 17 May 2006 10:56:26 +0200
-
-pike7.6 (7.6.75-3) unstable; urgency=low
-
- * New GL dependency
-
- -- Marek Habersack <grendel@debian.org> Wed, 10 May 2006 11:51:03 +0200
-
-pike7.6 (7.6.75-2) unstable; urgency=low
-
- * Cleanup build-dependencies (Closes: #365787)
- libpng3-dev -> libpng12-dev
- 'freeglut3-dev | libglut3-dev' -> freeglut3-dev
- Patch from Stefan Huehner <stefan@huehner.org>, thanks.
-
- -- Marek Habersack <grendel@debian.org> Tue, 9 May 2006 21:56:32 +0200
-
-pike7.6 (7.6.75-1) unstable; urgency=low
-
- * The latest cvs snapshot
- * Removed the ssl fix patch since the upstream contains a better one
- now.
- * pike7.6-mysql: Uinstallable; dependency on libmysqlclient15
- (Closes: #360325)
- Recompiled to correct the binary dependencies.
-
- -- Marek Habersack <grendel@debian.org> Wed, 5 Apr 2006 12:59:11 +0200
-
-pike7.6 (7.6.74-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Sun, 2 Apr 2006 20:08:53 +0200
-
-pike7.6 (7.6.73-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Sun, 2 Apr 2006 12:51:39 +0200
-
-pike7.6 (7.6.72-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Sun, 2 Apr 2006 12:50:37 +0200
-
-pike7.6 (7.6.71-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Sun, 2 Apr 2006 12:47:53 +0200
-
-pike7.6 (7.6.70-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Sun, 2 Apr 2006 12:43:57 +0200
-
-pike7.6 (7.6.69-1) unstable; urgency=low
-
- * The latest cvs snapshot
- * not installable in sid (Closes: #359231)
- Made the meta packages binary NMU safe
- * Added an SSL fix that should fix steam
- * pike7.6-core: doesn't clean out /usr/local stuff (Closes: #355413)
- The directories are removed on purge in postrm if they are empty.
-
- -- Marek Habersack <grendel@debian.org> Thu, 30 Mar 2006 12:51:20 +0200
-
-pike7.6 (7.6.68-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Thu, 2 Mar 2006 23:47:25 +0100
-
-pike7.6 (7.6.67-1) unstable; urgency=low
-
- * The latest cvs snapshot
- * Please upgrade build depends to libmysqlclient15-dev (Closes:
- #343794)
- * The pike package is present in sarge but missing from etch. (Closes:
- #342650)
-
- -- Marek Habersack <grendel@debian.org> Tue, 31 Jan 2006 21:28:38 +0100
-
-pike7.6 (7.6.66-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Sun, 22 Jan 2006 21:46:24 +0100
-
-pike7.6 (7.6.65-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Fri, 6 Jan 2006 18:44:19 +0100
-
-pike7.6 (7.6.64-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Fri, 6 Jan 2006 18:43:05 +0100
-
-pike7.6 (7.6.63-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Fri, 6 Jan 2006 17:31:52 +0100
-
-pike7.6 (7.6.62-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Fri, 6 Jan 2006 17:30:24 +0100
-
-pike7.6 (7.6.61-1) unstable; urgency=low
-
- * The latest cvs snapshot
- * dynamic_module_makefile moved to pike7.6-core since it contains
- platform-specific stuff. Also included a patch to detect the
- libgcc.a path dynamically.
- * pike7.6-dev depends on pike7.6-core now. It is necessary to both
- pull in dynamic_module_makefile and to enable compilation of modules
- with pike -x
- * Updated the patch for include_prefix change in install.pike
- * Closes: Bug#345329: pike-public.parser.xml2 - FTBFS:
- gcc: /usr/lib/gcc/i486-linux-gnu/4.0.3/libgcc.a: No such file or
- directory - Debian Bug report logs
- * Closes: Bug#345330: pike-public.network.pcap - FTBFS:
- gcc: /usr/lib/gcc/i486-linux-gnu/4.0.3/libgcc.a: No such file or
- directory - Debian Bug report logs
-
- -- Marek Habersack <grendel@debian.org> Fri, 30 Dec 2005 17:35:50 +0100
-
-pike7.6 (7.6.60-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Wed, 21 Dec 2005 0:23:28 +0100
-
-pike7.6 (7.6.59-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Tue, 20 Dec 2005 15:28:39 +0100
-
-pike7.6 (7.6.58-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Tue, 20 Dec 2005 15:26:59 +0100
-
-pike7.6 (7.6.57-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Mon, 19 Dec 2005 5:06:53 +0100
-
-pike7.6 (7.6.56-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Mon, 19 Dec 2005 5:05:38 +0100
-
-pike7.6 (7.6.55-2) unstable; urgency=low
-
- * Fix for -x module
-
- -- Marek Habersack <grendel@debian.org> Sun, 4 Dec 2005 02:58:15 +0100
-
-pike7.6 (7.6.55-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Fri, 2 Dec 2005 13:16:33 +0100
-
-pike7.6 (7.6.54-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Fri, 2 Dec 2005 13:13:38 +0100
-
-pike7.6 (7.6.53-1) unstable; urgency=low
-
- * The latest cvs snapshot
- * One more monger fix
- * A kFreeBSD build fix
-
- -- Marek Habersack <grendel@debian.org> Tue, 29 Nov 2005 17:34:06 +0100
-
-pike7.6 (7.6.52-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Tue, 29 Nov 2005 17:25:19 +0100
-
-pike7.6 (7.6.51-2) unstable; urgency=low
-
- * pike7.6_7.6.33-2 (alpha/unstable): FTBFS: glibc aborts in free()
- (Closes: #333072)
- * pike7.4-core: doesn't clean out /usr/local stuff (Closes: #339963)
-
- -- Marek Habersack <grendel@debian.org> Mon, 21 Nov 2005 21:21:23 +0100
-
-pike7.6 (7.6.51-1) unstable; urgency=low
-
- * The latest cvs snapshot
- * Some fixes to make pike -x module work better on Debian.
- * Manuals are no longer built during the binary build process. Instead,
- they are contained in the .orig tarball.
-
- -- Marek Habersack <grendel@debian.org> Mon, 21 Nov 2005 21:20:49 +0100
-
-pike7.6 (7.6.50-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Wed, 2 Nov 2005 17:38:26 +0100
-
-pike7.6 (7.6.49-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Mon, 31 Oct 2005 12:46:27 +0100
-
-pike7.6 (7.6.48-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Mon, 31 Oct 2005 12:42:24 +0100
-
-pike7.6 (7.6.47-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Wed, 26 Oct 2005 9:50:48 +0200
-
-pike7.6 (7.6.46-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Wed, 26 Oct 2005 9:49:35 +0200
-
-pike7.6 (7.6.45-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Tue, 25 Oct 2005 14:23:53 +0200
-
-pike7.6 (7.6.44-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Tue, 25 Oct 2005 14:22:34 +0200
-
-pike7.6 (7.6.43-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Tue, 25 Oct 2005 10:38:49 +0200
-
-pike7.6 (7.6.42-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Tue, 25 Oct 2005 10:37:42 +0200
-
-pike7.6 (7.6.41-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Mon, 24 Oct 2005 11:59:56 +0200
-
-pike7.6 (7.6.40-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Mon, 24 Oct 2005 11:58:49 +0200
-
-pike7.6 (7.6.39-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Mon, 17 Oct 2005 12:13:55 +0200
-
-pike7.6 (7.6.38-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Mon, 17 Oct 2005 12:12:44 +0200
-
-pike7.6 (7.6.37-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Wed, 12 Oct 2005 1:34:07 +0200
-
-pike7.6 (7.6.36-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Wed, 12 Oct 2005 1:31:42 +0200
-
-pike7.6 (7.6.35-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Sat, 20 Aug 2005 16:26:02 +0200
-
-pike7.6 (7.6.34-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Sat, 20 Aug 2005 16:24:41 +0200
-
-pike7.6 (7.6.33-2) unstable; urgency=low
-
- * /usr/lib/pike/7.6.24/include/pike/specs is missing (Closes: #322851)
- Using own version of specs.in, since the pike-generated one does not
- make sense on a Debian system.
- * Updated the Standards-Version, no changes
-
- -- Marek Habersack <grendel@debian.org> Tue, 16 Aug 2005 13:38:09 +0200
-
-pike7.6 (7.6.33-1) unstable; urgency=high
-
- * The latest cvs snapshot
- * Again urgency high to rush the recompile so that Caudium 1.4 can
- be recompiled on the non-x86 architectures. The previous upload
- of Pike was a bit rushed.
-
- -- Marek Habersack <grendel@debian.org> Thu, 28 Jul 2005 13:04:41 +0200
-
-pike7.6 (7.6.32-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Thu, 28 Jul 2005 13:02:47 +0200
-
-pike7.6 (7.6.31-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Wed, 27 Jul 2005 14:24:49 +0200
-
-pike7.6 (7.6.30-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Wed, 27 Jul 2005 14:22:53 +0200
-
-pike7.6 (7.6.29-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Fri, 22 Jul 2005 22:20:25 +0200
-
-pike7.6 (7.6.28-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Fri, 22 Jul 2005 22:18:34 +0200
-
-pike7.6 (7.6.27-2) unstable; urgency=high
-
- * Force a recompile to match the new libgmp3 package name
-
- -- Marek Habersack <grendel@debian.org> Tue, 19 Jul 2005 12:06:53 +0200
-
-pike7.6 (7.6.27-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Thu, 26 May 2005 02:12:22 +0200
-
-pike7.6 (7.6.24-2) unstable; urgency=low
-
- * Closes: #310631: debian/rules version detection could be better
- Thanks to Matthias Klose <doko@cs.tu-berlin.de> for providing the
- patch.
- * Closes: #282939: fails to start in interactive mode
- No longer happens with the newer Pike 7.6 versions.
-
- -- Marek Habersack <grendel@debian.org> Thu, 26 May 2005 02:48:36 +0200
-
-pike7.6 (7.6.24-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Wed, 22 Sep 2004 20:19:24 +0200
-
-pike7.6 (7.6.23-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Wed, 22 Sep 2004 17:52:43 +0200
-
-pike7.6 (7.6.22-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Wed, 22 Sep 2004 17:49:52 +0200
-
-pike7.6 (7.6.21-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Tue, 21 Sep 2004 0:24:04 +0200
-
-pike7.6 (7.6.20-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Tue, 21 Sep 2004 0:18:16 +0200
-
-pike7.6 (7.6.19-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Mon, 20 Sep 2004 23:35:37 +0200
-
-pike7.6 (7.6.18-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Mon, 20 Sep 2004 23:31:42 +0200
-
-pike7.6 (7.6.17-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Sun, 19 Sep 2004 16:42:33 +0200
-
-pike7.6 (7.6.16-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Sun, 19 Sep 2004 16:39:58 +0200
-
-pike7.6 (7.6.15-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Fri, 17 Sep 2004 13:26:37 +0200
-
-pike7.6 (7.6.14-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Fri, 17 Sep 2004 13:21:58 +0200
-
-pike7.6 (7.6.13-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Tue, 10 Aug 2004 15:32:25 +0200
-
-pike7.6 (7.6.12-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Tue, 10 Aug 2004 15:29:54 +0200
-
-pike7.6 (7.6.11-3) unstable; urgency=medium
-
- * Gotten rid of gdk-imlib1-dev build dependency
- * Delayed upload to wait for the indirect dependencies to get into
- the archives.
-
- -- Marek Habersack <grendel@debian.org> Fri, 30 Jul 2004 14:36:10 +0200
-
-pike7.6 (7.6.11-2) unstable; urgency=medium
-
- * Changed the build-dep from libxpm4-dev to libxpm-dev
- * Changed the build-dep from libtiff3g-dev to libtiff4-dev
-
- -- Marek Habersack <grendel@debian.org> Sun, 25 Jul 2004 02:25:22 +0200
-
-pike7.6 (7.6.11-1) unstable; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Thu, 1 Jul 2004 23:05:30 +0200
-
-pike7.6 (7.6.10-1) unstable; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Thu, 1 Jul 2004 23:03:26 +0200
-
-pike7.6 (7.6.9-2) unstable; urgency=low
-
- * Make sure all bugs filed against Pike 7.4 will not appear here
- * Pike 7.6 will replace Pike 7.4 in Debian soon.
-
- -- Marek Habersack <grendel@debian.org> Wed, 9 Jun 2004 13:40:35 +0200
-
-pike7.6 (7.6.9-1) unstable; urgency=low
-
- * The latest cvs snapshot
- * Added the full text of MPL 1.1 to the debian/copyright file
-
- -- Marek Habersack <grendel@debian.org> Mon, 17 May 2004 20:14:30 +0200
-
-pike7.6 (7.6.8-1) experimental; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Mon, 17 May 2004 20:12:55 +0200
-
-pike7.6 (7.6.7-2) unstable; urgency=low
-
- * Better dependencies for the GL libraries
-
- -- Marek Habersack <grendel@debian.org> Tue, 11 May 2004 16:18:21 +0200
-
-pike7.6 (7.6.7-1) unstable; urgency=low
-
- * The latest upstream release. The most important changes since v7.4
- are listed in the upstream CHANGES file in the /usr/share/doc/pike7.6
- directory
-
- -- Marek Habersack <grendel@debian.org> Wed, 5 May 2004 18:38:38 +0200
-
-pike7.6 (7.6.6-1) experimental; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Wed, 5 May 2004 18:35:56 +0200
-
-pike7.6 (7.6.5-1) experimental; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Sat, 1 May 2004 18:35:04 +0200
-
-pike7.6 (7.6.4-1) experimental; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Marek Habersack <grendel@debian.org> Sat, 1 May 2004 18:32:26 +0200
-
-pike7.6 (7.6.3-1) experimental; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Mon, 26 Apr 2004 2:19:59 +0200
-
-pike7.6 (7.6.2-1) experimental; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Pike build system <pike-devel@lists.lysator.liu.se> Mon, 26 Apr 2004 2:17:57 +0200
-
-pike7.5 (7.5.27-2) experimental; urgency=low
-
- * The latest CVS snapshot
-
- -- Marek Habersack <grendel@debian.org> Fri, 23 Apr 2004 17:49:47 +0200
-
-pike7.5 (7.5.27-1) experimental; urgency=low
-
- * The latest cvs snapshot
-
- -- Pike build system <pike-devel@lists.lysator.liu.se> Sat, 17 Apr 2004 17:57:50 +0200
-
-pike7.5 (7.5.26-1) experimental; urgency=low
-
- * Release number bumped by export.pike.
-
- -- Pike build system <pike-devel@lists.lysator.liu.se> Sat, 17 Apr 2004 17:56:36 +0200
-
-pike7.5 (7.5.25-1) experimental; urgency=low
-
- * The latest CVS snapshot
-
- -- Marek Habersack <grendel@debian.org> Sun, 4 Apr 2004 01:48:49 +0200
-
-pike7.5 (7.5.23-2) experimental; urgency=low
-
- * The latest CVS update
-
- -- Marek Habersack <grendel@debian.org> Fri, 2 Apr 2004 16:49:26 +0200
-
-pike7.5 (7.5.23-1) experimental; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Mon, 29 Mar 2004 17:28:21 +0200
-
-pike7.5 (7.5.21-1) experimental; urgency=low
-
- * The latest cvs snapshot
-
- -- Marek Habersack <grendel@debian.org> Wed, 17 Mar 2004 14:13:19 +0100
-
-pike7.5 (7.5.19-2) experimental; urgency=low
-
- * Creation of directories in /usr/local won't fail now
- (closes: Bug#234694)
-
- -- Marek Habersack <grendel@debian.org> Thu, 26 Feb 2004 01:28:15 +0100
-
-pike7.5 (7.5.19-1) experimental; urgency=low
-
- * The latest upstream update
-
- -- Marek Habersack <grendel@debian.org> Mon, 23 Feb 2004 22:42:46 +0100
-
-pike7.5 (7.5.17-2) experimental; urgency=low
-
- * Latest CVS snapshot.
-
- -- Marek Habersack <grendel@debian.org> Wed, 14 Jan 2004 19:53:42 +0100
-
-pike7.5 (7.5.17-1) experimental; urgency=low
-
- * The latest cvs snapshot.
- * Disabled using the machine code in the pike bytecode. It poses a
- security risk and breaks under kernels with exec-shield or PAX.
-
- -- Marek Habersack <grendel@debian.org> Tue, 9 Dec 2003 17:01:16 +0100
-
-pike7.5 (7.5.12-2) experimental; urgency=low
-
- * Added libnettle to the build dependencies.
-
- -- Marek Habersack <grendel@debian.org> Tue, 11 Nov 2003 18:24:24 +0100
-
-pike7.5 (7.5.12-1) experimental; urgency=low
-
- * Catching up on version numbers.
- * First upload to Debian/experimental.
-
- -- Marek Habersack <grendel@debian.org> Sat, 30 Oct 2003 22:46:18 +0100
-
-pike7.5 (7.5.5-1) unstable; urgency=low
-
- * Latest upstream version.
-
- -- Marek Habersack <grendel@debian.org> Sat, 29 Mar 2003 01:46:01 +0100
-
-pike7.5 (7.5.3-2) unstable; urgency=low
-
- * Latest upstream version.
- * Rediffed the Debian patches to work with the current sources.
-
- -- Marek Habersack <grendel@debian.org> Wed, 19 Mar 2003 13:42:44 +0100
-
-pike7.5 (7.5.3-1) unstable; urgency=low
-
- * Latest upstream version.
-
- -- Marek Habersack <grendel@debian.org> Wed, 5 Feb 2003 19:07:40 +0100
-
-pike7.5 (7.5.2-1) unstable; urgency=low
-
- * Latest upstream version.
- * No sparc machine code for now.
- * Updated the mesagl dependencies.
-
- -- Marek Habersack <grendel@debian.org> Wed, 5 Feb 2003 01:19:37 +0100
-
-pike7.5 (7.5.1-3) unstable; urgency=low
-
- * A bug in the sparc machine code causing a segfault was fixed.
-
- -- Marek Habersack <grendel@debian.org> Mon, 3 Feb 2003 17:16:46 +0100
-
-pike7.5 (7.5.1-2) unstable; urgency=low
-
- * Pike is installed using the --new-style layout now.
-
- -- Marek Habersack <grendel@debian.org> Tue, 28 Jan 2003 00:36:59 +0100
-
-pike7.5 (7.5.1-1) unstable; urgency=low
-
- * Latest upstream version.
-
- -- Marek Habersack <grendel@debian.org> Fri, 6 Dec 2002 05:20:15 +0100
-
-pike7.3 (7.3.62-1) unstable; urgency=low
-
- * Latest upstream version. The most important changes:
- * lib/modules/Tools.pmod/AutoDoc.pmod/DocParser.pmod: Fixed broken
- support for typedef.
- * src/modules/Gz/module.pmod.in: Now supports zlib's which lack the
- eof() function.
- * src/modules/Gz/module.pmod.in: Now behaves if zlib isn't
- available.
- * src/builtin_functions.c: Moved some debug functions to Debug.
- Updated sleep doc. Fixed describe_backtrace type.
- * src/builtin.cmod: Move _describe_program to
- Debug.describe_program.
- * src/modules/Gz/testsuite.in: Added test for Gz.File().
- * lib/modules/MIME.pmod/module.pmod: When doing guessy style MIME
- decoding, inherit the guess attribute for multipart message parts.
- * src/modules/Gz/zlibmod.c: Fixed nasty null-termination bug.
- * src/post_modules/Shuffler/Shuffler.cmod: Patched Shuffler module
- some more. This patch should fix some of the problems with the
- shuffler accessing references that have been destructed.
- * lib/modules/Filesystem.pmod/Tar.pmod: Bugfix: Since lookups are
- done with normalized paths, we need to normalize the paths in
- filename{s,_to_entry} as well to get proper matches.
- * src/pike_memory.h: Added a macro to detect whether a memory
- checker is in use, so that conflicting debug checks can be avoided.
- * lib/master.pike.in, src/svalue.c,
- lib/modules/Tools.pmod/testsuite.in: Make %O default output for
- objects and programs better.
- * lib/modules/Stdio.pmod/module.pmod, src/modules/files/file.c,
- src/modules/files/termios.c: Document the low level I/O functions
- in Stdio.File and not Fd.
- .
- Designwise motivation: Fd and Fd_ref ought to be considered
- internal; Stdio.File is the lowest "official" API level.
- .
- Practical motivation: It's _much_ easier to find the functions in
- the generated docs, despite the small pointer to Fd in Stdio.File.
- * lib/modules/Protocols.pmod/HTTP.pmod/Server.pmod/SSLPort.pike:
- added SSL support to the simple webserver. Based on SSL.https, but
- behaves exactly like Protocols.HTTP.Server.Port, except for SSL.
- * lib/master.pike.in: - Changed some search(x,y)!=-1 into
- has_value(x,y) - Optimized Getopt call by using local variables for
- NO_ARG, MAY_HAVE_ARG and HAS_ARG. - Optimized Getopt call by
- always having five elements per argument, so that Getopt need not
- rewrite the array. - Always accept the --autoreload option so that
- we are silenty ignoring it if Pike has not autoreload (instead of
- bailing out with strange error messages (that changes depending
- on the number and order of options)).
-
- -- Marek Habersack <grendel@debian.org> Mon, 25 Nov 2002 18:43:54 +0100
-
-pike7.3 (7.3.60-2) unstable; urgency=low
-
- * Latest cvs snapshot. The most important changes:
- * lib/modules/Protocols.pmod/HTTP.pmod/module.pmod: Added missing
- file argument for put_url().
- * lib/modules/Array.pmod: CHANGES says that there should be an
- Array.Iterator. So let's have one.
- * lib/modules/Parser.pmod/XML.pmod/DOM.pmod: Added iterators, nice
- _sprintf to Nodes, and made all lfuns static.
- * src/post_modules/Shuffler/Shuffler.cmod: If the done-callback
- destroyed the shuffler object, the shuffler crashed when signaling
- that data wasn't sent thru the give_back function. This might have
- other implications but seems to work as a fix for now.
-
- -- Marek Habersack <grendel@debian.org> Sat, 9 Nov 2002 19:46:43 +0100
-
-pike7.3 (7.3.60-1) unstable; urgency=low
-
- * Latest upstream version. The most important changes:
- * src/code/: ppc32.c, ppc32.h: Implemented OPCODE_INLINE_BRANCH
- interface for PPC.
- * src/dlopen.c: Some more IA64 fixes.
- * lib/modules/Protocols.pmod/HTTP.pmod/Query.pike: added the
- possibility to have array values in headers mapping to allow
- multiple headers
- * src/dlopen.c: The IA64 global offset table is now at the end of
- the datasegment, so that gp-relative offsets have a chance at
- working.
- * lib/modules/Standards.pmod/RDF.pike: Improved API and working
- N-triple parsing.
- * src/threads.c: Added a reference from MutexKey to the mutex
- object it holds, so that the latter won't be refcount garbed (which
- causes both to be destructed) if there are no other references.
-
- -- Marek Habersack <grendel@debian.org> Mon, 4 Nov 2002 22:32:36 +0100
-
-pike7.3 (7.3.58-3) unstable; urgency=low
-
- * Removed the sybase module as it doesn't work on Debian.
-
- -- Marek Habersack <grendel@debian.org> Wed, 23 Oct 2002 02:16:53 +0200
-
-pike7.3 (7.3.58-2) unstable; urgency=low
-
- * Latest CVS snapshot.
-
- -- Marek Habersack <grendel@debian.org> Mon, 21 Oct 2002 03:01:06 +0200
-
-pike7.3 (7.3.58-1) unstable; urgency=low
-
- * Latest upstream version. The most important changes:
- * lib/modules/Parser.pmod/XML.pmod/Tree.pmod: Better typing.
- * lib/modules/Array.pmod: Fixed a border problem in Array.sum
- * src/builtin.cmod: Fixed leak of the strings "string" and "int".
- * lib/modules/String.pmod/module.pmod: Removed the deprecated
- strmult and String_buffer (compatibility is already in place).
- Fixed a soundex bug. Made int2roman and int2size throw an error
- when input is out of range. Fixed an off by one error for the
- bytes/kb transition in int2size.
- * lib/modules/Parser.pmod/Pike.pmod: Parse binary numbers.
- * lib/modules/Standards.pmod/EXIF.pmod: Better EXIF support. Some
- API changes: get_properties only accepts Stdio.File objects.
- MN_Multi1 is renamed to MN_Multi3.
- * src/: builtin.cmod, builtin_functions.c: It's better to throw
- errors than return zero if ctime(), localtime() or gmtime() fails.
- * src/builtin.cmod: Fixed missing checks for NULL from gmtime(2),
- localtime(2) and ctime(2) which could cause segfaults. E.g. on NT
- they don't handle negative time stamps.
- * src/modules/: HTTPLoop/log.c, Oracle/oracle.c, spider/discdate.c:
- Fixed missing checks for NULL from gmtime(2), localtime(2) and
- ctime(2) which could cause segfaults. E.g. on NT they don't handle
- negative time stamps.
- * src/builtin_functions.c: Fixed missing checks for NULL from
- gmtime(2) and localtime(2) which could cause segfaults. E.g. on NT
- they don't handle negative time stamps.
- * lib/modules/Remote.pmod/connection.pike: Fixed races that could
- cause synchronous calls to hang in threaded mode. It's still
- unclear whether a connection close is handled cleanly, though.
- Better handling of exceptions from close callbacks.
-
- -- Marek Habersack <grendel@debian.org> Fri, 18 Oct 2002 22:49:02 +0200
-
-pike7.3 (7.3.56-2) unstable; urgency=low
-
- * Latest CVS snapshot.
-
- -- Marek Habersack <grendel@debian.org> Fri, 18 Oct 2002 01:37:36 +0200
-
-pike7.3 (7.3.56-1) unstable; urgency=low
-
- * Latest upstream version. The most important changes:
- * src/: docode.c, interpret_functions.h: Replaced the F_THROW_ZERO
- opcode used at normal exit from catch blocks with F_EXIT_CATCH,
- which uses the newer escape catch feature. This avoids a longjmp at
- the normal exit of every catch block.
- Also changed the return value for normal catch block exits to be
- UNDEFINED and not zero.
- * lib/modules/Parser.pmod/C.pmod: Added index possibility on
- tokens.
- * src/program.c: Use safe_apply_handler for calling
- get_default_module, to get better checking of the return value and
- to get correct handling of return values that are false.
- This fixes a bug in the odd recursion that involves the compat
- handler and e.g. lib/7.2/modules/__default.pmod which itself
- contains "#pike 7.2": The second time get_default_module is called
- it'll resolve an unfinished program with "__default" and thus get a
- function pointer that evaluates to false.
- * bin/pike.in, src/Makefile.in, src/builtin_functions.c,
- src/error.c: Set a breakpoint on pike_gdb_breakpoint by default
- when gdb is started. Made it accessible from pike with
- "_gdb_breakpoint" to make it convenient to enter gdb at a specific
- point in the pike code.
-
- -- Marek Habersack <grendel@debian.org> Wed, 25 Sep 2002 02:47:40 +0200
-
-pike7.3 (7.3.55-1) unstable; urgency=low
-
- * Latest upstream version. The most important changes:
- * src/modules/Gz/: configure.in, zlibmod.c: The Gz module now
- supports old versions of zlib again. Most notably seek(), tell(),
- eof() and setparams() are now optionally implemented in Gz._file.
- * lib/master.pike.in: Added include_prefix.
- * src/builtin_functions.c: More information about the use and
- limits of mktime().
- * src/main.c: Now calls tzset() to initialize timezone et al.
- * lib/modules/Protocols.pmod/LDAP.pmod/client.pike: add catch to
- prevent search from bombing out when talking to active directory
- servers. this is not a good fix, as the cause seems to be referrer
- data.
- This will need to be looked at more closely, but it at least allows
- us to talk to m$ systems.
- * lib/modules/Protocols.pmod/LDAP.pmod/client.pike: fixed create()
- so that connection is actually made when SSL support is not
- present.
- * lib/master.pike.in: Added -x option to run tools from
- Tools.Standalone.
-
- -- Marek Habersack <grendel@debian.org> Fri, 13 Sep 2002 15:44:33 +0200
-
-pike7.3 (7.3.53-1) unstable; urgency=low
-
- * Latest upstream version. The most important changes:
- * src/modules/Perl/perlmod.c: Adjustment to work better with Perl
- 5.8.0, plus a few minor layout changes to make the code nicer to
- read.
- * lib/modules/Local.pmod: Added support for specifying paths using
- the PIKE_LOCAL_PATH environment variable.
- * src/language.yacc: Fixed typing for intranges with bignum
- intervals.
- * lib/modules/Stdio.pmod/GZipFile.pike: Added basic support for
- reading and writing gzip files. This is the first version and it
- is still a bit experimental. Uses Gz._file() for lowlevel support.
- * src/modules/Gz/zlibmod.c: Added basic support for reading and
- writing gzip files. Lowlevel functions are located in Gz._file().
- * src/builtin_functions.c: Fixed incorrect info about rusage() and
- added a bit more description about some of the items.
- * src/language.yacc: Added the "global" keyword to
- magic_identifiers so it can be used after ->.
- * src/pike_types.c: parse_type() now supports the syntax
- object(this_program), and defaults to implements mode.
- * src/modules/Postgres/: configure.in, pgres_config.h.in,
- postgres.c: this makes the Postgres module detect/work correctly
- with the PostgreSQL 7.2+
-
- -- Marek Habersack <grendel@debian.org> Sun, 1 Sep 2002 00:22:22 +0200
-
-pike7.3 (7.3.51-4) unstable; urgency=low
-
- * Enabled the Pike security.
- * Build-conflicts with libutahglx since the latter doesn't conform
- to the Linux OpenGL ABI
- * Added correct build dependencies for Debian/Sid
-
- -- Marek Habersack <grendel@debian.org> Fri, 23 Aug 2002 02:47:22 +0200
-
-pike7.3 (7.3.51-3) unstable; urgency=low
-
- * Added the -svg package.
- * Most packages now link to the -core doc directory.
-
- -- Marek Habersack <grendel@debian.org> Sat, 10 Aug 2002 21:27:04 +0200
-
-pike7.3 (7.3.51-2) unstable; urgency=low
-
- * The Debian packaging setup merged with the upstream sources under
- the packaging/debian/ directory.
- * Patches previously applied to the sources before generating the
- Debian diff are now applied on the compile time.
- * Most packages depend on pikeX.Y-core now.
-
- -- Marek Habersack <grendel@debian.org> Tue, 6 Aug 2002 00:36:53 +0200
-
-pike7.3 (7.3.51-1) unstable; urgency=low
-
- * Latest CVS snapshot
- * the -crypto and -gz packages are merged with the core Pike package.
- * the -doc package is split into -manual and -reference and
- * The pike7.3 package became a meta package that installs a subset
- of all the Pike packages present in Debian. This subset makes up a
- recommended Pike environment for most systems.
-
- -- Marek Habersack <grendel@debian.org> Wed, 31 Jul 2002 23:35:18 +0200
-
-pike7.3 (7.3.49-2) unstable; urgency=low
-
- * Latest CVS snapshot
-
- -- Marek Habersack <grendel@debian.org> Mon, 29 Jul 2002 10:23:44 +0200
-
-pike7.3 (7.3.49-1) unstable; urgency=low
-
- * Latest CVS snapshot
-
- -- Marek Habersack <grendel@debian.org> Mon, 15 Jul 2002 23:21:33 +0200
-
-pike7.3 (7.3.47-1) unstable; urgency=low
-
- * Latest CVS snapshot
-
- -- Marek Habersack <grendel@debian.org> Wed, 12 Jun 2002 18:13:12 +0200
-
-pike7.3 (7.3.45-1) unstable; urgency=low
-
- * Latest CVS snapshot
-
- -- Marek Habersack <grendel@debian.org> Fri, 17 May 2002 16:41:09 +0200
-
-pike7.3 (7.3.41-1) unstable; urgency=low
-
- * Initial Release.
-
- -- Marek Habersack <grendel@debian.org> Sun, 5 May 2002 01:34:05 +0200
-
Index: 7.6.116-1/debian/rules
===================================================================
--- 7.6.116-1/debian/rules (revision 30)
+++ 7.6.116-1/debian/rules (nonexistent)
@@ -1,260 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 by Joey Hess.
-#
-# This version is for a hypothetical package that builds an
-# architecture-dependant package, as well as an architecture-independent
-# package.
-#
-# $Id: rules,v 1.64 2006/08/05 15:49:18 grendel Exp $
-#
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-include /usr/share/dpatch/dpatch.make
-
-ifdef CCVER
-CC=gcc-$(CCVER)
-else
-CC=gcc
-endif
-
-ifeq (,$(DEB_BUILD_ARCH))
-DEB_BUILD_ARCH=$(shell dpkg-architecture -qDEB_BUILD_ARCH)
-endif
-
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-CFLAGS_EXTRA = -g
-CPPFLAGS_EXTRA = -DDEBIAN
-
-ifdef SSP
-SSP_FLAGS=-fstack-protector
-endif
-
-CFARGSEXTRA = --with-cdebug
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-CFARGSEXTRA += --without-copt
-else
-CFARGSEXTRA += --with-copt
-endif
-
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-CFARGSEXTRA += --with-rtldebug
-else
-CFARGSEXTRA += --without-rtldebug
-endif
-
-CFLAGS_EXTRA += $(SSP_FLAGS)
-# Temporary workaround for hppa linker issues
-ifeq ($(DEB_BUILD_ARCH),hppa)
-CFLAGS_EXTRA += -ffunction-sections
-endif
-
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-EXTRA_ARGS=--with-security
-
-DO_MACHINE_CODE=no
-ifeq ($(DEB_BUILD_ARCH),i386)
-DO_MACHINE_CODE=yes
-endif
-ifeq ($(DEB_BUILD_ARCH),powerpc)
-DO_MACHINE_CODE=yes
-endif
-ifeq ($(DEB_BUILD_ARCH),sparc)
-DO_MACHINE_CODE=no
-endif
-
-ifeq ($(DO_MACHINE_CODE),yes)
-MACHINE_OPTS=--with-machine-code
-else
-MACHINE_OPTS=--without-machine-code
-endif
-
-DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
-MAJOR:=$(shell sed -ne 's/major://p' buildid.txt)
-MINOR:=$(shell sed -ne 's/minor://p' buildid.txt)
-BUILD:=$(shell sed -ne 's/build://p' buildid.txt)
-PIKEV:=$(MAJOR).$(MINOR)
-VERSION:=$(MAJOR).$(MINOR).$(BUILD)
-PIKE:=pike$(PIKEV)
-
-ifneq ($(VERSION),$(DEBVERSION))
-$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
-endif
-
-CFARGS=$(CFARGSEXTRA) \
- --host=$(DEB_HOST_GNU_TYPE) \
- --build=$(DEB_BUILD_GNU_TYPE) \
- --with-cflags='$(CFLAGS_EXTRA)' \
- --with-cppflags='$(CPPFLAGS_EXTRA)' \
- --with-bignums \
- --with-gmp \
- --with-poll \
- --with-zlib \
- --with-freetype \
- --without-ttflib \
- --with-libnettle \
- --without-sybase \
- --without-java \
- --with-odbc \
- --with-sane \
- --with-postgres \
- --with-postgres-include-dir=`pg_config --includedir` \
- --with-libpq-dir=/usr/lib \
- --with-perl \
- --without-ffmpeg \
- --without-fftw \
- --without-libpdf \
- --without-libpanda \
- --without-GTK \
- --without-GTK2 \
- --without-bundles \
- $(MACHINE_OPTS) $(EXTRA_ARGS)
-
-include_prefix=/usr/include/pike/$(VERSION)
-lib_prefix=/usr/lib/pike/$(VERSION)
-
-MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core -N $(PIKE)-dev)
-#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
-#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
-
-excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase Gnome GTK GDK DVB Java TTF
-# This is tricky. Note that it's only possible for an exclusion to match the last
-# component specified in an .install file or on the command line, and below.
-DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
-DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
- find debian/$$p/usr/lib/pike/*/* -type f -printf "-X%P "; done`
-
-TMP=$(CURDIR)/debian/tmp
-
-#export CFLAGS CC PIKE VERSION
-export CC
-
-build-arch: build-arch-stamp
-build-arch-stamp: $(DPATCH_STAMPFN)
- dh_testdir
-
- # Add here command to compile/build the package.
- $(MAKE) compile CONFIGUREARGS="$(CFARGS)"
- touch build-arch-stamp
-
-build-indep: build-indep-stamp
-build-indep-stamp: $(DPATCH_STAMPFN)
- dh_testdir
-
- # Add here command to compile/build the arch indep package.
- $(MAKE) documentation CONFIGUREARGS="$(CFARGS)"
- touch build-indep-stamp
-
-build: build-arch
-
-clean: clean-patched unpatch
- dh_clean
-
-clean-patched:
- dh_testdir
- dh_testroot
- rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp
-
- # Add here commands to clean up after the build process.
- $(MAKE) distclean
- rm -rf refdoc/modref refdoc/traditional_manual
-
-install: DH_OPTIONS=
-install: build-arch
- dh_testdir
- dh_testroot
- dh_clean -k
-
- $(MAKE) INSTALLARGS=--traditional \
- buildroot=$(TMP) \
- prefix=/usr \
- man_prefix=/usr/share/man \
- lib_prefix="$(lib_prefix)" \
- include_prefix="$(include_prefix)" \
- pike_name=/usr/bin/$(PIKE) \
- install_nodoc
-
-# Some cleaning
- find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';'
-
- install -d -m755 $(TMP)/usr/share/pixmaps
- install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm
- mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE)
- mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1
-
-# Fix permissions and shebang lines
- -for f in `find $(TMP)/usr/bin $(TMP)/usr/lib -type f`; do \
- if file $$f | grep -q "script"; then \
- chmod a+x $$f; \
- sed -ri -e 's@#!.*NOMODULE@#!/usr/bin/$(PIKE)@' \
- -e 's@#! */usr/local/bin/pike@#!/usr/bin/$(PIKE)@' \
- -e 's@#! */usr/bin/env.*pike@#!/usr/bin/$(PIKE)@' \
- $$f; \
- fi; \
- done
-
-# Don't install our own specs file - the ordinary one is not that bad really
-# sed -e 's/@PIKEVERSION@/$(VERSION)/g' \
- -e 's;@CONFIGURE_ARGS@;$(CFARGS);g' \
- debian/specs.in > $(TMP)$(include_prefix)/specs
-
-# Install pike-config
- sed -e "s#@CFLAGS@#-I$(include_prefix)#;s/@LDFLAGS@//" \
- -e "s/@MAJOR@/$(MAJOR)/;s/@MINOR@/$(MINOR)/;s/@BUILD@/$(BUILD)/" \
- debian/pike-config.in > $(TMP)/usr/bin/$(PIKE)-config
-
-# # pike -x module fix
- sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/dynamic_module_makefile;g' \
- $(TMP)$(include_prefix)/dynamic_module_makefile
-
-# Build architecture-independent files here.
-# Pass -i to all debhelper commands in this target to reduce clutter.
-binary-indep: build-indep
- dh_testdir -i
- dh_testroot -i
- # install the docs
- dh_install -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual
- dh_install -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference
- dh_install -i -N$(PIKE)-manual -N$(PIKE)-reference --sourcedir=$(TMP)
- dh_installdocs -i
- dh_installchangelogs -i -k CHANGES
- dh_link -i
- dh_compress -i
- dh_fixperms -i
- dh_installdeb -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-# Build architecture-dependent files here.
-binary-arch: build-arch install
- dh_testdir -a
- dh_testroot -a
-# dh_installdebconf -a
- dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE)
- dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY)
- for p in $(MODULE_PACKAGES) $(PIKE)-dev; do \
- dh_link -p$$p usr/share/doc/$(PIKE)-core usr/share/doc/$$p; \
- done
- dh_installdocs -a
- dh_installmenu -a
-# dh_installman -a
- dh_installchangelogs -a -k CHANGES
- dh_strip -a
- dh_compress -a
- dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite
- dh_installdeb -a
- dh_shlibdeps -a
- dh_gencontrol -a
- dh_md5sums -a
- dh_builddeb -a
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
/7.6.116-1/debian/rules
Property changes:
Deleted: svn:executable
## -1 +0,0 ##
-*
\ No newline at end of property
Index: 7.6.116-1/debian/pike7.6-reference.doc-base
===================================================================
--- 7.6.116-1/debian/pike7.6-reference.doc-base (revision 30)
+++ 7.6.116-1/debian/pike7.6-reference.doc-base (nonexistent)
@@ -1,10 +0,0 @@
-Document: pike7.6-refdoc
-Title: Pike 7.6 Reference
-Author: The Pike Authors
-Abstract: This document contains the full reference of all
- the Pike modules and functions.
-Section: Programming
-
-Format: HTML
-Index: /usr/share/doc/pike7.6-doc/html/reference/index.html
-Files: /usr/share/doc/pike7.6-doc/html/reference/*.html
Index: 7.6.116-1/debian/pike7.6-mysql.install
===================================================================
--- 7.6.116-1/debian/pike7.6-mysql.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-mysql.install (nonexistent)
@@ -1,6 +0,0 @@
-usr/lib/pike/*/include/mysql.h
-usr/lib/pike/*/7.4/include/mysql.h
-usr/lib/pike/*/modules/*Mysql.*
-usr/share/pike/*/modules/*Mysql.*
-usr/lib/pike/*/modules/Sql.pmod/mysql*
-usr/share/pike/*/modules/Sql.pmod/mysql*
Index: 7.6.116-1/debian/pike7.6-core.postrm
===================================================================
--- 7.6.116-1/debian/pike7.6-core.postrm (revision 30)
+++ 7.6.116-1/debian/pike7.6-core.postrm (nonexistent)
@@ -1,43 +0,0 @@
-#! /bin/sh
-# postrm script for #PACKAGE#
-#
-# see: dh_installdeb(1)
-
-set -e
-
-# summary of how this script can be called:
-# * <postrm> `remove'
-# * <postrm> `purge'
-# * <old-postrm> `upgrade' <new-version>
-# * <new-postrm> `failed-upgrade' <old-version>
-# * <new-postrm> `abort-install'
-# * <new-postrm> `abort-install' <old-version>
-# * <new-postrm> `abort-upgrade' <old-version>
-# * <disappearer's-postrm> `disappear' <r>overwrit>r> <new-version>
-# for details, see http://www.debian.org/doc/debian-policy/ or
-# the debian-policy package
-
-
-case "$1" in
- purge)
- for d in include/pike include/pike7.6 lib/pike/site_pike lib/pike lib/pike7.6/site_pike lib/pike7.6 share/pike/site_pike \
- share/pike share/pike7.6/site_pike share/pike7.6; do
- rmdir /usr/local/$d || true
- done
- ;;
-
- remove|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
- ;;
-
- *)
- echo "postrm called with unknown argument \`$1'" >&2
- exit 1
-
-esac
-
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
-exit 0
Index: 7.6.116-1/debian/pike7.6-pg.install
===================================================================
--- 7.6.116-1/debian/pike7.6-pg.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-pg.install (nonexistent)
@@ -1,6 +0,0 @@
-usr/lib/pike/*/include/postgres.h
-usr/lib/pike/*/7.4/include/postgres.h
-usr/lib/pike/*/modules/*Postgres.*
-usr/share/pike/*/modules/*Postgres.*
-usr/lib/pike/*/modules/Sql.pmod/postgres*
-usr/share/pike/*/modules/Sql.pmod/postgres*
Index: 7.6.116-1/debian/pike-config.in
===================================================================
--- 7.6.116-1/debian/pike-config.in (revision 30)
+++ 7.6.116-1/debian/pike-config.in (nonexistent)
@@ -1,36 +0,0 @@
-#!/bin/sh
-#
-# $Id: pike-config.in,v 1.1 2002/08/12 01:02:31 grendel Exp $
-#
-
-MY_CFLAGS="@CFLAGS@"
-MY_LDFLAGS="@LDFLAGS@"
-MY_VERSION="@MAJOR@.@MINOR@.@BUILD@"
-
-if test -z "$1"; then
- cat <<EOF
-Usage: pike-config [--cflags] [--ldflags] [--version]
-
- --cflags Print the compiler flags required to compile a module
- --ldflags Print the linker flags required to link a module
- --version Print the pike version for which the compilation is taking
- place
-
-EOF
- exit 1
-fi
-
-while true; do
- if test -z "$1"; then
- break
- fi
-
- case $1 in
- --cflags) echo -n "${MY_CFLAGS} " ;;
- --ldflags) echo -n "${MY_LDFLAGS} " ;;
- --version) echo -n "${MY_VERSION} " ;;
- esac
- shift
-done
-
-echo
Index: 7.6.116-1/debian/pike7.6-java.install
===================================================================
--- 7.6.116-1/debian/pike7.6-java.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-java.install (nonexistent)
@@ -1 +0,0 @@
-usr/lib/pike/*/modules/*Java.*
Index: 7.6.116-1/debian/copyright
===================================================================
--- 7.6.116-1/debian/copyright (revision 30)
+++ 7.6.116-1/debian/copyright (nonexistent)
@@ -1,529 +0,0 @@
-This package was debianized by Marek Habersack <grendel@debian.org> on
-Sun, 5 May 2002 01:34:05 +0200.
-
-The current maintainer is Magnus Holmgren <holmgren@debian.org> with
-some help from Henrik Andreasson <pike@han.pp.se>.
-
-It was downloaded from http://pike.ida.liu.se/download/pub/pike/
-
-Copyright © 1994-1996 Fredrik Hübinette
-Copyright © 1996-1997 Informationsvävarna AB
-Copyright © 1997-2000 Idonex AB
-Copyright © 2000-2002 Roxen Internet Software AB
-Copyright © 2002-2007 Department of Computer and Information Science,
- Linköping University
-
-Pike refers to the source code, and any executables
-created from the same source code. Parts of other
-copyrighted works are included in Pike, in accordance
-with their respective conditions for distribution.
-
-Doug Lea's Malloc
-Copyright © 1987-2005 Doug Lea
-
-Emacs font lock definitions
-Copyright © 2002 Martin Stjernholm
-
-IDEA encryption and decryption code
-Copyright © Xuejia Lai
-
-JPEG transform code
-Copyright © 1991-1998, Thomas G. Lane, Independent JPEG Group
-
-MD5 password hash code
-Copyright © Poul-Henning Kamp
-
-Regular expression matching code
-Copyright © 1986 by University of Toronto.
-
-TrueVision Targa code
-Copyright © 1997 Raphael FRANCOIS and Gordon Matzigkeit
-
-Unicode Character Database
-Copyright © 1991-2004 Unicode, Inc.
-
-Zlib detection and verification code
-Copyright © 1995-1998 Jean-loup Gailly and Mark Adler
-
-License:
-
-The Pike source is distributed under GPL (GNU General Public License 2), LGPL
-(GNU Lesser General Public License 2.1) and MPL (Mozilla Public License 1.1).
-
-On Debian GNU/Linux systems, the complete text of the GNU General
-Public License can be found in `/usr/share/common-licenses/GPL'.
-
-On Debian GNU/Linux systems, the complete text of the GNU Lesser General
-Public License can be found in `/usr/share/common-licenses/LGPL'.
-
-The full text of the Mozilla Public License 1.1 follows.
-
- MOZILLA PUBLIC LICENSE
- Version 1.1
-
- ---------------
-
-1. Definitions.
-
- 1.0.1. "Commercial Use" means distribution or otherwise making the
- Covered Code available to a third party.
-
- 1.1. "Contributor" means each entity that creates or contributes to
- the creation of Modifications.
-
- 1.2. "Contributor Version" means the combination of the Original
- Code, prior Modifications used by a Contributor, and the Modifications
- made by that particular Contributor.
-
- 1.3. "Covered Code" means the Original Code or Modifications or the
- combination of the Original Code and Modifications, in each case
- including portions thereof.
-
- 1.4. "Electronic Distribution Mechanism" means a mechanism generally
- accepted in the software development community for the electronic
- transfer of data.
-
- 1.5. "Executable" means Covered Code in any form other than Source
- Code.
-
- 1.6. "Initial Developer" means the individual or entity identified
- as the Initial Developer in the Source Code notice required by Exhibit
- A.
-
- 1.7. "Larger Work" means a work which combines Covered Code or
- portions thereof with code not governed by the terms of this License.
-
- 1.8. "License" means this document.
-
- 1.8.1. "Licensable" means having the right to grant, to the maximum
- extent possible, whether at the time of the initial grant or
- subsequently acquired, any and all of the rights conveyed herein.
-
- 1.9. "Modifications" means any addition to or deletion from the
- substance or structure of either the Original Code or any previous
- Modifications. When Covered Code is released as a series of files, a
- Modification is:
- A. Any addition to or deletion from the contents of a file
- containing Original Code or previous Modifications.
-
- B. Any new file that contains any part of the Original Code or
- previous Modifications.
-
- 1.10. "Original Code" means Source Code of computer software code
- which is described in the Source Code notice required by Exhibit A as
- Original Code, and which, at the time of its release under this
- License is not already Covered Code governed by this License.
-
- 1.10.1. "Patent Claims" means any patent claim(s), now owned or
- hereafter acquired, including without limitation, method, process,
- and apparatus claims, in any patent Licensable by grantor.
-
- 1.11. "Source Code" means the preferred form of the Covered Code for
- making modifications to it, including all modules it contains, plus
- any associated interface definition files, scripts used to control
- compilation and installation of an Executable, or source code
- differential comparisons against either the Original Code or another
- well known, available Covered Code of the Contributor's choice. The
- Source Code can be in a compressed or archival form, provided the
- appropriate decompression or de-archiving software is widely available
- for no charge.
-
- 1.12. "You" (or "Your") means an individual or a legal entity
- exercising rights under, and complying with all of the terms of, this
- License or a future version of this License issued under Section 6.1.
- For legal entities, "You" includes any entity which controls, is
- controlled by, or is under common control with You. For purposes of
- this definition, "control" means (a) the power, direct or indirect,
- to cause the direction or management of such entity, whether by
- contract or otherwise, or (b) ownership of more than fifty percent
- (50%) of the outstanding shares or beneficial ownership of such
- entity.
-
-2. Source Code License.
-
- 2.1. The Initial Developer Grant.
- The Initial Developer hereby grants You a world-wide, royalty-free,
- non-exclusive license, subject to third party intellectual property
- claims:
- (a) under intellectual property rights (other than patent or
- trademark) Licensable by Initial Developer to use, reproduce,
- modify, display, perform, sublicense and distribute the Original
- Code (or portions thereof) with or without Modifications, and/or
- as part of a Larger Work; and
-
- (b) under Patents Claims infringed by the making, using or
- selling of Original Code, to make, have made, use, practice,
- sell, and offer for sale, and/or otherwise dispose of the
- Original Code (or portions thereof).
-
- (c) the licenses granted in this Section 2.1(a) and (b) are
- effective on the date Initial Developer first distributes
- Original Code under the terms of this License.
-
- (d) Notwithstanding Section 2.1(b) above, no patent license is
- granted: 1) for code that You delete from the Original Code; 2)
- separate from the Original Code; or 3) for infringements caused
- by: i) the modification of the Original Code or ii) the
- combination of the Original Code with other software or devices.
-
- 2.2. Contributor Grant.
- Subject to third party intellectual property claims, each Contributor
- hereby grants You a world-wide, royalty-free, non-exclusive license
-
- (a) under intellectual property rights (other than patent or
- trademark) Licensable by Contributor, to use, reproduce, modify,
- display, perform, sublicense and distribute the Modifications
- created by such Contributor (or portions thereof) either on an
- unmodified basis, with other Modifications, as Covered Code
- and/or as part of a Larger Work; and
-
- (b) under Patent Claims infringed by the making, using, or
- selling of Modifications made by that Contributor either alone
- and/or in combination with its Contributor Version (or portions
- of such combination), to make, use, sell, offer for sale, have
- made, and/or otherwise dispose of: 1) Modifications made by that
- Contributor (or portions thereof); and 2) the combination of
- Modifications made by that Contributor with its Contributor
- Version (or portions of such combination).
-
- (c) the licenses granted in Sections 2.2(a) and 2.2(b) are
- effective on the date Contributor first makes Commercial Use of
- the Covered Code.
-
- (d) Notwithstanding Section 2.2(b) above, no patent license is
- granted: 1) for any code that Contributor has deleted from the
- Contributor Version; 2) separate from the Contributor Version;
- 3) for infringements caused by: i) third party modifications of
- Contributor Version or ii) the combination of Modifications made
- by that Contributor with other software (except as part of the
- Contributor Version) or other devices; or 4) under Patent Claims
- infringed by Covered Code in the absence of Modifications made by
- that Contributor.
-
-3. Distribution Obligations.
-
- 3.1. Application of License.
- The Modifications which You create or to which You contribute are
- governed by the terms of this License, including without limitation
- Section 2.2. The Source Code version of Covered Code may be
- distributed only under the terms of this License or a future version
- of this License released under Section 6.1, and You must include a
- copy of this License with every copy of the Source Code You
- distribute. You may not offer or impose any terms on any Source Code
- version that alters or restricts the applicable version of this
- License or the recipients' rights hereunder. However, You may include
- an additional document offering the additional rights described in
- Section 3.5.
-
- 3.2. Availability of Source Code.
- Any Modification which You create or to which You contribute must be
- made available in Source Code form under the terms of this License
- either on the same media as an Executable version or via an accepted
- Electronic Distribution Mechanism to anyone to whom you made an
- Executable version available; and if made available via Electronic
- Distribution Mechanism, must remain available for at least twelve (12)
- months after the date it initially became available, or at least six
- (6) months after a subsequent version of that particular Modification
- has been made available to such recipients. You are responsible for
- ensuring that the Source Code version remains available even if the
- Electronic Distribution Mechanism is maintained by a third party.
-
- 3.3. Description of Modifications.
- You must cause all Covered Code to which You contribute to contain a
- file documenting the changes You made to create that Covered Code and
- the date of any change. You must include a prominent statement that
- the Modification is derived, directly or indirectly, from Original
- Code provided by the Initial Developer and including the name of the
- Initial Developer in (a) the Source Code, and (b) in any notice in an
- Executable version or related documentation in which You describe the
- origin or ownership of the Covered Code.
-
- 3.4. Intellectual Property Matters
- (a) Third Party Claims.
- If Contributor has knowledge that a license under a third party's
- intellectual property rights is required to exercise the rights
- granted by such Contributor under Sections 2.1 or 2.2,
- Contributor must include a text file with the Source Code
- distribution titled "LEGAL" which describes the claim and the
- party making the claim in sufficient detail that a recipient will
- know whom to contact. If Contributor obtains such knowledge after
- the Modification is made available as described in Section 3.2,
- Contributor shall promptly modify the LEGAL file in all copies
- Contributor makes available thereafter and shall take other steps
- (such as notifying appropriate mailing lists or newsgroups)
- reasonably calculated to inform those who received the Covered
- Code that new knowledge has been obtained.
-
- (b) Contributor APIs.
- If Contributor's Modifications include an application programming
- interface and Contributor has knowledge of patent licenses which
- are reasonably necessary to implement that API, Contributor must
- also include this information in the LEGAL file.
-
- (c) Representations.
- Contributor represents that, except as disclosed pursuant to
- Section 3.4(a) above, Contributor believes that Contributor's
- Modifications are Contributor's original creation(s) and/or
- Contributor has sufficient rights to grant the rights conveyed by
- this License.
-
- 3.5. Required Notices.
- You must duplicate the notice in Exhibit A in each file of the Source
- Code. If it is not possible to put such notice in a particular Source
- Code file due to its structure, then You must include such notice in a
- location (such as a relevant directory) where a user would be likely
- to look for such a notice. If You created one or more Modification(s)
- You may add your name as a Contributor to the notice described in
- Exhibit A. You must also duplicate this License in any documentation
- for the Source Code where You describe recipients' rights or ownership
- rights relating to Covered Code. You may choose to offer, and to
- charge a fee for, warranty, support, indemnity or liability
- obligations to one or more recipients of Covered Code. However, You
- may do so only on Your own behalf, and not on behalf of the Initial
- Developer or any Contributor. You must make it absolutely clear than
- any such warranty, support, indemnity or liability obligation is
- offered by You alone, and You hereby agree to indemnify the Initial
- Developer and every Contributor for any liability incurred by the
- Initial Developer or such Contributor as a result of warranty,
- support, indemnity or liability terms You offer.
-
- 3.6. Distribution of Executable Versions.
- You may distribute Covered Code in Executable form only if the
- requirements of Section 3.1-3.5 have been met for that Covered Code,
- and if You include a notice stating that the Source Code version of
- the Covered Code is available under the terms of this License,
- including a description of how and where You have fulfilled the
- obligations of Section 3.2. The notice must be conspicuously included
- in any notice in an Executable version, related documentation or
- collateral in which You describe recipients' rights relating to the
- Covered Code. You may distribute the Executable version of Covered
- Code or ownership rights under a license of Your choice, which may
- contain terms different from this License, provided that You are in
- compliance with the terms of this License and that the license for the
- Executable version does not attempt to limit or alter the recipient's
- rights in the Source Code version from the rights set forth in this
- License. If You distribute the Executable version under a different
- license You must make it absolutely clear that any terms which differ
- from this License are offered by You alone, not by the Initial
- Developer or any Contributor. You hereby agree to indemnify the
- Initial Developer and every Contributor for any liability incurred by
- the Initial Developer or such Contributor as a result of any such
- terms You offer.
-
- 3.7. Larger Works.
- You may create a Larger Work by combining Covered Code with other code
- not governed by the terms of this License and distribute the Larger
- Work as a single product. In such a case, You must make sure the
- requirements of this License are fulfilled for the Covered Code.
-
-4. Inability to Comply Due to Statute or Regulation.
-
- If it is impossible for You to comply with any of the terms of this
- License with respect to some or all of the Covered Code due to
- statute, judicial order, or regulation then You must: (a) comply with
- the terms of this License to the maximum extent possible; and (b)
- describe the limitations and the code they affect. Such description
- must be included in the LEGAL file described in Section 3.4 and must
- be included with all distributions of the Source Code. Except to the
- extent prohibited by statute or regulation, such description must be
- sufficiently detailed for a recipient of ordinary skill to be able to
- understand it.
-
-5. Application of this License.
-
- This License applies to code to which the Initial Developer has
- attached the notice in Exhibit A and to related Covered Code.
-
-6. Versions of the License.
-
- 6.1. New Versions.
- Netscape Communications Corporation ("Netscape") may publish revised
- and/or new versions of the License from time to time. Each version
- will be given a distinguishing version number.
-
- 6.2. Effect of New Versions.
- Once Covered Code has been published under a particular version of the
- License, You may always continue to use it under the terms of that
- version. You may also choose to use such Covered Code under the terms
- of any subsequent version of the License published by Netscape. No one
- other than Netscape has the right to modify the terms applicable to
- Covered Code created under this License.
-
- 6.3. Derivative Works.
- If You create or use a modified version of this License (which you may
- only do in order to apply it to code which is not already Covered Code
- governed by this License), You must (a) rename Your license so that
- the phrases "Mozilla", "MOZILLAPL", "MOZPL", "Netscape",
- "MPL", "NPL" or any confusingly similar phrase do not appear in your
- license (except to note that your license differs from this License)
- and (b) otherwise make it clear that Your version of the license
- contains terms which differ from the Mozilla Public License and
- Netscape Public License. (Filling in the name of the Initial
- Developer, Original Code or Contributor in the notice described in
- Exhibit A shall not of themselves be deemed to be modifications of
- this License.)
-
-7. DISCLAIMER OF WARRANTY.
-
- COVERED CODE IS PROVIDED UNDER THIS LICENSE ON AN "AS IS" BASIS,
- WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING,
- WITHOUT LIMITATION, WARRANTIES THAT THE COVERED CODE IS FREE OF
- DEFECTS, MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE OR NON-INFRINGING.
- THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE COVERED CODE
- IS WITH YOU. SHOULD ANY COVERED CODE PROVE DEFECTIVE IN ANY RESPECT,
- YOU (NOT THE INITIAL DEVELOPER OR ANY OTHER CONTRIBUTOR) ASSUME THE
- COST OF ANY NECESSARY SERVICING, REPAIR OR CORRECTION. THIS DISCLAIMER
- OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO USE OF
- ANY COVERED CODE IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER.
-
-8. TERMINATION.
-
- 8.1. This License and the rights granted hereunder will terminate
- automatically if You fail to comply with terms herein and fail to cure
- such breach within 30 days of becoming aware of the breach. All
- sublicenses to the Covered Code which are properly granted shall
- survive any termination of this License. Provisions which, by their
- nature, must remain in effect beyond the termination of this License
- shall survive.
-
- 8.2. If You initiate litigation by asserting a patent infringement
- claim (excluding declatory judgment actions) against Initial Developer
- or a Contributor (the Initial Developer or Contributor against whom
- You file such action is referred to as "Participant") alleging that:
-
- (a) such Participant's Contributor Version directly or indirectly
- infringes any patent, then any and all rights granted by such
- Participant to You under Sections 2.1 and/or 2.2 of this License
- shall, upon 60 days notice from Participant terminate prospectively,
- unless if within 60 days after receipt of notice You either: (i)
- agree in writing to pay Participant a mutually agreeable reasonable
- royalty for Your past and future use of Modifications made by such
- Participant, or (ii) withdraw Your litigation claim with respect to
- the Contributor Version against such Participant. If within 60 days
- of notice, a reasonable royalty and payment arrangement are not
- mutually agreed upon in writing by the parties or the litigation claim
- is not withdrawn, the rights granted by Participant to You under
- Sections 2.1 and/or 2.2 automatically terminate at the expiration of
- the 60 day notice period specified above.
-
- (b) any software, hardware, or device, other than such Participant's
- Contributor Version, directly or indirectly infringes any patent, then
- any rights granted to You by such Participant under Sections 2.1(b)
- and 2.2(b) are revoked effective as of the date You first made, used,
- sold, distributed, or had made, Modifications made by that
- Participant.
-
- 8.3. If You assert a patent infringement claim against Participant
- alleging that such Participant's Contributor Version directly or
- indirectly infringes any patent where such claim is resolved (such as
- by license or settlement) prior to the initiation of patent
- infringement litigation, then the reasonable value of the licenses
- granted by such Participant under Sections 2.1 or 2.2 shall be taken
- into account in determining the amount or value of any payment or
- license.
-
- 8.4. In the event of termination under Sections 8.1 or 8.2 above,
- all end user license agreements (excluding distributors and resellers)
- which have been validly granted by You or any distributor hereunder
- prior to termination shall survive termination.
-
-9. LIMITATION OF LIABILITY.
-
- UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER TORT
- (INCLUDING NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL YOU, THE INITIAL
- DEVELOPER, ANY OTHER CONTRIBUTOR, OR ANY DISTRIBUTOR OF COVERED CODE,
- OR ANY SUPPLIER OF ANY OF SUCH PARTIES, BE LIABLE TO ANY PERSON FOR
- ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY
- CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL,
- WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER
- COMMERCIAL DAMAGES OR LOSSES, EVEN IF SUCH PARTY SHALL HAVE BEEN
- INFORMED OF THE POSSIBILITY OF SUCH DAMAGES. THIS LIMITATION OF
- LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY
- RESULTING FROM SUCH PARTY'S NEGLIGENCE TO THE EXTENT APPLICABLE LAW
- PROHIBITS SUCH LIMITATION. SOME JURISDICTIONS DO NOT ALLOW THE
- EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO
- THIS EXCLUSION AND LIMITATION MAY NOT APPLY TO YOU.
-
-10. U.S. GOVERNMENT END USERS.
-
- The Covered Code is a "commercial item," as that term is defined in
- 48 C.F.R. 2.101 (Oct. 1995), consisting of "commercial computer
- software" and "commercial computer software documentation," as such
- terms are used in 48 C.F.R. 12.212 (Sept. 1995). Consistent with 48
- C.F.R. 12.212 and 48 C.F.R. 227.7202-1 through 227.7202-4 (June 1995),
- all U.S. Government End Users acquire Covered Code with only those
- rights set forth herein.
-
-11. MISCELLANEOUS.
-
- This License represents the complete agreement concerning subject
- matter hereof. If any provision of this License is held to be
- unenforceable, such provision shall be reformed only to the extent
- necessary to make it enforceable. This License shall be governed by
- California law provisions (except to the extent applicable law, if
- any, provides otherwise), excluding its conflict-of-law provisions.
- With respect to disputes in which at least one party is a citizen of,
- or an entity chartered or registered to do business in the United
- States of America, any litigation relating to this License shall be
- subject to the jurisdiction of the Federal Courts of the Northern
- District of California, with venue lying in Santa Clara County,
- California, with the losing party responsible for costs, including
- without limitation, court costs and reasonable attorneys' fees and
- expenses. The application of the United Nations Convention on
- Contracts for the International Sale of Goods is expressly excluded.
- Any law or regulation which provides that the language of a contract
- shall be construed against the drafter shall not apply to this
- License.
-
-12. RESPONSIBILITY FOR CLAIMS.
-
- As between Initial Developer and the Contributors, each party is
- responsible for claims and damages arising, directly or indirectly,
- out of its utilization of rights under this License and You agree to
- work with Initial Developer and Contributors to distribute such
- responsibility on an equitable basis. Nothing herein is intended or
- shall be deemed to constitute any admission of liability.
-
-13. MULTIPLE-LICENSED CODE.
-
- Initial Developer may designate portions of the Covered Code as
- "Multiple-Licensed". "Multiple-Licensed" means that the Initial
- Developer permits you to utilize portions of the Covered Code under
- Your choice of the NPL or the alternative licenses, if any, specified
- by the Initial Developer in the file described in Exhibit A.
-
-EXHIBIT A -Mozilla Public License.
-
- ``The contents of this file are subject to the Mozilla Public License
- Version 1.1 (the "License"); you may not use this file except in
- compliance with the License. You may obtain a copy of the License at
- http://www.mozilla.org/MPL/
-
- Software distributed under the License is distributed on an "AS IS"
- basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See the
- License for the specific language governing rights and limitations
- under the License.
-
- The Original Code is ______________________________________.
-
- The Initial Developer of the Original Code is ________________________.
- Portions created by ______________________ are Copyright (C) ______
- _______________________. All Rights Reserved.
-
- Contributor(s): ______________________________________.
-
- Alternatively, the contents of this file may be used under the terms
- of the _____ license (the "[___] License"), in which case the
- provisions of [______] License are applicable instead of those
- above. If you wish to allow use of your version of this file only
- under the terms of the [____] License and not to allow others to use
- your version of this file under the MPL, indicate your decision by
- deleting the provisions above and replace them with the notice and
- other provisions required by the [___] License. If you do not delete
- the provisions above, a recipient may use your version of this file
- under either the MPL or the [___] License."
-
- [NOTE: The text of this Exhibit A may differ slightly from the text of
- the notices in the Source Code files of the Original Code. You should
- use the text of this Exhibit A rather than the text found in the
- Original Code Source Code for Your Modifications.]
Index: 7.6.116-1/debian/pike7.6-image.install
===================================================================
--- 7.6.116-1/debian/pike7.6-image.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-image.install (nonexistent)
@@ -1,6 +0,0 @@
-usr/lib/pike/*/modules/Image.so
-usr/lib/pike/*/modules/*Image_[!S]*.so
-usr/lib/pike/*/modules/*Image*.pmod
-usr/share/pike/*/modules/*Image*.pmod*
-usr/share/pike/*/modules/_Image.pmod
-usr/lib/pike/*/modules/_Image.pmod
Index: 7.6.116-1/debian/pike7.6-sdl.install
===================================================================
--- 7.6.116-1/debian/pike7.6-sdl.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-sdl.install (nonexistent)
@@ -1,2 +0,0 @@
-usr/lib/pike/*/modules/*SDL.*
-usr/share/pike/*/modules/*SDL.*
Index: 7.6.116-1/debian/pike7.6-manual.doc-base
===================================================================
--- 7.6.116-1/debian/pike7.6-manual.doc-base (revision 30)
+++ 7.6.116-1/debian/pike7.6-manual.doc-base (nonexistent)
@@ -1,10 +0,0 @@
-Document: pike7.6-manual
-Title: Pike 7.6 Manual
-Author: The Pike Authors
-Abstract: This manual describes the Pike 7.6 language and contains
- a short tutorial on the language.
-Section: Programming
-
-Format: HTML
-Index: /usr/share/doc/pike7.6-doc/html/manual/index.html
-Files: /usr/share/doc/pike7.6-doc/html/manual/*.html
Index: 7.6.116-1/debian/pike7.6-gtk.install
===================================================================
--- 7.6.116-1/debian/pike7.6-gtk.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-gtk.install (nonexistent)
@@ -1,8 +0,0 @@
-usr/lib/pike/*/modules/GDK*
-usr/lib/pike/*/modules/Gnome*
-usr/lib/pike/*/modules/GTKSupport.pmod
-usr/lib/pike/*/modules/*GTK*
-usr/share/pike/*/modules/GDK*
-usr/share/pike/*/modules/Gnome*
-usr/share/pike/*/modules/GTKSupport.pmod
-usr/share/pike/*/modules/*GTK*
Index: 7.6.116-1/debian/README.Debian
===================================================================
--- 7.6.116-1/debian/README.Debian (revision 30)
+++ 7.6.116-1/debian/README.Debian (nonexistent)
@@ -1,61 +0,0 @@
-Missing modules
----------------
-
-The following modules are not included in the Debian Pike packages for
-various reasons, even if they are included in the module reference
-(pike7.6-reference):
-
- - DVB: Doesn't work with Linux 2.6 (and certainly not with other OSes).
- - _Ffmpeg: formerly missing from Debian due to patent issues. Might be
- included in the next release.
- - Gnome, GTK, GDK: Uses obsolete GTK version (1.2).
- - Math.Transforms.FFT: Few use cases in Pike, pulls in unnecessary
- dependencies.
- - Mird: Old, unmaintained, largely unknown library.
- - Msql: Obsolete, proprietary DBM.
- - PDF: Uses unmaintained libraries unavailable in Debian.
- - Ssleay: Obsolete.
- - Oracle: Proprietary DBM (so far ...).
- - Java: Links with the JVM library in a non-policy compliant
- way. Work needed.
- - Image.TTF: Uses obsolete library (freetype1).
-
-Places to visit
----------------
- - http://pike.ida.liu.se/ - the main Pike site
- - http://community.roxen.com - community site for users of the
- Roxen webserver and the Pike bugs database, information etc.
- - http://caudium.net/ - website of the Caudium WebServer which is
- written in Pike
- - http://www.roxen.com/ - website of the Roxen IS, the company which
- for a long time developed and maintained Pike as well as the Roxen
- WebServer mentioned above.
-
-Notes for developers
---------------------
-
-The postinst script created a few directories in /usr/local which you can
-use for your modules/include files. Once created by the postinst script
-they will never be touched by any pike package again. The directories
-are:
-
-/usr/local/include/pike
-/usr/local/include/pike7.6
-
-/usr/local/lib/pike/site_pike
-/usr/local/lib/pike7.6/site_pike
-
-/usr/local/share/pike/site_pike
-/usr/local/share/pike7.6/site_pike
-
-Note: I have come to the conclusion that this structure isn't awfully
-well though through. It is likely to change, but probably not until
-Pike 7.8. What's missing is a working infrastructure for building and
-installing third-pary modules and applications so that they won't have
-to be rebuilt for each new Pike revision, similarly to Perl and/or
-Python. Stay tuned.
-
-----
-$Id$
-
- -- Magnus Holmgren <magnus@kibibyte.se>, Fri, 21 Dec 2007 09:43:18 +0100
/7.6.116-1/debian/README.Debian
Property changes:
Deleted: svn:keywords
## -1 +0,0 ##
-Id
\ No newline at end of property
Index: 7.6.116-1/debian/pike7.6-pcre.install
===================================================================
--- 7.6.116-1/debian/pike7.6-pcre.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-pcre.install (nonexistent)
@@ -1,2 +0,0 @@
-usr/lib/pike/*/modules/*Regexp_PCRE.*
-usr/share/pike/*/modules/*Regexp_PCRE.*
Index: 7.6.116-1/debian/control
===================================================================
--- 7.6.116-1/debian/control (revision 30)
+++ 7.6.116-1/debian/control (nonexistent)
@@ -1,237 +0,0 @@
-Source: pike7.6
-Section: interpreters
-Priority: optional
-Maintainer: Magnus Holmgren <holmgren@debian.org>
-Uploaders: Henrik Andreasson <pike@han.pp.se>
-Standards-Version: 3.7.3
-Build-Depends: debhelper (>> 4.0.0), dpatch, bison, sharutils, bc,
- libgmp3-dev, libnettle-dev (>= 1.14),
- zlib1g-dev | libz-dev, libbz2-dev, libreadline5-dev,
- libgdbm-dev, libiodbc2-dev, libmysqlclient15-dev, libpq-dev,
- libperl-dev, libpcre3-dev, libxml2-dev,
- libsdl-mixer1.2-dev, libsdl1.2-dev, libsane-dev,
- x11proto-gl-dev, libxpm-dev, libglade2-dev, libfreetype6-dev,
- freeglut3-dev, libjpeg-dev, libtiff4-dev, librsvg2-dev (>= 2.7), libpng12-dev
-Build-Conflicts: libutahglx-dev
-Homepage: http://pike.ida.liu.se/
-Vcs-Svn: svn://svn.kibibyte.se/pike/branches/7.6
-Vcs-Browser: http://svn.kibibyte.se/pike
-
-Package: pike7.6-core
-Architecture: any
-Depends: ${shlibs:Depends}
-Suggests: pike7.6-doc
-Recommends: pike7.6-image (= ${binary:Version})
-Description: Powerful interpreted programming language
- Pike is an interpreted, object-oriented, dynamic programming language
- with a syntax similar to C. It includes many powerful data types and
- a module system that, for instance, provides image manipulation together,
- with support for graphics formats like SVG, JPG, PNG, GIF, XCF and many
- others, database connectivity, advanced cryptography, XML/HTML parsers
- and others. To learn more about pike, please visit http://pike.ida.liu.se/
- Note that some of the Pike features are found in other pike7.6-* packages
- (image processing, MySQL, PostgreSQL, sane and more).
-
-Package: pike7.6
-Architecture: all
-Depends: pike7.6-core (>= ${source:Version}), pike7.6-image (>= ${source:Version}), pike7.6-gdbm (>= ${source:Version})
-Recommends: pike7.6-doc (>= ${source:Version})
-Suggests: pike7.6-mysql (>= ${source:Version}), pike7.6-pg (>= ${source:Version}), pike7.6-dev (>= ${source:Version})
-Description: Recommended meta package for Pike 7.6
- This is a meta package which depends upon several other Pike
- packages that together make up the recommended Pike installation.
- If you want to install every packaged component of the Pike
- distribution, please install the pike7.6-meta package.
- .
- If you want to remove several components this package depends
- upon, you can purge this package without worrying about the
- functionality loss in Pike and then remove the packages you
- don't need on your system.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-dev
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (>= ${source:Version})
-Description: Development files for Pike 7.6
- This package contains files you will need to develop C extension
- modules for Pike. The package depends on the recommended set of
- packages for the Pike environment.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-manual
-Architecture: all
-Section: doc
-Description: Pike 7.6 manual
- The Pike manual auto-generated from the sources.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-reference
-Architecture: all
-Section: doc
-Description: Pike 7.6 reference
- The Pike reference auto-generated from the sources.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-doc
-Architecture: all
-Section: doc
-Depends: pike7.6-manual (>= ${source:Version}), pike7.6-reference (>= ${source:Version})
-Description: Pike 7.6 documentation meta package
- This package depends upon all the Pike 7.6 documentation
- packages. Note that the download and installation sizes might be very
- large.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-meta
-Architecture: all
-Depends: pike7.6 (>= ${source:Version}), pike7.6-mysql (>= ${source:Version}), pike7.6-pg (>= ${source:Version}), pike7.6-odbc (>= ${source:Version}), pike7.6-image (>= ${source:Version}), pike7.6-sdl (>= ${source:Version}), pike7.6-gdbm (>= ${source:Version}), pike7.6-gl (>= ${source:Version}), pike7.6-sane (>= ${source:Version}), pike7.6-doc (>= ${source:Version}), pike7.6-dev (>= ${source:Version}), pike7.6-perl (>= ${source:Version}), pike7.6-svg (>= ${source:Version}), pike7.6-pcre (>= ${source:Version}), pike7.6-bzip2 (>= ${source:Version})
-Description: Meta package for Pike 7.6
- This package depends on all the components that make up the Pike
- language distribution. It will pull in a LOT of packages the
- Pike components depend upon (including XFree libraries, GTK+, GNOME)!
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-mysql
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (= ${binary:Version})
-Description: MySQL module for Pike
- This Pike module provides access to MySQL databases.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-pg
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (= ${binary:Version})
-Description: PostgreSQL module for Pike
- This Pike module provides access to PostgreSQL databases.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-odbc
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (= ${binary:Version})
-Description: Odbc module for Pike
- This Pike module provides glue to the iOdbc interface.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-svg
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (= ${binary:Version})
-Suggests: pike7.6-image (= ${binary:Version})
-Description: SVG format support for Pike
- This module provides an SVG graphics format module. It has
- been separated from the pike7.6-image module because of its
- quite extensive dependencies.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-image
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (= ${binary:Version})
-Suggests: pike7.6-svg (= ${binary:Version})
-Description: Image module for Pike
- This module provides many powerful image processing functions to
- Pike programs.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-sdl
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (= ${binary:Version})
-Description: SDL module for Pike
- This module provides the Pike interface to the SDL library.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-gdbm
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (= ${binary:Version})
-Description: Gdbm module for Pike
- This Pike module provides access to gdbm databases.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-gl
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (= ${binary:Version})
-Description: Mesa module for Pike
- This Pike module provides access to the Mesa 3D graphics library.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-sane
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (= ${binary:Version})
-Description: SANE module for Pike
- This Pike module provides access to SANE.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-perl
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (= ${binary:Version})
-Description: Perl module for Pike
- This Pike module enables one to embed perl in pike programs.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-pcre
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (= ${binary:Version})
-Description: PCRE module for Pike
- This Pike module enables one to use the PCRE (Perl regular
- expressions) from within Pike programs.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
-
-Package: pike7.6-bzip2
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (= ${binary:Version})
-Description: Bzip2 module for Pike
- This Pike module enables one to use the Bzip2 compression
- algorithm from within Pike programs.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
Index: 7.6.116-1/debian/pike7.6-svg.install
===================================================================
--- 7.6.116-1/debian/pike7.6-svg.install (revision 30)
+++ 7.6.116-1/debian/pike7.6-svg.install (nonexistent)
@@ -1 +0,0 @@
-usr/lib/pike/*/modules/*Image_SVG.so
Index: 7.6.116-1/debian/control.disabled
===================================================================
--- 7.6.116-1/debian/control.disabled (revision 30)
+++ 7.6.116-1/debian/control.disabled (nonexistent)
@@ -1,24 +0,0 @@
-Package: pike7.6-gtk
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (=${Source-Version})
-Description: GTK module for Pike
- This Pike module provides access to the GTK+ library.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
- .
- http://pike.ida.liu.se/
-
-Package: pike7.6-java
-Architecture: any
-Depends: ${shlibs:Depends}, pike7.6-core (= ${binary:Version})
-Description: Java module for Pike
- This Pike module enables one to call Java code from Pike programs.
- .
- Pike is an interpreted programming language, for more information
- see the description of the pike7.6-core package or visit the URL
- below.
- .
- http://pike.ida.liu.se/
-
Index: 7.6.116-1/debian
===================================================================
--- 7.6.116-1/debian (revision 30)
+++ 7.6.116-1/debian (nonexistent)
/7.6.116-1/debian
Property changes:
Deleted: mergeWithUpstream
## -1 +0,0 ##
-1
\ No newline at end of property