Subversion Repositories pike-old

Compare Revisions

Ignore whitespace Rev 2 → Rev 3

/trunk/debian/patches/01_master.in.dpatch
1,18 → 1,17
#! /bin/sh /usr/share/dpatch/dpatch-run
## 01_master.in.dpatch by <magnus@proffe.kibibyte.se>
## 01_master.in.dpatch by <magnus@kibibyte.se>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Add local site-pike directories to master.pike.in
 
@DPATCH@
 
diff -U3 -Narp pike7.6-7.6.24/lib/master.pike.in pike7.6-7.6.24.new/lib/master.pike.in
--- pike7.6-7.6.24/lib/master.pike.in 2004-07-23 14:17:24 +0200
+++ pike7.6-7.6.24.new/lib/master.pike.in 2005-01-06 23:27:54 +0100
@@ -565,6 +565,14 @@ string normalize_path( string path )
#else
return replace(path,"\\","/");
diff -urNad trunk~/lib/master.pike.in trunk/lib/master.pike.in
--- trunk~/lib/master.pike.in 2007-01-01 01:28:04.000000000 +0100
+++ trunk/lib/master.pike.in 2007-09-26 09:26:21.000000000 +0200
@@ -1115,6 +1115,14 @@
include_prefix = "¤include_prefix¤";
#endif
system_module_path=pike_module_path;
+
+ // Debian paths
+ add_include_path("/usr/local/include/pike");
23,4 → 22,4
+ add_module_path("/usr/local/share/pike"+__REAL_MAJOR__+"."+__REAL_MINOR__+"/site_pike");
}
//! Mapping containing the cache of currently compiled files.