Subversion Repositories pike-old

Compare Revisions

Ignore whitespace Rev 40 → Rev 41

/trunk/debian/patches/02_smartlink_rpath.dpatch
1,5 → 1,5
#! /bin/sh /usr/share/dpatch/dpatch-run
## 02_smartlink_rpath.dpatch by <magnus@proffe.kibibyte.se>
## 02_smartlink_rpath.dpatch
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Make smartlink not use -rpath
6,9 → 6,9
 
@DPATCH@
 
--- pike7.3-7.3.51.orig/bin/smartlink
+++ pike7.3-7.3.51/bin/smartlink
@@ -147,9 +147,8 @@
--- 7.7.orig/bin/smartlink 2006-03-19 18:01:51.000000000 +0100
+++ 7.7/bin/smartlink 2006-08-09 02:07:32.940847999 +0200
@@ -162,9 +162,8 @@ if test x$# != x0 ; then
LDOPTS="$LDOPTS -R$RPATH"
;;
Linux\ 2.*)
20,9 → 20,9
;;
UnixWare\ 7.*)
if test x$LINKING != xno -a "x$RPATH" != x ; then
--- pike7.5-7.5.3/src/smartlink.c.orig 2003-01-17 20:13:38.000000000 +0100
+++ pike7.3-7.5.3/src/smartlink.c 2003-03-20 16:58:02.000000000 +0100
@@ -146,7 +146,7 @@
--- 7.7.orig/src/smartlink.c 2006-08-09 01:30:57.000000000 +0200
+++ 7.7/src/smartlink.c 2006-08-09 02:07:32.940847999 +0200
@@ -151,7 +151,7 @@ int main(int argc, char **argv)
full_rpath = rpath;
#ifdef USE_Wl
31,7 → 31,7
#elif defined(USE_Wl_R)
strcat(rpath, "-Wl,-R");
#elif defined(USE_R)
@@ -258,7 +258,7 @@
@@ -293,7 +293,7 @@ int main(int argc, char **argv)
}
rpath_in_use |= add_path(rpath, ld_lib_path);
}
40,7 → 40,7
if (rpath_in_use) {
/* Delete the terminating ':' */
rpath[strlen(rpath) - 1] = 0;
@@ -305,6 +305,7 @@
@@ -340,6 +340,7 @@ int main(int argc, char **argv)
#error Unknown method
#endif
}