Subversion Repositories pike-old

Compare Revisions

Ignore whitespace Rev 2 → Rev 3

/trunk/debian/patches/05_install.pike.dpatch
5,21 → 5,10
## DP: Allow include_prefix to be separately overridden in install.pike
 
@DPATCH@
 
--- 7.6/bin/install.pike 2005-12-30 14:33:48.450200000 +0100
+++ 7.6.fix/bin/install.pike 2005-12-30 15:14:24.806462750 +0100
@@ -1197,7 +1197,7 @@ int pre_install(array(string) argv)
exec_prefix=combine_path(prefix,"bin");
lib_prefix=combine_path(prefix,"lib");
doc_prefix=combine_path(prefix,"doc");
- include_prefix=combine_path(prefix,"include","pike");
+ include_prefix=vars->include_prefix||combine_path(prefix,"include","pike");
man_prefix=combine_path(prefix,"man");
if (export) {
low_install_file(combine_path(vars->TMP_BINDIR,"install.pike"),
--- 7.6.orig/src/Makefile.in 2005-07-28 01:19:28.618585000 +0200
+++ 7.6/src/Makefile.in 2005-08-16 12:53:13.127535720 +0200
@@ -53,7 +53,7 @@ man_prefix = $(prefix)/man
diff -urNad trunk~/src/Makefile.in trunk/src/Makefile.in
--- trunk~/src/Makefile.in 2006-10-20 15:40:28.000000000 +0200
+++ trunk/src/Makefile.in 2007-09-26 09:51:13.000000000 +0200
@@ -53,7 +53,7 @@
# TESTARGS = -F -a
# Arguments for install.pike used by the install targets.
28,7 → 17,7
#
# use bison please, yacc isn't good enough.
@@ -495,7 +495,7 @@ install: pike tools
@@ -506,7 +506,7 @@
MANDIR_SRC="$(MANDIR_SRC)" \
man_prefix="$(man_prefix)" pike_name=$(pike_name) \
fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \