Subversion Repositories pike-old

Compare Revisions

Ignore whitespace Rev 2 → Rev 3

/trunk/debian/patches/01_master.in.dpatch
1,18 → 1,17
#! /bin/sh /usr/share/dpatch/dpatch-run
## 01_master.in.dpatch by <magnus@proffe.kibibyte.se>
## 01_master.in.dpatch by <magnus@kibibyte.se>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Add local site-pike directories to master.pike.in
 
@DPATCH@
 
diff -U3 -Narp pike7.6-7.6.24/lib/master.pike.in pike7.6-7.6.24.new/lib/master.pike.in
--- pike7.6-7.6.24/lib/master.pike.in 2004-07-23 14:17:24 +0200
+++ pike7.6-7.6.24.new/lib/master.pike.in 2005-01-06 23:27:54 +0100
@@ -565,6 +565,14 @@ string normalize_path( string path )
#else
return replace(path,"\\","/");
diff -urNad trunk~/lib/master.pike.in trunk/lib/master.pike.in
--- trunk~/lib/master.pike.in 2007-01-01 01:28:04.000000000 +0100
+++ trunk/lib/master.pike.in 2007-09-26 09:26:21.000000000 +0200
@@ -1115,6 +1115,14 @@
include_prefix = "¤include_prefix¤";
#endif
system_module_path=pike_module_path;
+
+ // Debian paths
+ add_include_path("/usr/local/include/pike");
23,4 → 22,4
+ add_module_path("/usr/local/share/pike"+__REAL_MAJOR__+"."+__REAL_MINOR__+"/site_pike");
}
//! Mapping containing the cache of currently compiled files.
/trunk/debian/patches/05_install.pike.dpatch
5,21 → 5,10
## DP: Allow include_prefix to be separately overridden in install.pike
 
@DPATCH@
 
--- 7.6/bin/install.pike 2005-12-30 14:33:48.450200000 +0100
+++ 7.6.fix/bin/install.pike 2005-12-30 15:14:24.806462750 +0100
@@ -1197,7 +1197,7 @@ int pre_install(array(string) argv)
exec_prefix=combine_path(prefix,"bin");
lib_prefix=combine_path(prefix,"lib");
doc_prefix=combine_path(prefix,"doc");
- include_prefix=combine_path(prefix,"include","pike");
+ include_prefix=vars->include_prefix||combine_path(prefix,"include","pike");
man_prefix=combine_path(prefix,"man");
if (export) {
low_install_file(combine_path(vars->TMP_BINDIR,"install.pike"),
--- 7.6.orig/src/Makefile.in 2005-07-28 01:19:28.618585000 +0200
+++ 7.6/src/Makefile.in 2005-08-16 12:53:13.127535720 +0200
@@ -53,7 +53,7 @@ man_prefix = $(prefix)/man
diff -urNad trunk~/src/Makefile.in trunk/src/Makefile.in
--- trunk~/src/Makefile.in 2006-10-20 15:40:28.000000000 +0200
+++ trunk/src/Makefile.in 2007-09-26 09:51:13.000000000 +0200
@@ -53,7 +53,7 @@
# TESTARGS = -F -a
# Arguments for install.pike used by the install targets.
28,7 → 17,7
#
# use bison please, yacc isn't good enough.
@@ -495,7 +495,7 @@ install: pike tools
@@ -506,7 +506,7 @@
MANDIR_SRC="$(MANDIR_SRC)" \
man_prefix="$(man_prefix)" pike_name=$(pike_name) \
fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \
/trunk/debian/patches/10_misplaced_MAXPATHLEN.dpatch
0,0 → 1,31
#!/bin/sh /usr/share/dpatch/dpatch-run
## 10_misplaced_MAXPATHLEN.dpatch by Samuel Thibault <samuel.thibault@ens-lyon.org>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Move reserve MAXPATHLEN definition up.
 
@DPATCH@
 
--- pike7.6-7.6.112.orig/src/modules/files/efuns.c 2007-07-24 23:08:26.932458000 +0000
+++ pike7.6-7.6.112/src/modules/files/efuns.c 2007-07-24 23:09:58.626801000 +0000
@@ -106,6 +106,10 @@
#endif
+#ifndef MAXPATHLEN
+#define MAXPATHLEN 32768
+#endif
+
struct array *encode_stat(PIKE_STAT_T *s)
{
struct array *a;
@@ -1113,9 +1117,6 @@
size*=2;
} while (size < 10000);
#else
-#ifndef MAXPATHLEN
-#define MAXPATHLEN 32768
-#endif
tmp=xalloc(MAXPATHLEN+1);
THREADS_ALLOW_UID();
e = getwd(tmp);
/trunk/debian/patches/00list
4,3 → 4,4
04_make_variables_fpic
05_install.pike
07_dynamic_module_makefile.in-libgcc
10_misplaced_MAXPATHLEN