Subversion Repositories pike-old

Compare Revisions

Ignore whitespace Rev 7 → Rev 8

/trunk/debian/patches/01_master.in.dpatch
7,11 → 7,12
@DPATCH@
diff -urNad trunk~/lib/master.pike.in trunk/lib/master.pike.in
--- trunk~/lib/master.pike.in 2007-01-01 01:28:04.000000000 +0100
+++ trunk/lib/master.pike.in 2007-10-02 14:04:02.000000000 +0200
@@ -1111,6 +1111,14 @@
add_module_path("¤lib_prefix¤/modules");
+++ trunk/lib/master.pike.in 2007-09-26 09:26:21.000000000 +0200
@@ -1115,6 +1115,14 @@
include_prefix = "¤include_prefix¤";
#endif
system_module_path=pike_module_path;
+
+ // Debian paths
+ add_include_path("/usr/local/include/pike");
+ add_include_path("/usr/local/include/pike"+__REAL_MAJOR__+"."+__REAL_MINOR__);
19,7 → 20,6
+ add_module_path("/usr/local/lib/pike"+__REAL_MAJOR__+"."+__REAL_MINOR__+"/site_pike");
+ add_module_path("/usr/local/share/pike/site_pike");
+ add_module_path("/usr/local/share/pike"+__REAL_MAJOR__+"."+__REAL_MINOR__+"/site_pike");
+
#if "¤include_prefix¤"[0]!='¤'
include_prefix = "¤include_prefix¤";
#endif
}
/trunk/debian/patches/03_language.yacc_bison_fix.dpatch
0,0 → 1,20
#! /bin/sh /usr/share/dpatch/dpatch-run
## 03_language.yacc_bison_fix.dpatch by <magnus@proffe.kibibyte.se>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Disable fix for Bison apparently using too small ints
 
@DPATCH@
 
diff -U3 -Narp pike7.6-7.6.27/src/language.c pike7.6-7.6.27.new/src/language.c
--- pike7.6-7.6.27/src/language.c 2005-06-18 02:46:36.000000000 +0200
+++ pike7.6-7.6.27.new/src/language.c 2005-06-18 02:53:45.009538576 +0200
@@ -326,7 +326,7 @@ typedef union YYSTYPE {
#include <stdio.h>
int yylex(YYSTYPE *yylval);
/* Bison is stupid, and tries to optimize for space... */
-#ifdef YYBISON
+#if defined(YYBISON) && !defined(DEBIAN)
#define short int
#endif /* YYBISON */
/trunk/debian/patches/00list
1,6 → 1,7
01_master.in
02_smartlink_rpath
#04_make_variables_fpic
03_language.yacc_bison_fix
04_make_variables_fpic
05_install.pike
07_dynamic_module_makefile.in-libgcc
10_misplaced_MAXPATHLEN