Subversion Repositories pike-old

Compare Revisions

Ignore whitespace Rev 40 → Rev 41

/trunk/debian/rules
11,6 → 11,7
 
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
 
include /usr/share/dpatch/dpatch.make
 
ifdef CCVER
23,9 → 24,6
DEB_BUILD_ARCH=$(shell dpkg-architecture -qDEB_BUILD_ARCH)
endif
 
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
CFLAGS_EXTRA = -g
CPPFLAGS_EXTRA = -DDEBIAN
 
76,7 → 74,8
MACHINE_OPTS=--without-machine-code
endif
 
DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
#DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
DEBVERSION:=$(shell dpkg-parsechangelog | grep "Version:" | cut -d" " -f2 | cut -d"-" -f1)
MAJOR:=$(shell sed -ne 's/major://p' buildid.txt)
MINOR:=$(shell sed -ne 's/minor://p' buildid.txt)
BUILD:=$(shell sed -ne 's/build://p' buildid.txt)
105,14 → 104,19
--with-postgres \
--with-postgres-include-dir=`pg_config --includedir` \
--with-libpq-dir=/usr/lib \
--with-perl \
--without-ffmpeg \
--without-fftw \
--without-libpdf \
--without-libpanda \
--without-GTK \
--without-GTK2 \
--with-GTK2 \
--without-bundles \
--without-oracle \
--without-dvb \
--with-sqlite \
--disable-rpath \
--disable-smartlink_binary \
--with-relocatable-dumped-modules \
$(MACHINE_OPTS) $(EXTRA_ARGS)
 
include_prefix=/usr/include/pike/$(VERSION)
122,7 → 126,7
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
 
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase Gnome GTK GDK DVB Java TTF
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF
# This is tricky. Note that it's only possible for an exclusion to match the last
# component specified in an .install file or on the command line, and below.
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
137,8 → 141,6
build-arch: build-arch-stamp
build-arch-stamp: $(DPATCH_STAMPFN)
dh_testdir
 
# Add here command to compile/build the package.
$(MAKE) compile CONFIGUREARGS="$(CFARGS)"
touch build-arch-stamp
 
145,8 → 147,6
build-indep: build-indep-stamp
build-indep-stamp: $(DPATCH_STAMPFN)
dh_testdir
 
# Add here command to compile/build the arch indep package.
$(MAKE) documentation CONFIGUREARGS="$(CFARGS)"
touch build-indep-stamp
 
159,8 → 159,6
dh_testdir
dh_testroot
rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp
 
# Add here commands to clean up after the build process.
$(MAKE) distclean
rm -rf refdoc/modref refdoc/traditional_manual
 
169,15 → 167,14
dh_testdir
dh_testroot
dh_clean -k
 
$(MAKE) INSTALLARGS=--traditional \
buildroot=$(TMP) \
prefix=/usr \
man_prefix=/usr/share/man \
lib_prefix="$(lib_prefix)" \
prefix=/usr \
man_prefix=/usr/share/man \
lib_prefix="$(lib_prefix)" \
include_prefix="$(include_prefix)" \
pike_name=/usr/bin/$(PIKE) \
install_nodoc
install_nodoc
 
# Some cleaning
find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';'
210,7 → 207,7
 
# # pike -x module fix
sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/dynamic_module_makefile;g' \
$(TMP)$(include_prefix)/dynamic_module_makefile
$(TMP)$(include_prefix)/modules/dynamic_module_makefile
 
# Build architecture-independent files here.
# Pass -i to all debhelper commands in this target to reduce clutter.
235,7 → 232,6
binary-arch: build-arch install
dh_testdir -a
dh_testroot -a
# dh_installdebconf -a
dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE)
dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY)
for p in $(MODULE_PACKAGES) $(PIKE)-dev; do \
243,7 → 239,6
done
dh_installdocs -a
dh_installmenu -a
# dh_installman -a
dh_installchangelogs -a -k CHANGES
dh_strip -a
dh_compress -a