Rev 63 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 63 | Rev 70 | ||
---|---|---|---|
Line 30... | Line 30... | ||
30 | SSP_FLAGS=-fstack-protector |
30 | SSP_FLAGS=-fstack-protector |
31 | endif |
31 | endif |
32 | 32 | ||
33 | CFARGSEXTRA = --with-cdebug |
33 | CFARGSEXTRA = --with-cdebug |
34 | 34 | ||
35 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
35 | ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS))) |
36 | CFARGSEXTRA += --without-copt |
36 | CFARGSEXTRA += --without-copt |
37 | else |
37 | else |
38 | CFARGSEXTRA += --with-copt |
38 | CFARGSEXTRA += --with-copt |
39 | endif |
39 | endif |
40 | 40 | ||
41 | ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS))) |
41 | ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS))) |
42 | CFARGSEXTRA += --with-rtldebug |
42 | CFARGSEXTRA += --with-rtldebug |
43 | else |
43 | else |
44 | CFARGSEXTRA += --without-rtldebug |
44 | CFARGSEXTRA += --without-rtldebug |
45 | endif |
45 | endif |
46 | 46 | ||
Line 48... | Line 48... | ||
48 | # Temporary workaround for hppa linker issues |
48 | # Temporary workaround for hppa linker issues |
49 | ifeq ($(DEB_BUILD_ARCH),hppa) |
49 | ifeq ($(DEB_BUILD_ARCH),hppa) |
50 | CFLAGS_EXTRA += -ffunction-sections |
50 | CFLAGS_EXTRA += -ffunction-sections |
51 | endif |
51 | endif |
52 | 52 | ||
53 | ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS))) |
53 | ifeq (,$(filter nostrip,$(DEB_BUILD_OPTIONS))) |
54 | INSTALL_PROGRAM += -s |
54 | INSTALL_PROGRAM += -s |
55 | endif |
55 | endif |
56 | 56 | ||
57 | EXTRA_ARGS=--with-security |
57 | EXTRA_ARGS=--with-security |
58 | 58 |