Rev 24 | Rev 70 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 24 | Rev 63 | ||
---|---|---|---|
Line 182... | Line 182... | ||
182 | install -d -m755 $(TMP)/usr/share/pixmaps |
182 | install -d -m755 $(TMP)/usr/share/pixmaps |
183 | install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm |
183 | install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm |
184 | mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE) |
184 | mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE) |
185 | mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1 |
185 | mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1 |
186 | 186 | ||
187 | # Fix permissions and shebang lines |
187 | # Simply strip exec permissions and shebangs from all pike scripts. |
188 | -for f in `find $(TMP)/usr/bin $(TMP)/usr/lib -type f`; do \ |
188 | find $(TMP)/usr -name *.p* -type f \ |
189 | if file $$f | grep -q "script"; then \ |
- | |
190 | chmod a+x $$f; \ |
189 | -exec chmod a-x '{}' + \ |
191 | sed -ri -e 's@#!.*NOMODULE@#!/usr/bin/$(PIKE)@' \ |
190 | -exec sed -ri -e '1!b;/^#!/d' '{}' + |
192 | -e 's@#! */usr/local/bin/pike@#!/usr/bin/$(PIKE)@' \ |
- | |
193 | -e 's@#! */usr/bin/env.*pike@#!/usr/bin/$(PIKE)@' \ |
- | |
194 | $$f; \ |
- | |
195 | fi; \ |
- | |
196 | done |
- | |
197 | 191 | ||
198 | # Don't install our own specs file - the ordinary one is not that bad really |
192 | # Don't install our own specs file - the ordinary one is not that bad really |
199 | # sed -e 's/@PIKEVERSION@/$(VERSION)/g' \ |
193 | # sed -e 's/@PIKEVERSION@/$(VERSION)/g' \ |
200 | -e 's;@CONFIGURE_ARGS@;$(CFARGS);g' \ |
194 | -e 's;@CONFIGURE_ARGS@;$(CFARGS);g' \ |
201 | debian/specs.in > $(TMP)$(include_prefix)/specs |
195 | debian/specs.in > $(TMP)$(include_prefix)/specs |