Rev 3 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
2 | magnus | 1 | #! /bin/sh /usr/share/dpatch/dpatch-run |
2 | ## 05_install.pike.dpatch by <magnus@proffe.kibibyte.se> |
||
3 | ## |
||
4 | ## All lines beginning with `## DP:' are a description of the patch. |
||
5 | ## DP: Allow include_prefix to be separately overridden in install.pike |
||
6 | |||
7 | @DPATCH@ |
||
3 | magnus | 8 | diff -urNad trunk~/src/Makefile.in trunk/src/Makefile.in |
9 | --- trunk~/src/Makefile.in 2006-10-20 15:40:28.000000000 +0200 |
||
10 | +++ trunk/src/Makefile.in 2007-09-26 09:51:13.000000000 +0200 |
||
11 | @@ -53,7 +53,7 @@ |
||
2 | magnus | 12 | # TESTARGS = -F -a |
13 | |||
14 | # Arguments for install.pike used by the install targets. |
||
15 | -INSTALLARGS = --new-style |
||
16 | +INSTALLARGS ?= --new-style |
||
17 | |||
18 | # |
||
19 | # use bison please, yacc isn't good enough. |
||
3 | magnus | 20 | @@ -506,7 +506,7 @@ |
2 | magnus | 21 | MANDIR_SRC="$(MANDIR_SRC)" \ |
22 | man_prefix="$(man_prefix)" pike_name=$(pike_name) \ |
||
23 | fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \ |
||
24 | - $(INSTALLARGS) |
||
25 | + include_prefix="$(include_prefix)" $(INSTALLARGS) |
||
26 | |||
27 | install_interactive: pike tools |
||
28 | @$(RUNPIKE) $(TMP_BINDIR)/install.pike --interactive \ |