Rev 3 | Blame | Compare with Previous | Last modification | View Log | RSS feed
#! /bin/sh /usr/share/dpatch/dpatch-run
## 05_install.pike.dpatch by <magnus@proffe.kibibyte.se>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Allow include_prefix to be separately overridden in install.pike
@DPATCH@
diff -urNad trunk~/src/Makefile.in trunk/src/Makefile.in
--- trunk~/src/Makefile.in 2006-10-20 15:40:28.000000000 +0200
+++ trunk/src/Makefile.in 2007-09-26 09:51:13.000000000 +0200
@@ -53,7 +53,7 @@
# TESTARGS = -F -a
# Arguments for install.pike used by the install targets.
-INSTALLARGS = --new-style
+INSTALLARGS ?= --new-style
#
# use bison please, yacc isn't good enough.
@@ -506,7 +506,7 @@
MANDIR_SRC="$(MANDIR_SRC)" \
man_prefix="$(man_prefix)" pike_name=$(pike_name) \
fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \
- $(INSTALLARGS)
+ include_prefix="$(include_prefix)" $(INSTALLARGS)
install_interactive: pike tools
@$(RUNPIKE) $(TMP_BINDIR)/install.pike --interactive \