Rev 3 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
3 | magnus | 1 | #!/bin/sh /usr/share/dpatch/dpatch-run |
2 | ## 10_misplaced_MAXPATHLEN.dpatch by Samuel Thibault <samuel.thibault@ens-lyon.org> |
||
3 | ## |
||
4 | ## All lines beginning with `## DP:' are a description of the patch. |
||
5 | ## DP: Move reserve MAXPATHLEN definition up. |
||
6 | |||
7 | @DPATCH@ |
||
8 | |||
9 | --- pike7.6-7.6.112.orig/src/modules/files/efuns.c 2007-07-24 23:08:26.932458000 +0000 |
||
10 | +++ pike7.6-7.6.112/src/modules/files/efuns.c 2007-07-24 23:09:58.626801000 +0000 |
||
11 | @@ -106,6 +106,10 @@ |
||
12 | |||
13 | #endif |
||
14 | |||
15 | +#ifndef MAXPATHLEN |
||
16 | +#define MAXPATHLEN 32768 |
||
17 | +#endif |
||
18 | + |
||
19 | struct array *encode_stat(PIKE_STAT_T *s) |
||
20 | { |
||
21 | struct array *a; |
||
22 | @@ -1113,9 +1117,6 @@ |
||
23 | size*=2; |
||
24 | } while (size < 10000); |
||
25 | #else |
||
26 | -#ifndef MAXPATHLEN |
||
27 | -#define MAXPATHLEN 32768 |
||
28 | -#endif |
||
29 | tmp=xalloc(MAXPATHLEN+1); |
||
30 | THREADS_ALLOW_UID(); |
||
31 | e = getwd(tmp); |