Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
279 holmgren 1
Bug-Debian: https://bugs.debian.org/878566
2
Author: Henrik Grubbström (Grubba) <grubba@grubba.org>
3
Origin: upstream, http://pike-librarian.lysator.liu.se/piff.xml?module=pike.git&file=src/modules/Postgres/pgresult.c&from=bbd892a86e2f103ea5cf21199c7f2c19f6214ddd&to=7d05b499bb04616ae52ab094c274cc92156fbd7e
4
Description: Fixed compilation when STATIC_MUTEX_INIT exists and paranoid linker.
5
 
6
diff --git a/src/modules/Postgres/pgresult.c b/src/modules/Postgres/pgresult.c
7
index fb4b553859..03109ec96c 100644
8
--- a/src/modules/Postgres/pgresult.c
9
+++ b/src/modules/Postgres/pgresult.c
10
@@ -102,7 +102,7 @@
11
 #  define PQ_LOCK() mt_lock(pg_mutex)
12
 #  define PQ_UNLOCK() mt_unlock(pg_mutex)
13
 # else
14
-extern PIKE_MUTEX_T pike_postgres_mutex STATIC_MUTEX_INIT;
15
+extern PIKE_MUTEX_T pike_postgres_mutex;
16
 #  define PQ_FETCH()
17
 #define PQ_LOCK() mt_lock(&pike_postgres_mutex)
18
 #define PQ_UNLOCK() mt_unlock(&pike_postgres_mutex)