Rev 61 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
116 | holmgren | 1 | Author: Magnus Holmgren <holmgren@debian.org> |
2 | Description: Allow share_prefix to be separately overridden in install.pike |
||
2 | magnus | 3 | |
41 | magnus | 4 | diff -urNad pike7.8-7.8.116~/src/Makefile.in pike7.8-7.8.116/src/Makefile.in |
5 | --- pike7.8-7.8.116~/src/Makefile.in 2008-11-18 15:16:56.000000000 -0400 |
||
6 | +++ pike7.8-7.8.116/src/Makefile.in 2009-05-04 21:50:17.000000000 -0300 |
||
7 | @@ -57,7 +57,7 @@ |
||
2 | magnus | 8 | # TESTARGS = -F -a |
9 | |||
10 | # Arguments for install.pike used by the install targets. |
||
11 | -INSTALLARGS = --new-style |
||
12 | +INSTALLARGS ?= --new-style |
||
13 | |||
14 | # |
||
15 | # use bison please, yacc isn't good enough. |
||
41 | magnus | 16 | @@ -658,7 +658,7 @@ |
2 | magnus | 17 | man_prefix="$(man_prefix)" pike_name=$(pike_name) \ |
18 | fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \ |
||
41 | magnus | 19 | cflags="@DYNAMIC_MODULE_FLAGS@" ldflags="" \ |
2 | magnus | 20 | - $(INSTALLARGS) |
61 | holmgren | 21 | + share_prefix="$(share_prefix)" $(INSTALLARGS) |
2 | magnus | 22 | |
41 | magnus | 23 | install_interactive: pike-complete-stamp tools |
2 | magnus | 24 | @$(RUNPIKE) $(TMP_BINDIR)/install.pike --interactive \ |
61 | holmgren | 25 | --- a/bin/install.pike 2009-06-08 23:51:36.000000000 +0200 |
26 | +++ b/bin/install.pike 2009-08-22 15:46:55.000000000 +0200 |
||
27 | @@ -1904,6 +1904,7 @@ |
||
28 | string exec_prefix; |
||
29 | string lib_prefix; |
||
30 | string include_prefix; |
||
31 | +string share_prefix; |
||
32 | string doc_prefix; |
||
33 | string man_prefix; |
||
34 | string cflags; |
||
35 | @@ -1946,6 +1947,8 @@ |
||
36 | lib_prefix=vars->lib_prefix||(prefix+"/lib/pike/"); |
||
37 | include_prefix = |
||
38 | vars->include_prefix || combine_path(prefix,"include","pike"); |
||
39 | + share_prefix = |
||
40 | + vars->share_prefix || lib_prefix; |
||
41 | doc_prefix = |
||
42 | vars->doc_prefix || combine_path(prefix, "doc", "pike"); |
||
43 | man_prefix=vars->man_prefix||(prefix+"/share/man/"); |
||
44 | @@ -2128,7 +2131,7 @@ |
||
45 | lib_prefix = combine_path(prefix, "lib"); |
||
46 | include_prefix = combine_path(prefix,"include","pike"); |
||
47 | make_master("lib/master.pike", "lib/master.pike.in", |
||
48 | - lib_prefix, include_prefix, UNDEFINED, cflags, ldflags); |
||
49 | + lib_prefix, include_prefix, share_prefix, cflags, ldflags); |
||
50 | status1("Installing master done."); |
||
51 | return 0; |
||
52 | |||
53 | @@ -2853,10 +2856,10 @@ |
||
54 | } |
||
55 | else |
||
56 | make_master(combine_path(vars->TMP_LIBDIR,"master.pike"), master_src, |
||
57 | - lib_prefix, include_prefix, UNDEFINED, cflags, ldflags); |
||
58 | + lib_prefix, include_prefix, share_prefix, cflags, ldflags); |
||
59 | |||
60 | install_dir(vars->TMP_LIBDIR,lib_prefix,1); |
||
61 | - install_dir(vars->LIBDIR_SRC,lib_prefix,1); |
||
62 | + install_dir(vars->LIBDIR_SRC,share_prefix,1); |
||
63 | |||
64 | install_header_files(vars->SRCDIR,include_prefix); |
||
65 | install_header_files(combine_path(vars->SRCDIR,"code"), |