Rev 126 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
94 | holmgren | 1 | #! /bin/sh /usr/share/dpatch/dpatch-run |
2 | ## unbreak_cross_compiling.dpatch by Marc Dirix <marc@electronics-design.nl> |
||
3 | ## |
||
4 | ## DP: Fix various breakage preventing cross compilation: |
||
5 | ## DP: * Use the installed pike when needed, not the newly built one. |
||
6 | ## DP: * Don't disable dynamic module loading just because we're cross-compiling |
||
7 | |||
8 | @DPATCH@ |
||
181 | holmgren | 9 | --- a/src/configure |
10 | +++ b/src/configure |
||
11 | @@ -8718,7 +8718,7 @@ if test "x$enable_binary" = "xno"; then |
||
12 | RUNPIKE="USE_PIKE" |
||
94 | holmgren | 13 | RUNTPIKE="USE_PIKE" |
181 | holmgren | 14 | elif test "x$cross_compiling" = "xyes"; then |
15 | - RUNPIKE="DEFAULT_RUNPIKE" |
||
16 | + RUNPIKE="USE_PIKE" |
||
17 | RUNTPIKE="USE_PIKE" |
||
94 | holmgren | 18 | else |
181 | holmgren | 19 | RUNPIKE="DEFAULT_RUNPIKE" |
20 | @@ -106150,7 +106150,7 @@ EOF |
||
94 | holmgren | 21 | ;; |
22 | esac |
||
23 | if test "$cross_compiling" = yes; then |
||
24 | - pike_cv_sys_dynamic_loading=no |
||
25 | + pike_cv_sys_dynamic_loading=yes |
||
26 | else |
||
27 | cat >conftest.$ac_ext <<_ACEOF |
||
28 | /* confdefs.h. */ |