Rev 116 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
94 | holmgren | 1 | #! /bin/sh /usr/share/dpatch/dpatch-run |
2 | ## unbreak_cross_compiling.dpatch by Marc Dirix <marc@electronics-design.nl> |
||
3 | ## |
||
4 | ## DP: Fix various breakage preventing cross compilation: |
||
5 | ## DP: * Use the installed pike when needed, not the newly built one. |
||
6 | ## DP: * Don't disable dynamic module loading just because we're cross-compiling |
||
7 | ## DP: * Don't freak out because a test program cannot be run |
||
8 | |||
9 | @DPATCH@ |
||
10 | --- a/src/configure 2009-09-22 20:37:45.000000000 +0000 |
||
11 | +++ b/src/configure 2010-05-04 09:44:55.000000000 +0000 |
||
12 | @@ -8855,7 +8855,7 @@ |
||
13 | RUNTPIKE="USE_PIKE" |
||
14 | else |
||
15 | if test "x$cross_compiling" = "xyes"; then |
||
16 | - RUNPIKE="DEFAULT_RUNPIKE" |
||
17 | + RUNPIKE="USE_PIKE" |
||
18 | RUNTPIKE="USE_PIKE" |
||
19 | else |
||
20 | RUNPIKE="DEFAULT_RUNPIKE" |
||
21 | @@ -106926,7 +106926,7 @@ |
||
22 | ;; |
||
23 | esac |
||
24 | if test "$cross_compiling" = yes; then |
||
25 | - pike_cv_sys_dynamic_loading=no |
||
26 | + pike_cv_sys_dynamic_loading=yes |
||
27 | else |
||
28 | cat >conftest.$ac_ext <<_ACEOF |
||
29 | /* confdefs.h. */ |
||
30 | --- a/src/modules/Mysql/configure 2010-05-19 10:20:10.745552500 +0000 |
||
31 | +++ b/src/modules/Mysql/configure 2009-09-22 20:38:35.000000000 +0000 |
||
32 | @@ -7018,13 +7018,7 @@ |
||
33 | $as_echo "yes" >&6; } |
||
34 | |||
35 | if test "$cross_compiling" = yes; then |
||
36 | - { { $as_echo "$as_me:$LINENO: error: in \`$ac_pwd':" >&5 |
||
37 | -$as_echo "$as_me: error: in \`$ac_pwd':" >&2;} |
||
38 | -{ { $as_echo "$as_me:$LINENO: error: cannot run test program while cross compiling |
||
39 | -See \`config.log' for more details." >&5 |
||
40 | -$as_echo "$as_me: error: cannot run test program while cross compiling |
||
41 | -See \`config.log' for more details." >&2;} |
||
42 | - { (exit 1); exit 1; }; }; } |
||
43 | +: |
||
44 | else |
||
45 | cat >conftest.$ac_ext <<_ACEOF |
||
46 | /* confdefs.h. */ |