Rev 181 | Go to most recent revision | Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
172 | holmgren | 1 | Description: Include the necessary header file declaring htons() in Protocols.DNS_SD. |
2 | |||
3 | --- a/src/modules/_Protocols_DNS_SD/configure.in |
||
4 | +++ b/src/modules/_Protocols_DNS_SD/configure.in |
||
5 | @@ -12,7 +12,7 @@ if test x$with_dnssd = xyes ; then |
||
6 | |||
7 | PIKE_FEATURE(DNS-SD,[no (dns_sd.h or howl.h not found)]) |
||
8 | |||
9 | - AC_CHECK_HEADERS(dns_sd.h howl.h) |
||
10 | + AC_CHECK_HEADERS(dns_sd.h howl.h netinet/in.h arpa/inet.h) |
||
11 | |||
12 | if test x$ac_cv_header_dns_sd_h = xyes; then |
||
13 | PIKE_FEATURE(DNS-SD,[no (libdns_sd not found)]) |
||
14 | --- a/src/modules/_Protocols_DNS_SD/sd.c |
||
15 | +++ b/src/modules/_Protocols_DNS_SD/sd.c |
||
16 | @@ -34,6 +34,12 @@ |
||
17 | |||
18 | #include <signal.h> |
||
19 | |||
20 | +#ifdef HAVE_NETINET_IN_H |
||
21 | +#include <netinet/in.h> |
||
22 | +#endif /* HAVE_NETINET_IN_H */ |
||
23 | +#ifdef HAVE_ARPA_INET_H |
||
24 | +#include <arpa/inet.h> |
||
25 | +#endif /* HAVE_ARPA_INET_H */ |
||
26 | |||
27 | #ifdef THIS |
||
28 | #undef THIS |
||
29 | --- a/src/modules/_Protocols_DNS_SD/config.h.in |
||
30 | +++ b/src/modules/_Protocols_DNS_SD/config.h.in |
||
31 | @@ -10,6 +10,9 @@ |
||
32 | #define PROTOCOLS_DNS_SD_H |
||
33 | |||
34 | |||
35 | +/* Define to 1 if you have the <arpa/inet.h> header file. */ |
||
36 | +#undef HAVE_ARPA_INET_H |
||
37 | + |
||
38 | /* Define to 1 if you have the <dns_sd.h> header file. */ |
||
39 | #undef HAVE_DNS_SD_H |
||
40 | |||
41 | @@ -25,6 +28,9 @@ |
||
42 | /* Define to 1 if you have the <memory.h> header file. */ |
||
43 | #undef HAVE_MEMORY_H |
||
44 | |||
45 | +/* Define to 1 if you have the <netinet/in.h> header file. */ |
||
46 | +#undef HAVE_NETINET_IN_H |
||
47 | + |
||
48 | /* Define to 1 if you have the <stdint.h> header file. */ |
||
49 | #undef HAVE_STDINT_H |
||
50 | |||
51 | --- a/src/modules/_Protocols_DNS_SD/configure |
||
52 | +++ b/src/modules/_Protocols_DNS_SD/configure |
||
53 | @@ -3616,7 +3616,7 @@ done |
||
54 | |||
55 | |||
56 | |||
57 | -for ac_header in dns_sd.h howl.h |
||
58 | +for ac_header in dns_sd.h howl.h netinet/in.h arpa/inet.h |
||
59 | do |
||
60 | |||
61 | |||
62 | @@ -3769,7 +3769,7 @@ fi |
||
63 | done |
||
64 | |||
65 | else |
||
66 | - for ac_hdr in dns_sd.h howl.h |
||
67 | + for ac_hdr in dns_sd.h howl.h netinet/in.h arpa/inet.h |
||
68 | do |
||
69 | ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'` |
||
70 | eval "ac_cv_header_$ac_safe=yes" |