Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 136 | Rev 138 | Go to most recent revision | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 136 Rev 137
1
#!/usr/bin/make -f
1
#!/usr/bin/make -f
2
# Sample debian/rules that uses debhelper. 
2
# Sample debian/rules that uses debhelper. 
3
# GNU copyright 1997 by Joey Hess.
3
# GNU copyright 1997 by Joey Hess.
4
#
4
#
5
# This version is for a hypothetical package that builds an
5
# This version is for a hypothetical package that builds an
6
# architecture-dependant package, as well as an architecture-independent
6
# architecture-dependant package, as well as an architecture-independent
7
# package.
7
# package.
8
#
8
#
9
# $Id: rules,v 1.64 2006/08/05 15:49:18 grendel Exp $
9
# $Id: rules,v 1.64 2006/08/05 15:49:18 grendel Exp $
10
#
10
#
11
11
12
# Uncomment this to turn on verbose mode. 
12
# Uncomment this to turn on verbose mode. 
13
#export DH_VERBOSE=1
13
#export DH_VERBOSE=1
14
14
15
ifdef CCVER
15
ifdef CCVER
16
CC=gcc-$(CCVER)
16
CC=gcc-$(CCVER)
17
else
17
else
18
CC=gcc
18
CC=gcc
19
endif
19
endif
20
20
21
export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
21
export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
22
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
22
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
23
23
24
CFARGSEXTRA := --with-cdebug
24
CFARGSEXTRA := --with-cdebug
25
25
26
ifneq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
26
ifneq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
27
export CC=$(DEB_HOST_GNU_TYPE)-gcc
27
export CC=$(DEB_HOST_GNU_TYPE)-gcc
28
CFARGSEXTRA += --host=$(DEB_HOST_GNU_TYPE)
28
CFARGSEXTRA += --host=$(DEB_HOST_GNU_TYPE)
29
endif
29
endif
30
30
31
DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
31
DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
32
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
32
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
33
33
34
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
34
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
35
CFARGSEXTRA += --without-copt
35
CFARGSEXTRA += --without-copt
36
else
36
else
37
  ifneq (,$(filter $(DEB_HOST_ARCH), i386))
37
  ifneq (,$(filter $(DEB_HOST_ARCH), i386))
38
    CFARGSEXTRA += --without-copt
38
    CFARGSEXTRA += --without-copt
39
    export DEB_CFLAGS_MAINT_STRIP := -O2 -O3
39
    export DEB_CFLAGS_MAINT_STRIP := -O2 -O3
40
    export DEB_CFLAGS_MAINT_PREPEND := -O1
40
    export DEB_CFLAGS_MAINT_PREPEND := -O1
41
  else
41
  else
42
    CFARGSEXTRA += --with-copt
42
    CFARGSEXTRA += --with-copt
43
  endif
43
  endif
44
endif
44
endif
45
45
46
ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
46
ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
47
CFARGSEXTRA += --with-rtldebug
47
CFARGSEXTRA += --with-rtldebug
48
else
48
else
49
CFARGSEXTRA += --without-rtldebug
49
CFARGSEXTRA += --without-rtldebug
50
endif
50
endif
51
51
52
# Temporary workaround for hppa linker issues
52
# Temporary workaround for hppa linker issues
53
ifeq ($(DEB_BUILD_ARCH),hppa)
53
ifeq ($(DEB_BUILD_ARCH),hppa)
54
export DEB_CFLAGS_MAINT_APPEND += -ffunction-sections
54
export DEB_CFLAGS_MAINT_APPEND += -ffunction-sections
55
endif
55
endif
56
56
57
EXTRA_ARGS=--with-security
57
EXTRA_ARGS=--with-security
58
58
59
export DEB_CPPFLAGS_MAINT_APPEND := -DDEBIAN
59
export DEB_CPPFLAGS_MAINT_APPEND := -DDEBIAN
60
60
61
DO_MACHINE_CODE=no
61
DO_MACHINE_CODE=no
62
ifeq ($(DEB_HOST_ARCH),i386)
62
ifeq ($(DEB_HOST_ARCH),i386)
63
DO_MACHINE_CODE=yes
63
DO_MACHINE_CODE=yes
64
endif
64
endif
65
ifeq ($(DEB_HOST_ARCH),powerpc)
65
ifeq ($(DEB_HOST_ARCH),powerpc)
66
DO_MACHINE_CODE=yes
66
DO_MACHINE_CODE=yes
67
endif
67
endif
68
ifeq ($(DEB_BUILD_ARCH),sparc)
68
ifeq ($(DEB_BUILD_ARCH),sparc)
69
DO_MACHINE_CODE=no
69
DO_MACHINE_CODE=no
70
endif
70
endif
71
71
72
ifeq ($(DO_MACHINE_CODE),yes)
72
ifeq ($(DO_MACHINE_CODE),yes)
73
MACHINE_OPTS=--with-machine-code
73
MACHINE_OPTS=--with-machine-code
74
else
74
else
75
MACHINE_OPTS=--without-machine-code
75
MACHINE_OPTS=--without-machine-code
76
endif
76
endif
77
77
78
#DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
78
#DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
79
DEBVERSION:=$(shell dpkg-parsechangelog | grep "Version:" | cut -d" " -f2 | cut -d"-" -f1)
79
DEBVERSION:=$(shell dpkg-parsechangelog | grep "Version:" | cut -d" " -f2 | cut -d"-" -f1)
80
MAJOR:=$(shell sed -ne 's/major://p' buildid.txt)
80
MAJOR:=$(shell sed -ne 's/major://p' buildid.txt)
81
MINOR:=$(shell sed -ne 's/minor://p' buildid.txt)
81
MINOR:=$(shell sed -ne 's/minor://p' buildid.txt)
82
BUILD:=$(shell sed -ne 's/build://p' buildid.txt)
82
BUILD:=$(shell sed -ne 's/build://p' buildid.txt)
83
PIKEV:=$(MAJOR).$(MINOR)
83
PIKEV:=$(MAJOR).$(MINOR)
84
VERSION:=$(MAJOR).$(MINOR).$(BUILD)
84
VERSION:=$(MAJOR).$(MINOR).$(BUILD)
85
PIKE:=pike$(PIKEV)
85
PIKE:=pike$(PIKEV)
86
86
87
ifneq ($(VERSION),$(DEBVERSION))
87
ifneq ($(VERSION),$(DEBVERSION))
88
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
88
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
89
endif
89
endif
90
90
91
CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
91
CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
92
CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
92
CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
93
LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
93
LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
94
94
95
# --with-lib-path is just to stop configure from adding all the
95
# --with-lib-path is just to stop configure from adding all the
96
# standard library directories with -L as well as -R to LDFLAGS
96
# standard library directories with -L as well as -R to LDFLAGS
97
CFARGS=$(CFARGSEXTRA) \
97
CFARGS=$(CFARGSEXTRA) \
98
       --with-cflags='`dpkg-buildflags --get CFLAGS`' \
98
       --with-cflags='`dpkg-buildflags --get CFLAGS`' \
99
       --with-cppflags='`dpkg-buildflags --get CPPFLAGS`' \
99
       --with-cppflags='`dpkg-buildflags --get CPPFLAGS`' \
100
       --with-ldflags='`dpkg-buildflags --get LDFLAGS`' \
100
       --with-ldflags='`dpkg-buildflags --get LDFLAGS`' \
101
       --prefix=/usr \
101
       --prefix=/usr \
102
       --with-bignums \
102
       --with-bignums \
103
       --with-gmp \
103
       --with-gmp \
104
       --with-poll \
104
       --with-poll \
105
       --with-zlib \
105
       --with-zlib \
106
       --with-freetype \
106
       --with-freetype \
107
       --without-ttflib \
107
       --without-ttflib \
108
       --with-libnettle \
108
       --with-libnettle \
109
       --without-sybase \
109
       --without-sybase \
110
       --without-java \
110
       --without-java \
111
       --with-odbc \
111
       --with-odbc \
112
       --with-sane \
112
       --with-sane \
113
       --with-postgres \
113
       --with-postgres \
114
       --with-postgres-include-dir=`pg_config --includedir` \
114
       --with-postgres-include-dir=`pg_config --includedir` \
115
       --with-libpq-dir=/usr/lib \
115
       --with-libpq-dir=/usr/lib \
116
       --without-ffmpeg \
116
       --without-ffmpeg \
117
       --without-fftw \
117
       --without-fftw \
118
       --without-libpdf \
118
       --without-libpdf \
119
       --without-libpanda \
119
       --without-libpanda \
120
       --without-GTK \
120
       --without-GTK \
121
       --with-GTK2 \
121
       --with-GTK2 \
122
       --without-bundles \
122
       --without-bundles \
123
       --without-oracle \
123
       --without-oracle \
124
       --without-dvb \
124
       --without-dvb \
125
       --with-sqlite \
125
       --with-sqlite \
126
       --disable-rpath \
126
       --disable-rpath \
127
       --disable-smartlink_binary \
127
       --disable-smartlink_binary \
128
       $(MACHINE_OPTS) $(EXTRA_ARGS)
128
       $(MACHINE_OPTS) $(EXTRA_ARGS)
129
129
130
include_prefix=/usr/include/pike$(PIKEV)/pike
130
include_prefix=/usr/include/pike$(PIKEV)/pike
131
lib_prefix=/usr/lib/pike$(PIKEV)
131
lib_prefix=/usr/lib/pike$(PIKEV)
132
132
133
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core)
133
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core)
134
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
134
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
135
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
135
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
136
136
137
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF PV.pike Gnome GDK GTKSupport
137
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF PV.pike Gnome GDK GTKSupport
138
# This is tricky. Note that it's only possible for an exclusion to match the last
138
# This is tricky. Note that it's only possible for an exclusion to match the last
139
# component specified in an .install file or on the command line, and below.
139
# component specified in an .install file or on the command line, and below.
140
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
140
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
141
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
141
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
142
	      find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`
142
	      find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`
143
143
144
TMP=$(CURDIR)/debian/tmp
144
TMP=$(CURDIR)/debian/tmp
145
145
146
#export CFLAGS CC PIKE VERSION
146
#export CFLAGS CC PIKE VERSION
147
export CC
147
export CC
148
148
149
build-arch: build-arch-stamp
149
build-arch: build-arch-stamp
150
build-arch-stamp:
150
build-arch-stamp:
151
	dh_testdir
151
	dh_testdir
152
	$(MAKE) compile CONFIGUREARGS="$(CFARGS)"
152
	$(MAKE) compile CONFIGUREARGS="$(CFARGS)"
153
	touch build-arch-stamp
153
	touch build-arch-stamp
154
154
155
build-indep: build-indep-stamp
155
build-indep: build-indep-stamp
156
build-indep-stamp:
156
build-indep-stamp:
157
	dh_testdir
157
	dh_testdir
158
	$(MAKE) documentation CONFIGUREARGS="$(CFARGS)"
158
	$(MAKE) documentation CONFIGUREARGS="$(CFARGS)"
159
	touch build-indep-stamp
159
	touch build-indep-stamp
160
160
161
build: build-arch
161
build: build-arch
162
162
163
clean:
163
clean:
164
	dh_testdir
164
	dh_testdir
165
	dh_testroot
165
	dh_testroot
166
	rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp
166
	rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp
167
	$(MAKE) distclean
167
	$(MAKE) distclean
168
	rm -rf refdoc/modref refdoc/traditional_manual
168
	rm -rf refdoc/modref refdoc/traditional_manual
169
	dh_clean
169
	dh_clean
170
170
171
install: DH_OPTIONS=
171
install: DH_OPTIONS=
172
install: build-arch
172
install: build-arch
173
	dh_testdir
173
	dh_testdir
174
	dh_testroot
174
	dh_testroot
175
	dh_clean -k
175
	dh_clean -k
176
	$(MAKE) INSTALLARGS=--traditional \
176
	$(MAKE) INSTALLARGS=--traditional \
177
		buildroot=$(TMP) \
177
		buildroot=$(TMP) \
178
		prefix=/usr \
178
		prefix=/usr \
179
		man_prefix=/usr/share/man \
179
		man_prefix=/usr/share/man \
180
		lib_prefix="$(lib_prefix)" \
180
		lib_prefix="$(lib_prefix)" \
181
		include_prefix="$(include_prefix)" \
181
		include_prefix="$(include_prefix)" \
182
		pike_name=/usr/bin/$(PIKE) \
182
		pike_name=/usr/bin/$(PIKE) \
183
		install_nodoc
183
		install_nodoc
184
184
185
#	Some cleaning
185
#	Some cleaning
186
	find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';'
186
	find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';'
187
187
188
	install -d -m755 $(TMP)/usr/share/pixmaps
188
	install -d -m755 $(TMP)/usr/share/pixmaps
189
	install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm
189
	install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm
190
	mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE)
190
	mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE)
191
	mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1
191
	mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1
192
192
193
#	Simply strip exec permissions and shebangs from all pike scripts.
193
#	Simply strip exec permissions and shebangs from all pike scripts.
194
	find $(TMP)/usr -name *.p* -type f \
194
	find $(TMP)/usr -name *.p* -type f \
195
		-exec chmod a-x '{}' + \
195
		-exec chmod a-x '{}' + \
196
		-exec sed -ri -e '1!b;/^#!/d' '{}' +
196
		-exec sed -ri -e '1!b;/^#!/d' '{}' +
197
197
198
#	Install our own, simpler specs file.
198
#	Install our own, simpler specs file.
199
	sed -e "s;@include_prefix@;$(include_prefix);g" \
199
	sed -e "s;@include_prefix@;$(include_prefix);g" \
200
	    -e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \
200
	    -e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \
201
	    debian/specs.in > $(TMP)$(include_prefix)/specs
201
	    debian/specs.in > $(TMP)$(include_prefix)/specs
202
202
203
#	Fix precompike.pike
203
#	Fix precompike.pike
204
	sed -i -e "s%\.\./lib%$(lib_prefix)%" $(TMP)$(include_prefix)/precompile.pike
204
	sed -i -e "s%\.\./lib%$(lib_prefix)%" $(TMP)$(include_prefix)/precompile.pike
205
205
206
# 	# pike -x module fix
206
# 	# pike -x module fix
207
#	sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/modules/dynamic_module_makefile;g' \
207
#	sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/modules/dynamic_module_makefile;g' \
208
#		$(TMP)$(include_prefix)/modules/dynamic_module_makefile
208
#		$(TMP)$(include_prefix)/modules/dynamic_module_makefile
209
209
210
# Build architecture-independent files here.
210
# Build architecture-independent files here.
211
# Pass -i to all debhelper commands in this target to reduce clutter.
211
# Pass -i to all debhelper commands in this target to reduce clutter.
212
binary-indep: build-indep
212
binary-indep: build-indep
213
	dh_testdir -i
213
	dh_testdir -i
214
	dh_testroot -i
214
	dh_testroot -i
215
	# install the docs
215
	# install the docs
216
	dh_install -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual
216
	dh_install -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual
217
	dh_install -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference
217
	dh_install -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference
218
	dh_install -i -N$(PIKE)-manual -N$(PIKE)-reference --sourcedir=$(TMP)
218
	dh_install -i -N$(PIKE)-manual -N$(PIKE)-reference --sourcedir=$(TMP)
219
	dh_installdocs -i
219
	dh_installdocs -i
220
	dh_installchangelogs -i -k CHANGES
220
	dh_installchangelogs -i -k CHANGES
221
	dh_link -i
221
	dh_link -i
222
	dh_compress -i
222
	dh_compress -i
223
	dh_fixperms -i
223
	dh_fixperms -i
224
	dh_installdeb -i
224
	dh_installdeb -i
225
	dh_gencontrol -i
225
	dh_gencontrol -i
226
	dh_md5sums -i
226
	dh_md5sums -i
227
	dh_builddeb -i
227
	dh_builddeb -i
228
228
229
# Build architecture-dependent files here.
229
# Build architecture-dependent files here.
230
binary-arch: build-arch install
230
binary-arch: build-arch install
231
	dh_testdir -a
231
	dh_testdir -a
232
	dh_testroot -a
232
	dh_testroot -a
233
	dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE)
233
	dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE)
234
	dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY)
234
	dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY)
235
	for p in $(MODULE_PACKAGES) $(PIKE)-dev; do \
235
	for p in $(MODULE_PACKAGES) $(PIKE)-dev; do \
236
		dh_link -p$$p usr/share/doc/$(PIKE)-core usr/share/doc/$$p; \
236
		dh_link -p$$p usr/share/doc/$(PIKE)-core usr/share/doc/$$p; \
237
		sed "s/#PACKAGE#/$$p/" debian/prerm-snippet > debian/$$p.prerm.debhelper; \
237
		sed "s/#PACKAGE#/$$p/" debian/prerm-snippet >> debian/$$p.prerm.debhelper; \
238
	done
238
	done
239
	dh_installdocs -a
239
	dh_installdocs -a
240
	dh_installmenu -a
240
	dh_installmenu -a
241
	dh_installchangelogs -a -k CHANGES
241
	dh_installchangelogs -a -k CHANGES
242
	dh_strip -a
242
	dh_strip -a
243
	dh_compress -a
243
	dh_compress -a
244
	dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite
244
	dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite
245
	dh_installdeb -a
245
	dh_installdeb -a
246
	dh_shlibdeps -a
246
	dh_shlibdeps -a
247
	dh_gencontrol -a
247
	dh_gencontrol -a
248
	dh_md5sums -a
248
	dh_md5sums -a
249
	dh_builddeb -a
249
	dh_builddeb -a
250
250
251
binary: binary-indep binary-arch
251
binary: binary-indep binary-arch
252
.PHONY: build clean binary-indep binary-arch binary install configure
252
.PHONY: build clean binary-indep binary-arch binary install configure