Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 136 | Rev 138 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
2 magnus 1
#!/usr/bin/make -f
2
# Sample debian/rules that uses debhelper.
3
# GNU copyright 1997 by Joey Hess.
4
#
5
# This version is for a hypothetical package that builds an
6
# architecture-dependant package, as well as an architecture-independent
7
# package.
8
#
9
# $Id: rules,v 1.64 2006/08/05 15:49:18 grendel Exp $
10
#
11
 
12
# Uncomment this to turn on verbose mode.
13
#export DH_VERBOSE=1
41 magnus 14
 
2 magnus 15
ifdef CCVER
16
CC=gcc-$(CCVER)
17
else
18
CC=gcc
19
endif
20
 
94 holmgren 21
export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
22
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
23
 
134 holmgren 24
CFARGSEXTRA := --with-cdebug
94 holmgren 25
 
26
ifneq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
27
export CC=$(DEB_HOST_GNU_TYPE)-gcc
28
CFARGSEXTRA += --host=$(DEB_HOST_GNU_TYPE)
29
endif
30
 
134 holmgren 31
DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
32
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
2 magnus 33
 
71 holmgren 34
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
12 magnus 35
CFARGSEXTRA += --without-copt
2 magnus 36
else
134 holmgren 37
  ifneq (,$(filter $(DEB_HOST_ARCH), i386))
38
    CFARGSEXTRA += --without-copt
39
    export DEB_CFLAGS_MAINT_STRIP := -O2 -O3
40
    export DEB_CFLAGS_MAINT_PREPEND := -O1
41
  else
42
    CFARGSEXTRA += --with-copt
43
  endif
2 magnus 44
endif
45
 
71 holmgren 46
ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
12 magnus 47
CFARGSEXTRA += --with-rtldebug
48
else
49
CFARGSEXTRA += --without-rtldebug
2 magnus 50
endif
51
 
52
# Temporary workaround for hppa linker issues
53
ifeq ($(DEB_BUILD_ARCH),hppa)
134 holmgren 54
export DEB_CFLAGS_MAINT_APPEND += -ffunction-sections
2 magnus 55
endif
56
 
57
EXTRA_ARGS=--with-security
58
 
134 holmgren 59
export DEB_CPPFLAGS_MAINT_APPEND := -DDEBIAN
60
 
2 magnus 61
DO_MACHINE_CODE=no
134 holmgren 62
ifeq ($(DEB_HOST_ARCH),i386)
2 magnus 63
DO_MACHINE_CODE=yes
64
endif
134 holmgren 65
ifeq ($(DEB_HOST_ARCH),powerpc)
2 magnus 66
DO_MACHINE_CODE=yes
67
endif
68
ifeq ($(DEB_BUILD_ARCH),sparc)
69
DO_MACHINE_CODE=no
70
endif
71
 
72
ifeq ($(DO_MACHINE_CODE),yes)
73
MACHINE_OPTS=--with-machine-code
74
else
75
MACHINE_OPTS=--without-machine-code
76
endif
77
 
41 magnus 78
#DEBVERSION:=$(shell dpkg-parsechangelog | sed -ne 's/Version: *\(.*\)-.*$$/\1/p')
79
DEBVERSION:=$(shell dpkg-parsechangelog | grep "Version:" | cut -d" " -f2 | cut -d"-" -f1)
3 magnus 80
MAJOR:=$(shell sed -ne 's/major://p' buildid.txt)
81
MINOR:=$(shell sed -ne 's/minor://p' buildid.txt)
82
BUILD:=$(shell sed -ne 's/build://p' buildid.txt)
83
PIKEV:=$(MAJOR).$(MINOR)
84
VERSION:=$(MAJOR).$(MINOR).$(BUILD)
85
PIKE:=pike$(PIKEV)
86
 
87
ifneq ($(VERSION),$(DEBVERSION))
88
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
89
endif
90
 
134 holmgren 91
CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
92
CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
93
LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
94
 
95
# --with-lib-path is just to stop configure from adding all the
96
# standard library directories with -L as well as -R to LDFLAGS
2 magnus 97
CFARGS=$(CFARGSEXTRA) \
134 holmgren 98
       --with-cflags='`dpkg-buildflags --get CFLAGS`' \
99
       --with-cppflags='`dpkg-buildflags --get CPPFLAGS`' \
100
       --with-ldflags='`dpkg-buildflags --get LDFLAGS`' \
101
       --prefix=/usr \
2 magnus 102
       --with-bignums \
103
       --with-gmp \
104
       --with-poll \
105
       --with-zlib \
106
       --with-freetype \
3 magnus 107
       --without-ttflib \
2 magnus 108
       --with-libnettle \
109
       --without-sybase \
3 magnus 110
       --without-java \
2 magnus 111
       --with-odbc \
112
       --with-sane \
113
       --with-postgres \
12 magnus 114
       --with-postgres-include-dir=`pg_config --includedir` \
2 magnus 115
       --with-libpq-dir=/usr/lib \
116
       --without-ffmpeg \
12 magnus 117
       --without-fftw \
2 magnus 118
       --without-libpdf \
3 magnus 119
       --without-libpanda \
2 magnus 120
       --without-GTK \
41 magnus 121
       --with-GTK2 \
12 magnus 122
       --without-bundles \
41 magnus 123
       --without-oracle \
124
       --without-dvb \
125
       --with-sqlite \
126
       --disable-rpath \
127
       --disable-smartlink_binary \
3 magnus 128
       $(MACHINE_OPTS) $(EXTRA_ARGS)
2 magnus 129
 
113 holmgren 130
include_prefix=/usr/include/pike$(PIKEV)/pike
84 holmgren 131
lib_prefix=/usr/lib/pike$(PIKEV)
2 magnus 132
 
105 holmgren 133
MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core)
3 magnus 134
#{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}.
135
#usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.*
136
 
95 holmgren 137
excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase DVB Java TTF PV.pike Gnome GDK GTKSupport
3 magnus 138
# This is tricky. Note that it's only possible for an exclusion to match the last
139
# component specified in an .install file or on the command line, and below.
99 holmgren 140
DH_EXCLUDE:=$(addprefix -X,$(excluded_modules))
3 magnus 141
DH_ALREADY=`for p in $(MODULE_PACKAGES); do \
84 holmgren 142
	      find debian/$$p/usr/lib/pike?.?/* -type f -printf "-X%P "; done`
3 magnus 143
 
144
TMP=$(CURDIR)/debian/tmp
145
 
12 magnus 146
#export CFLAGS CC PIKE VERSION
147
export CC
2 magnus 148
 
149
build-arch: build-arch-stamp
122 holmgren 150
build-arch-stamp:
2 magnus 151
	dh_testdir
152
	$(MAKE) compile CONFIGUREARGS="$(CFARGS)"
153
	touch build-arch-stamp
154
 
155
build-indep: build-indep-stamp
122 holmgren 156
build-indep-stamp:
2 magnus 157
	dh_testdir
158
	$(MAKE) documentation CONFIGUREARGS="$(CFARGS)"
159
	touch build-indep-stamp
160
 
19 magnus 161
build: build-arch
2 magnus 162
 
122 holmgren 163
clean:
2 magnus 164
	dh_testdir
165
	dh_testroot
166
	rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp
12 magnus 167
	$(MAKE) distclean
2 magnus 168
	rm -rf refdoc/modref refdoc/traditional_manual
122 holmgren 169
	dh_clean
2 magnus 170
 
171
install: DH_OPTIONS=
3 magnus 172
install: build-arch
2 magnus 173
	dh_testdir
174
	dh_testroot
175
	dh_clean -k
3 magnus 176
	$(MAKE) INSTALLARGS=--traditional \
177
		buildroot=$(TMP) \
41 magnus 178
		prefix=/usr \
179
		man_prefix=/usr/share/man \
180
		lib_prefix="$(lib_prefix)" \
3 magnus 181
		include_prefix="$(include_prefix)" \
2 magnus 182
		pike_name=/usr/bin/$(PIKE) \
41 magnus 183
		install_nodoc
2 magnus 184
 
3 magnus 185
#	Some cleaning
186
	find "$(TMP)$(lib_prefix)" -name '.autodoc' -type f -exec rm -f '{}' ';'
2 magnus 187
 
3 magnus 188
	install -d -m755 $(TMP)/usr/share/pixmaps
189
	install -m644 debian/pike.xpm $(TMP)/usr/share/pixmaps/$(PIKE).xpm
190
	mv $(TMP)/usr/bin/pike $(TMP)/usr/bin/$(PIKE)
191
	mv $(TMP)/usr/share/man/man1/pike.1 $(TMP)/usr/share/man/man1/$(PIKE).1
2 magnus 192
 
64 holmgren 193
#	Simply strip exec permissions and shebangs from all pike scripts.
194
	find $(TMP)/usr -name *.p* -type f \
195
		-exec chmod a-x '{}' + \
196
		-exec sed -ri -e '1!b;/^#!/d' '{}' +
2 magnus 197
 
84 holmgren 198
#	Install our own, simpler specs file.
199
	sed -e "s;@include_prefix@;$(include_prefix);g" \
200
	    -e "s;@CONFIGURE_ARGS@;$(CFARGS);g" \
12 magnus 201
	    debian/specs.in > $(TMP)$(include_prefix)/specs
2 magnus 202
 
84 holmgren 203
#	Fix precompike.pike
204
	sed -i -e "s%\.\./lib%$(lib_prefix)%" $(TMP)$(include_prefix)/precompile.pike
205
 
3 magnus 206
# 	# pike -x module fix
45 holmgren 207
#	sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/modules/dynamic_module_makefile;g' \
208
#		$(TMP)$(include_prefix)/modules/dynamic_module_makefile
2 magnus 209
 
210
# Build architecture-independent files here.
211
# Pass -i to all debhelper commands in this target to reduce clutter.
3 magnus 212
binary-indep: build-indep
2 magnus 213
	dh_testdir -i
214
	dh_testroot -i
3 magnus 215
	# install the docs
216
	dh_install -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual
217
	dh_install -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference
218
	dh_install -i -N$(PIKE)-manual -N$(PIKE)-reference --sourcedir=$(TMP)
2 magnus 219
	dh_installdocs -i
12 magnus 220
	dh_installchangelogs -i -k CHANGES
2 magnus 221
	dh_link -i
222
	dh_compress -i
223
	dh_fixperms -i
224
	dh_installdeb -i
225
	dh_gencontrol -i
226
	dh_md5sums -i
227
	dh_builddeb -i
228
 
229
# Build architecture-dependent files here.
230
binary-arch: build-arch install
231
	dh_testdir -a
232
	dh_testroot -a
12 magnus 233
	dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE)
3 magnus 234
	dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY)
12 magnus 235
	for p in $(MODULE_PACKAGES) $(PIKE)-dev; do \
3 magnus 236
		dh_link -p$$p usr/share/doc/$(PIKE)-core usr/share/doc/$$p; \
137 holmgren 237
		sed "s/#PACKAGE#/$$p/" debian/prerm-snippet >> debian/$$p.prerm.debhelper; \
3 magnus 238
	done
2 magnus 239
	dh_installdocs -a
3 magnus 240
	dh_installmenu -a
12 magnus 241
	dh_installchangelogs -a -k CHANGES
2 magnus 242
	dh_strip -a
243
	dh_compress -a
3 magnus 244
	dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite
2 magnus 245
	dh_installdeb -a
246
	dh_shlibdeps -a
247
	dh_gencontrol -a
248
	dh_md5sums -a
249
	dh_builddeb -a
250
 
251
binary: binary-indep binary-arch
252
.PHONY: build clean binary-indep binary-arch binary install configure