Rev 113 | Rev 126 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 113 | Rev 122 | ||
---|---|---|---|
Line 10... | Line 10... | ||
10 | # |
10 | # |
11 | 11 | ||
12 | # Uncomment this to turn on verbose mode. |
12 | # Uncomment this to turn on verbose mode. |
13 | #export DH_VERBOSE=1 |
13 | #export DH_VERBOSE=1 |
14 | 14 | ||
15 | include /usr/share/dpatch/dpatch.make |
- | |
16 | - | ||
17 | ifdef CCVER |
15 | ifdef CCVER |
18 | CC=gcc-$(CCVER) |
16 | CC=gcc-$(CCVER) |
19 | else |
17 | else |
20 | CC=gcc |
18 | CC=gcc |
21 | endif |
19 | endif |
Line 144... | Line 142... | ||
144 | 142 | ||
145 | #export CFLAGS CC PIKE VERSION |
143 | #export CFLAGS CC PIKE VERSION |
146 | export CC |
144 | export CC |
147 | 145 | ||
148 | build-arch: build-arch-stamp |
146 | build-arch: build-arch-stamp |
149 | build-arch-stamp: $(DPATCH_STAMPFN) |
147 | build-arch-stamp: |
150 | dh_testdir |
148 | dh_testdir |
151 | $(MAKE) compile CONFIGUREARGS="$(CFARGS)" |
149 | $(MAKE) compile CONFIGUREARGS="$(CFARGS)" |
152 | touch build-arch-stamp |
150 | touch build-arch-stamp |
153 | 151 | ||
154 | build-indep: build-indep-stamp |
152 | build-indep: build-indep-stamp |
155 | build-indep-stamp: $(DPATCH_STAMPFN) |
153 | build-indep-stamp: |
156 | dh_testdir |
154 | dh_testdir |
157 | $(MAKE) documentation CONFIGUREARGS="$(CFARGS)" |
155 | $(MAKE) documentation CONFIGUREARGS="$(CFARGS)" |
158 | touch build-indep-stamp |
156 | touch build-indep-stamp |
159 | 157 | ||
160 | build: build-arch |
158 | build: build-arch |
161 | 159 | ||
162 | clean: clean-patched unpatch |
- | |
163 | dh_clean |
160 | clean: |
164 | - | ||
165 | clean-patched: |
- | |
166 | dh_testdir |
161 | dh_testdir |
167 | dh_testroot |
162 | dh_testroot |
168 | rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp |
163 | rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp |
169 | $(MAKE) distclean |
164 | $(MAKE) distclean |
170 | rm -rf refdoc/modref refdoc/traditional_manual |
165 | rm -rf refdoc/modref refdoc/traditional_manual |
- | 166 | dh_clean |
|
171 | 167 | ||
172 | install: DH_OPTIONS= |
168 | install: DH_OPTIONS= |
173 | install: build-arch |
169 | install: build-arch |
174 | dh_testdir |
170 | dh_testdir |
175 | dh_testroot |
171 | dh_testroot |