Rev 3 | Rev 8 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 3 | Rev 7 | ||
---|---|---|---|
Line 21... | Line 21... | ||
21 | 21 | ||
22 | ifeq (,$(DEB_BUILD_ARCH)) |
22 | ifeq (,$(DEB_BUILD_ARCH)) |
23 | DEB_BUILD_ARCH=$(shell dpkg-architecture -qDEB_BUILD_ARCH) |
23 | DEB_BUILD_ARCH=$(shell dpkg-architecture -qDEB_BUILD_ARCH) |
24 | endif |
24 | endif |
25 | 25 | ||
- | 26 | CFLAGS_EXTRA = -g |
|
26 | CPPFLAGS_EXTRA = -DDEBIAN |
27 | CPPFLAGS_EXTRA = -DDEBIAN |
27 | 28 | ||
28 | ifdef SSP |
29 | ifdef SSP |
29 | SSP_FLAGS=-fstack-protector |
30 | SSP_FLAGS=-fstack-protector |
30 | endif |
31 | endif |
31 | 32 | ||
- | 33 | CFARGSEXTRA = --with-cdebug |
|
- | 34 | ||
32 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
35 | ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS))) |
33 | CFARGSEXTRA=--without-rtldebug --without-cdebug --without-debug --without-copt |
36 | CFARGSEXTRA += --without-copt |
34 | else |
37 | else |
35 | CFARGSEXTRA=--without-rtldebug --without-cdebug --without-debug |
38 | CFARGSEXTRA += --with-copt |
36 | endif |
39 | endif |
37 | 40 | ||
38 | ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS))) |
41 | ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS))) |
- | 42 | CFARGSEXTRA += --with-rtldebug |
|
- | 43 | else |
|
39 | CFARGSEXTRA += --with-rtldebug --with-cdebug --with-debug |
44 | CFARGSEXTRA += --without-rtldebug |
40 | endif |
45 | endif |
41 | 46 | ||
42 | CFLAGS_EXTRA += $(SSP_FLAGS) |
47 | CFLAGS_EXTRA += $(SSP_FLAGS) |
43 | # Temporary workaround for hppa linker issues |
48 | # Temporary workaround for hppa linker issues |
44 | ifeq ($(DEB_BUILD_ARCH),hppa) |
49 | ifeq ($(DEB_BUILD_ARCH),hppa) |
Line 79... | Line 84... | ||
79 | ifneq ($(VERSION),$(DEBVERSION)) |
84 | ifneq ($(VERSION),$(DEBVERSION)) |
80 | $(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION)) |
85 | $(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION)) |
81 | endif |
86 | endif |
82 | 87 | ||
83 | CFARGS=$(CFARGSEXTRA) \ |
88 | CFARGS=$(CFARGSEXTRA) \ |
84 | --with-cflags="$(CFLAGS_EXTRA)" \ |
89 | --with-cflags=\\'$(CFLAGS_EXTRA)\\' \ |
85 | --with-cppflags="$(CPPFLAGS_EXTRA)" \ |
90 | --with-cppflags=\\'$(CPPFLAGS_EXTRA)\\' \ |
86 | --with-bignums \ |
91 | --with-bignums \ |
87 | --with-gmp \ |
92 | --with-gmp \ |
88 | --with-poll \ |
93 | --with-poll \ |
89 | --with-zlib \ |
94 | --with-zlib \ |
90 | --with-freetype \ |
95 | --with-freetype \ |
Line 93... | Line 98... | ||
93 | --without-sybase \ |
98 | --without-sybase \ |
94 | --without-java \ |
99 | --without-java \ |
95 | --with-odbc \ |
100 | --with-odbc \ |
96 | --with-sane \ |
101 | --with-sane \ |
97 | --with-postgres \ |
102 | --with-postgres \ |
98 | --with-postgres-include-dir=/usr/include/postgresql \ |
103 | --with-postgres-include-dir=`pg_config --includedir` \ |
99 | --with-libpq-dir=/usr/lib \ |
104 | --with-libpq-dir=/usr/lib \ |
100 | --with-perl \ |
105 | --with-perl \ |
101 | --without-ffmpeg \ |
106 | --without-ffmpeg \ |
- | 107 | --without-fftw \ |
|
102 | --without-libpdf \ |
108 | --without-libpdf \ |
103 | --without-libpanda \ |
109 | --without-libpanda \ |
104 | --without-GTK \ |
110 | --without-GTK \ |
105 | --without-GTK2 \ |
111 | --without-GTK2 \ |
- | 112 | --without-bundles \ |
|
106 | $(MACHINE_OPTS) $(EXTRA_ARGS) |
113 | $(MACHINE_OPTS) $(EXTRA_ARGS) |
107 | 114 | ||
108 | include_prefix=/usr/include/pike/$(VERSION) |
115 | include_prefix=/usr/include/pike/$(VERSION) |
109 | lib_prefix=/usr/lib/pike/$(VERSION) |
116 | lib_prefix=/usr/lib/pike/$(VERSION) |
110 | 117 | ||
111 | MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core -N $(PIKE)-dev) |
118 | MODULE_PACKAGES=$(shell dh_listpackages -a -N $(PIKE)-core -N $(PIKE)-dev) |
112 | #{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}. |
119 | #{ADT,Array,Audio,Cache,Calendar,Calendar_I,COM,Colors,CommonLog,Crypto,Debug,Filesystem,Error,Float,Function,Geography,Getopt,Gettext,Gmp,Graphics,Gz,HTTPAccept,Int,Kerberos,Languages,Local,Locale,Mapping,Math,MIME,Mird,Multiset,Nettle,Parser,Pike,Pipe,Process,Program,Protocols,Regexp,Remote,SSL,Shuffler,Standards,Stdio,String,System,Thread,Tools,Unicode,Web,Yabu,Yp,_ADT,_Charset,_Roxen,___Gz,___MIME,___Math,___Mird,___Regexp,___Yp,____Charset,__builtin*,spider}. |
113 | #usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.* |
120 | #usr/lib/pike/*/modules/Sql.pmod/{module,Sql,rsql,sql_*}.* |
114 | 121 | ||
115 | excluded_modules:=Ssleay Msql msql PDF Ffmpeg Oracle oracle sybase Gnome GTK GDK DVB Java TTF |
122 | excluded_modules:=Ssleay Mird Msql msql PDF Ffmpeg Oracle oracle sybase Gnome GTK GDK DVB Java TTF |
116 | # This is tricky. Note that it's only possible for an exclusion to match the last |
123 | # This is tricky. Note that it's only possible for an exclusion to match the last |
117 | # component specified in an .install file or on the command line, and below. |
124 | # component specified in an .install file or on the command line, and below. |
118 | DH_EXCLUDE:=$(addprefix -X,$(excluded_modules)) |
125 | DH_EXCLUDE:=$(addprefix -X,$(excluded_modules)) |
119 | DH_ALREADY=`for p in $(MODULE_PACKAGES); do \ |
126 | DH_ALREADY=`for p in $(MODULE_PACKAGES); do \ |
120 | find debian/$$p/usr/lib/pike/*/* -type f -printf "-X%P "; done` |
127 | find debian/$$p/usr/lib/pike/*/* -type f -printf "-X%P "; done` |
121 | 128 | ||
122 | TMP=$(CURDIR)/debian/tmp |
129 | TMP=$(CURDIR)/debian/tmp |
123 | 130 | ||
124 | export CFLAGS CC PIKE VERSION |
131 | #export CFLAGS CC PIKE VERSION |
- | 132 | export CC |
|
125 | 133 | ||
126 | build-arch: build-arch-stamp |
134 | build-arch: build-arch-stamp |
127 | build-arch-stamp: $(DPATCH_STAMPFN) |
135 | build-arch-stamp: $(DPATCH_STAMPFN) |
128 | dh_testdir |
136 | dh_testdir |
129 | 137 | ||
Line 148... | Line 156... | ||
148 | dh_testdir |
156 | dh_testdir |
149 | dh_testroot |
157 | dh_testroot |
150 | rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp |
158 | rm -f build-stamp build-arch-stamp build-indep-stamp configure-stamp |
151 | 159 | ||
152 | # Add here commands to clean up after the build process. |
160 | # Add here commands to clean up after the build process. |
153 | -$(MAKE) distclean |
161 | $(MAKE) distclean |
154 | rm -rf refdoc/modref refdoc/traditional_manual |
162 | rm -rf refdoc/modref refdoc/traditional_manual |
155 | 163 | ||
156 | install: DH_OPTIONS= |
164 | install: DH_OPTIONS= |
157 | install: build-arch |
165 | install: build-arch |
158 | dh_testdir |
166 | dh_testdir |
Line 185... | Line 193... | ||
185 | -e 's@#! */usr/bin/env.*pike@#!/usr/bin/$(PIKE)@' \ |
193 | -e 's@#! */usr/bin/env.*pike@#!/usr/bin/$(PIKE)@' \ |
186 | $$f; \ |
194 | $$f; \ |
187 | fi; \ |
195 | fi; \ |
188 | done |
196 | done |
189 | 197 | ||
190 | # Install the specs file |
198 | # Don't install our own specs file - the ordinary one is not that bad really |
191 | sed -e 's/@PIKEVERSION@/$(VERSION)/g' \ |
199 | # sed -e 's/@PIKEVERSION@/$(VERSION)/g' \ |
192 | -e 's;@CONFIGURE_ARGS@;$(CFARGS);g' \ |
200 | -e 's;@CONFIGURE_ARGS@;$(CFARGS);g' \ |
193 | < debian/specs.in > $(TMP)$(include_prefix)/specs |
201 | debian/specs.in > $(TMP)$(include_prefix)/specs |
194 | 202 | ||
195 | # Install pike-config |
203 | # Install pike-config |
196 | sed -e "s#@CFLAGS@#$(include_prefix)#;s/@LDFLAGS@//" \ |
204 | sed -e "s#@CFLAGS@#-I$(include_prefix)#;s/@LDFLAGS@//" \ |
197 | -e "s/@MAJOR@/$(MAJOR)/;s/@MINOR@/$(MINOR)/;s/@BUILD@/$(BUILD)/" \ |
205 | -e "s/@MAJOR@/$(MAJOR)/;s/@MINOR@/$(MINOR)/;s/@BUILD@/$(BUILD)/" \ |
198 | debian/pike-config.in > $(TMP)/usr/bin/$(PIKE)-config |
206 | debian/pike-config.in > $(TMP)/usr/bin/$(PIKE)-config |
199 | 207 | ||
200 | # # pike -x module fix |
208 | # # pike -x module fix |
201 | sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/dynamic_module_makefile;g' \ |
209 | sed -i -e 's;\$$(MODULE_BASE)/dynamic_module_makefile;\$$(PIKE_SRC_DIR)/dynamic_module_makefile;g' \ |
Line 209... | Line 217... | ||
209 | # install the docs |
217 | # install the docs |
210 | dh_install -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual |
218 | dh_install -p$(PIKE)-manual refdoc/traditional_manual/* usr/share/doc/$(PIKE)-doc/html/manual |
211 | dh_install -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference |
219 | dh_install -p$(PIKE)-reference refdoc/modref/* usr/share/doc/$(PIKE)-doc/html/reference |
212 | dh_install -i -N$(PIKE)-manual -N$(PIKE)-reference --sourcedir=$(TMP) |
220 | dh_install -i -N$(PIKE)-manual -N$(PIKE)-reference --sourcedir=$(TMP) |
213 | dh_installdocs -i |
221 | dh_installdocs -i |
214 | dh_installchangelogs -i |
222 | dh_installchangelogs -i -k CHANGES |
215 | dh_link -i |
223 | dh_link -i |
216 | dh_compress -i |
224 | dh_compress -i |
217 | dh_fixperms -i |
225 | dh_fixperms -i |
218 | dh_installdeb -i |
226 | dh_installdeb -i |
219 | dh_gencontrol -i |
227 | dh_gencontrol -i |
Line 223... | Line 231... | ||
223 | # Build architecture-dependent files here. |
231 | # Build architecture-dependent files here. |
224 | binary-arch: build-arch install |
232 | binary-arch: build-arch install |
225 | dh_testdir -a |
233 | dh_testdir -a |
226 | dh_testroot -a |
234 | dh_testroot -a |
227 | # dh_installdebconf -a |
235 | # dh_installdebconf -a |
228 | dh_install -a --sourcedir=debian/tmp -N$(PIKE)-core $(DH_EXCLUDE) |
236 | dh_install -a -N$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) |
229 | dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY) |
237 | dh_install -p$(PIKE)-core --sourcedir=debian/tmp $(DH_EXCLUDE) $(DH_ALREADY) |
230 | for p in $(MODULE_PACKAGES); do \ |
238 | for p in $(MODULE_PACKAGES) $(PIKE)-dev; do \ |
231 | dh_link -p$$p usr/share/doc/$(PIKE)-core usr/share/doc/$$p; \ |
239 | dh_link -p$$p usr/share/doc/$(PIKE)-core usr/share/doc/$$p; \ |
232 | done |
240 | done |
233 | dh_installdocs -a |
241 | dh_installdocs -a |
234 | dh_installmenu -a |
242 | dh_installmenu -a |
235 | # dh_installman -a |
243 | # dh_installman -a |
236 | dh_installchangelogs -a |
244 | dh_installchangelogs -a -k CHANGES |
237 | dh_strip -a |
245 | dh_strip -a |
238 | dh_compress -a |
246 | dh_compress -a |
239 | dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite |
247 | dh_fixperms -a -X/run_autoconfig -X/precompile.sh -X/smartlink -X/fixdepends.sh -X/install_module -X/mktestsuite |
240 | dh_installdeb -a |
248 | dh_installdeb -a |
241 | dh_shlibdeps -a |
249 | dh_shlibdeps -a |