Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 195 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 195 Rev 207
Line 87... Line 87...
87
87
88
ifneq ($(VERSION),$(DEBVERSION))
88
ifneq ($(VERSION),$(DEBVERSION))
89
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
89
$(error Version mismatch; buildid.txt: $(VERSION), debian/changelog: $(DEBVERSION))
90
endif
90
endif
91
91
92
CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
-
 
93
CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
-
 
94
LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
-
 
95
-
 
96
# --with-lib-path is just to stop configure from adding all the
92
# --with-lib-path is just to stop configure from adding all the
97
# standard library directories with -L as well as -R to LDFLAGS
93
# standard library directories with -L as well as -R to LDFLAGS
98
CFARGS=$(CFARGSEXTRA) \
94
CFARGS=$(CFARGSEXTRA) \
99
       --with-cflags='`dpkg-buildflags --get CFLAGS`' \
95
       --with-cflags='`dpkg-buildflags --get CFLAGS`' \
100
       --with-cppflags='`dpkg-buildflags --get CPPFLAGS`' \
96
       --with-cppflags='`dpkg-buildflags --get CPPFLAGS`' \