?revision_form?Rev ?revision_input??revision_submit??revision_endform?
Rev 134 |
Go to most recent revision |
Blame |
Compare with Previous |
Last modification |
View Log
| RSS feed
Author: Magnus Holmgren
Bug-Debian: http://bugs.debian.org/593436
Description: Increase module dumping timeout
The timeout seems to be too short on architectures such as ARM and Geode.
--- a/lib/modules/Tools.pmod/Standalone.pmod/dump.pike
+++ b/lib/modules/Tools.pmod/Standalone.pmod/dump.pike
@@ -325,7 +325,8 @@ void dump_files() {
#if constant(alarm)
// Dumping shouldn't take more than a minute per file.
- alarm(60);
+ // Except on architectures such as ARM and Geode.
+ alarm(300);
#endif
string file = files[pos++];