Rev 98 | Rev 126 | Go to most recent revision | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 98 | Rev 114 | ||
---|---|---|---|
Line 29... | Line 29... | ||
29 | # installation fails and the `postinst' is called with `abort-upgrade', |
29 | # installation fails and the `postinst' is called with `abort-upgrade', |
30 | # `abort-remove' or `abort-deconfigure'. |
30 | # `abort-remove' or `abort-deconfigure'. |
31 | LOCAL_DIRS="lib/pike${PIKE}/modules lib/pike${PIKE}/include" |
31 | LOCAL_DIRS="lib/pike${PIKE}/modules lib/pike${PIKE}/include" |
32 | 32 | ||
33 | update_modules () { |
33 | update_modules () { |
- | 34 | # Unfortunately we more or less have to delete all .o files and |
|
- | 35 | # redump everything, because although master.pike won't use a .o |
|
- | 36 | # file that is older than its corresponding source, modules often |
|
- | 37 | # contain compile-time conditionals like |
|
- | 38 | # |
|
- | 39 | # #if constant(Mysql.mysql) |
|
- | 40 | # |
|
- | 41 | # If the Mysql module is not installed, the code inside that |
|
- | 42 | # conditional block will not be compiled, and the referring module |
|
- | 43 | # won't be detected as out-of-date if the Mysql module is later |
|
- | 44 | # installed. |
|
34 | find /usr/lib/$PIKEBIN/modules -name '*.o' -delete |
45 | find /usr/lib/$PIKEBIN -name '*.o' -delete |
35 | $PIKEBIN -x dump --distquiet -r /usr/lib/$PIKEBIN/modules |
46 | $PIKEBIN -x dump --distquiet -r /usr/lib/$PIKEBIN |
36 | } |
47 | } |
37 | 48 | ||
38 | case "$1" in |
49 | case "$1" in |
39 | configure) |
50 | configure) |
40 | update-alternatives --install /usr/bin/pike pike /usr/bin/${PIKEBIN} 12 \ |
51 | update-alternatives --install /usr/bin/pike pike /usr/bin/${PIKEBIN} 12 \ |
Line 46... | Line 57... | ||
46 | if [ ! -d /usr/local/$d ]; then |
57 | if [ ! -d /usr/local/$d ]; then |
47 | install -d -m 755 -o root -g root /usr/local/$d || true |
58 | install -d -m 755 -o root -g root /usr/local/$d || true |
48 | fi |
59 | fi |
49 | done |
60 | done |
50 | 61 | ||
51 | $PIKEBIN -x dump --distquiet /usr/lib/$PIKEBIN/master.pike |
- | |
52 | update_modules |
62 | update_modules |
53 | ;; |
63 | ;; |
54 | 64 | ||
55 | abort-upgrade|abort-remove|abort-deconfigure) |
65 | abort-upgrade|abort-remove|abort-deconfigure) |
56 | 66 |