Subversion Repositories

?revision_form?
Rev ?revision_input??revision_submit?
?revision_endform?

Go to most recent revision | Show changed files | Directory listing | RSS feed

Filtering Options

Rev Age Author Path Log message Diff
76 4110d 18h holmgren /tags/7.8.316-1/ [svn-buildpackage] Tagging pike7.8 (7.8.316-1)  
75 4110d 18h holmgren /trunk/debian/ Set distribution to experimental  
72 4110d 19h holmgren /trunk/debian/ Increase Standards-Version to 3.8.3.  
71 4110d 19h holmgren /trunk/debian/ Use $(filter) instead of $(findstring) to parse DEB_BUILD_OPTIONS.  
68 4110d 19h holmgren /trunk/debian/ Add debian/README.source.  
67 4110d 19h holmgren /trunk/debian/ Point Vcs-Svn and Vcs-Browser at svn.debian.org.  
65 4110d 20h holmgren /trunk/debian/ Spelling  
64 4110d 20h holmgren /trunk/debian/ Instead of patching shebangs and fixing execute permissions, simply
remove them from all Pike scripts. None of them are meant to be run
directly anyway.
 
62 4110d 20h holmgren /trunk/debian/ Refresh all other patches.  
61 4110d 20h holmgren /trunk/debian/ 05_install.pike.dpatch (disabled): The passing-on of lib_prefix was
fixed upstream, so this patch now instead does that with share_prefix
and modifies install.pike to use it. The rest of the package is not
quite ready though, so the patch is disabled for now.
 
60 4110d 21h holmgren /trunk/debian/patches/ Include precompiled C code changes in Nettle 2.0 patch.  
52 4111d 17h holmgren /trunk/debian/ Increase Debhelper compat level to 5.  
50 4111d 19h holmgren /trunk/debian/patches/ Reduce Nettle patch to only work with Nettle 2.0 so that we don't have to rebuild configure.  
47 4117d 21h holmgren /trunk/debian/ * Switch to Nettle 2.0 (Build-Depend on nettle-dev instead of
libnettle-dev).
+ nettle_2.0.dpatch: Temporarily include changes made in upstream CVS
to accomodate the API changes.
 
46 4117d 21h holmgren /trunk/debian/ New upstream release.  
45 4119d 14h holmgren /trunk/debian/ Skip the pike -x module fix; it doesn't seem necessary and was also
currently broken.
 
44 4131d 17h magnus /trunk/debian/ Close bugs.  
43 4131d 22h magnus /trunk/debian/ pike7.8-core.postinst: Increase update-alternatives priority.  
42 4133d 02h magnus /trunk/debian/ Rename the metapackage that depends on all Pike packages pike7.8-full,
-full being a more common suffix for such a package.
 
41 4155d 21h magnus /trunk/debian/ * New major upstream release; new package name.
+ New modules: SQLite, Fuse, DNS-SD, and FFTW.
- Perl module removed.
* Modify debian/watch to track the latest 7.8 version using uscan's
recursive capabilities.
* debian/control:
* Bumped standards to version 3.8.0.
+ Added build dependency on libfftw3-dev.
+ Added build dependency on libavahi-compat-libdnssd-dev.
+ Created new binary package 'pike-dnssd' for pike DNS-SD module.
- Dropped the dependencies on libpng12-dev and libreadline5-dev.
* debian/rules:
- Removed '--with-perl' from CFARGS as perl module is deprecated.
* Fixed path to dynamic_module_makefile in install rule.
* Rewrote shell trickery to determine DEBVERSION as previous method did
not work correctly in all cases.
- Enable GTK2 module as it has much better support in 7.8.
- Fixed CFARGS quoting issues.
- Specifically disable DVB and Oracle in CFARGS.
- Tidy things up a bit.
* debian/patches/05_install.pike.dpatch: refreshed.
* debian/patches/07_dynamic_module_makefile.in-libgcc.dpatch: refreshed.
* debian/copyright: Point at versioned copy of GPL and LGPL.
* Big thanks to Cody A.W. Somerville <cody-somerville@ubuntu.com> who did
most the the work.
 

Show All