Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 98 | Only display areas with differences | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed

Rev 98 Rev 112
1
#! /bin/sh
1
#! /bin/sh
2
# postinst script for pike7.8
2
# postinst script for pike7.8
3
#
3
#
4
# see: dh_installdeb(1)
4
# see: dh_installdeb(1)
5
# 
5
# 
6
# $Id: pike7.8-core.postinst,v 1.1 2006/01/17 22:37:48 grendel Exp $
6
# $Id: pike7.8-core.postinst,v 1.1 2006/01/17 22:37:48 grendel Exp $
7
#
7
#
8
8
9
set -e
9
set -e
10
10
11
PIKE=7.8
11
PIKE=7.8
12
PIKEBIN=pike${PIKE}
12
PIKEBIN=pike${PIKE}
13
13
14
# summary of how this script can be called:
14
# summary of how this script can be called:
15
#        * <postinst> `configure' <most-recently-configured-version>
15
#        * <postinst> `configure' <most-recently-configured-version>
16
#        * <old-postinst> `abort-upgrade' <new version>
16
#        * <old-postinst> `abort-upgrade' <new version>
17
#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
17
#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
18
#          <new-version>
18
#          <new-version>
19
#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
19
#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
20
#          <failed-install-package> <version> `removing'
20
#          <failed-install-package> <version> `removing'
21
#          <conflicting-package> <version>
21
#          <conflicting-package> <version>
22
# for details, see http://www.debian.org/doc/debian-policy/ or
22
# for details, see http://www.debian.org/doc/debian-policy/ or
23
# the debian-policy package
23
# the debian-policy package
24
#
24
#
25
# quoting from the policy:
25
# quoting from the policy:
26
#     Any necessary prompting should almost always be confined to the
26
#     Any necessary prompting should almost always be confined to the
27
#     post-installation script, and should be protected with a conditional
27
#     post-installation script, and should be protected with a conditional
28
#     so that unnecessary prompting doesn't happen if a package's
28
#     so that unnecessary prompting doesn't happen if a package's
29
#     installation fails and the `postinst' is called with `abort-upgrade',
29
#     installation fails and the `postinst' is called with `abort-upgrade',
30
#     `abort-remove' or `abort-deconfigure'.
30
#     `abort-remove' or `abort-deconfigure'.
31
LOCAL_DIRS="lib/pike${PIKE}/modules lib/pike${PIKE}/include"
31
LOCAL_DIRS="lib/pike${PIKE}/modules lib/pike${PIKE}/include"
32
32
33
update_modules () {
33
update_modules () {
34
    find /usr/lib/$PIKEBIN/modules -name '*.o' -delete
34
    find /usr/lib/$PIKEBIN/modules -name '*.o' -delete
35
    $PIKEBIN -x dump --distquiet -r /usr/lib/$PIKEBIN/modules
35
    $PIKEBIN -x dump --distquiet -r /usr/lib/$PIKEBIN/modules
36
}
36
}
37
37
38
case "$1" in
38
case "$1" in
39
    configure)
39
    configure)
40
    update-alternatives --install /usr/bin/pike pike /usr/bin/${PIKEBIN} 12 \
40
    update-alternatives --install /usr/bin/pike pike /usr/bin/${PIKEBIN} 12 \
41
    --slave /usr/share/man/man1/pike.1.gz pike.1.gz /usr/share/man/man1/${PIKEBIN}.1.gz
41
    --slave /usr/share/man/man1/pike.1.gz pike.1.gz /usr/share/man/man1/${PIKEBIN}.1.gz
42
    #
42
    #
43
    # If the creation fails, so be it, user might have the filesystem mounted r/o
43
    # If the creation fails, so be it, user might have the filesystem mounted r/o
44
    #
44
    #
45
    for d in $LOCAL_DIRS; do
45
    for d in $LOCAL_DIRS; do
46
        if [ ! -d /usr/local/$d ]; then
46
        if [ ! -d /usr/local/$d ]; then
47
            install -d -m 755 -o root -g root /usr/local/$d || true
47
            install -d -m 755 -o root -g root /usr/local/$d || true
48
        fi
48
        fi
49
    done
49
    done
50
50
51
    $PIKEBIN -x dump --distquiet /usr/lib/$PIKEBIN/master.pike
51
    $PIKEBIN -x dump --distquiet /usr/lib/$PIKEBIN/master.pike
52
    update_modules
52
    update_modules
53
    ;;
53
    ;;
54
54
55
    abort-upgrade|abort-remove|abort-deconfigure)
55
    abort-upgrade|abort-remove|abort-deconfigure)
56
56
57
    ;;
57
    ;;
58
58
59
    triggered)
59
    triggered)
60
	update_modules
60
	update_modules
61
    ;;
61
    ;;
62
62
63
    *)
63
    *)
64
        echo "postinst called with unknown argument \`$1'" >&2
64
        echo "postinst called with unknown argument \`$1'" >&2
65
        exit 1
65
        exit 1
66
    ;;
66
    ;;
67
esac
67
esac
68
68
69
# dh_installdeb will replace this with shell code automatically
69
# dh_installdeb will replace this with shell code automatically
70
# generated by other debhelper scripts.
70
# generated by other debhelper scripts.
71
71
72
#DEBHELPER#
72
#DEBHELPER#
73
73
74
exit 0
74
exit 0