Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 151 | Blame | Compare with Previous | Last modification | View Log | RSS feed

--- a/src/configure
+++ b/src/configure
@@ -90560,6 +90560,9 @@ cat confdefs.h >>conftest.$ac_ext
 cat >>conftest.$ac_ext <<_ACEOF
 /* end confdefs.h.  */
 #include <pthread.h>
+#if defined(__stub_pthread_atfork) || defined(__stub___pthread_atfork)
+#error pthread_atfork is just a stub
+#endif
         void foo(void) { pthread_atfork(0,0,0); }
 
 int
--- a/src/configure.in
+++ b/src/configure.in
@@ -3977,6 +3977,9 @@ pthread_t gazonk;
     AC_MSG_CHECKING(for pthread_atfork)
     AC_CACHE_VAL(pike_cv_have_pthread_atfork,[
       AC_TRY_LINK([#include <pthread.h>
+#if defined(__stub_pthread_atfork) || defined(__stub___pthread_atfork)
+#error pthread_atfork is just a stub
+#endif
         void foo(void) { pthread_atfork(0,0,0); }
       ],[],[
         pike_cv_have_pthread_atfork=yes