Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 169 | Blame | Compare with Previous | Last modification | View Log | RSS feed

From: Arne Goedeke <el@laramies.com>
Subject: Nette.MD5: passwd array was too small
Origin: upstream, http://pike-librarian.lysator.liu.se/piff.xml?module=pike.git&file=src/post_modules/Nettle/crypt_md5.c&from=ef75d0301312d2d5603760772bcd09f16cd24c8a&to=2652ce0df4d39c09a57049b3ca0daf735b331e5b

--- a/src/post_modules/Nettle/crypt_md5.c
+++ b/src/post_modules/Nettle/crypt_md5.c
@@ -47,7 +47,7 @@ char *pike_crypt_md5(int pl, const char
                               * it this way, we can get
                               * better later on
                               */
-  static char passwd[22], *p;
+  static char passwd[23], *p;
   unsigned char final[MD5_DIGEST_SIZE];
   int i;
   struct md5_ctx ctx;