Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 236 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
236 holmgren 1
Description: Fix FTBFS (missing symbols) on i386
2
 (probably due to changed meaning of inline with GCC 5, although it is
3
 unclear why only i386 fails). Patch named after what it's for
4
 according to upstream's comment.
5
Origin: upstream, commit ab15112ae6c8d82611374d9da1ed3116206d4a29
6
Author: Tobias S. Josefowitz<tobij@tobij.de>
7
 
8
--- a/src/pike_search_engine2.c
9
+++ b/src/pike_search_engine2.c
10
@@ -47,6 +47,9 @@ HCHAR *NameNH(memchr_search)(void *data,
11
 }
12
 
13
 
14
+#ifndef DEBUG_CLANG
15
+static /* works around clang 3.0 compilation/linking error. */
16
+#endif
17
 INLINE HCHAR *NameNH(memchr_memcmp)(NCHAR *needle,
18
                                    ptrdiff_t needlelen,
19
                                    HCHAR *haystack,