Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 231 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
134 holmgren 1
Description: Make smartlink not use -rpath
2 magnus 2
 
134 holmgren 3
--- a/bin/smartlink
4
+++ b/bin/smartlink
5
@@ -161,10 +161,9 @@ if test x$# != x0 ; then
6
    SunOS\ 5.*)
2 magnus 7
      LDOPTS="$LDOPTS -R$RPATH"
8
    ;;
134 holmgren 9
-   Linux\ 2.*)
2 magnus 10
-     if test x$LINKING != xno -a "x$RPATH" != x ; then
11
-      LDOPTS="$LDOPTS -Wl,-rpath,$RPATH"
12
-     fi
231 holmgren 13
+   Linux\ *)
2 magnus 14
+     LD_LIBRARY_PATH="$RPATH"
15
+     export LD_LIBRARY_PATH
16
    ;;
17
    UnixWare\ 7.*)
18
      if test x$LINKING != xno -a "x$RPATH" != x ; then