Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 238 | Blame | Compare with Previous | Last modification | View Log | RSS feed

Description: Make smartlink not use -rpath

--- a/bin/smartlink
+++ b/bin/smartlink
@@ -167,9 +167,8 @@ if test x$# != x0 ; then
      export LD_LIBRARY_PATH LD_RUN_PATH
    ;;
    Linux\ *)
-     if test x$LINKING != xno -a "x$RPATH" != x ; then
-      LDOPTS="$LDOPTS -Wl,-rpath,$RPATH"
-     fi
+     LD_LIBRARY_PATH="$RPATH"
+     export LD_LIBRARY_PATH
    ;;
    UnixWare\ 7.*)
      if test x$LINKING != xno -a "x$RPATH" != x ; then