Rev 41 | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 41 | Rev 62 | ||
---|---|---|---|
Line 3... | Line 3... | ||
3 | ## |
3 | ## |
4 | ## All lines beginning with `## DP:' are a description of the patch. |
4 | ## All lines beginning with `## DP:' are a description of the patch. |
5 | ## DP: Make smartlink not use -rpath |
5 | ## DP: Make smartlink not use -rpath |
6 | 6 | ||
7 | @DPATCH@ |
7 | @DPATCH@ |
8 | - | ||
- | 8 | diff -urNad trunk~/bin/smartlink trunk/bin/smartlink |
|
9 | --- 7.7.orig/bin/smartlink 2006-03-19 18:01:51.000000000 +0100 |
9 | --- trunk~/bin/smartlink 2008-08-19 13:51:08.000000000 +0200 |
10 | +++ 7.7/bin/smartlink 2006-08-09 02:07:32.940847999 +0200 |
10 | +++ trunk/bin/smartlink 2009-08-16 17:18:26.000000000 +0200 |
11 | @@ -162,9 +162,8 @@ if test x$# != x0 ; then |
11 | @@ -162,9 +162,8 @@ |
12 | LDOPTS="$LDOPTS -R$RPATH" |
12 | LDOPTS="$LDOPTS -R$RPATH" |
13 | ;; |
13 | ;; |
14 | Linux\ 2.*) |
14 | Linux\ 2.*) |
15 | - if test x$LINKING != xno -a "x$RPATH" != x ; then |
15 | - if test x$LINKING != xno -a "x$RPATH" != x ; then |
16 | - LDOPTS="$LDOPTS -Wl,-rpath,$RPATH" |
16 | - LDOPTS="$LDOPTS -Wl,-rpath,$RPATH" |
Line 18... | Line 18... | ||
18 | + LD_LIBRARY_PATH="$RPATH" |
18 | + LD_LIBRARY_PATH="$RPATH" |
19 | + export LD_LIBRARY_PATH |
19 | + export LD_LIBRARY_PATH |
20 | ;; |
20 | ;; |
21 | UnixWare\ 7.*) |
21 | UnixWare\ 7.*) |
22 | if test x$LINKING != xno -a "x$RPATH" != x ; then |
22 | if test x$LINKING != xno -a "x$RPATH" != x ; then |
- | 23 | diff -urNad trunk~/src/smartlink.c trunk/src/smartlink.c |
|
23 | --- 7.7.orig/src/smartlink.c 2006-08-09 01:30:57.000000000 +0200 |
24 | --- trunk~/src/smartlink.c 2008-08-19 17:57:34.000000000 +0200 |
24 | +++ 7.7/src/smartlink.c 2006-08-09 02:07:32.940847999 +0200 |
25 | +++ trunk/src/smartlink.c 2009-08-16 17:18:26.000000000 +0200 |
25 | @@ -151,7 +151,7 @@ int main(int argc, char **argv) |
26 | @@ -160,7 +160,7 @@ |
26 | full_rpath = rpath; |
27 | full_rpath = rpath; |
27 | 28 | ||
28 | #ifdef USE_Wl |
29 | #ifdef USE_Wl |
29 | - strcat(rpath, "-Wl,-rpath,"); |
30 | - strcat(rpath, "-Wl,-rpath,"); |
30 | + /* strcat(rpath, "-Wl,-rpath,"); */ |
31 | + /* strcat(rpath, "-Wl,-rpath,"); */ |
31 | #elif defined(USE_Wl_R) |
32 | #elif defined(USE_Wl_R) |
32 | strcat(rpath, "-Wl,-R"); |
33 | strcat(rpath, "-Wl,-R"); |
33 | #elif defined(USE_R) |
34 | #elif defined(USE_R) |
34 | @@ -293,7 +293,7 @@ int main(int argc, char **argv) |
35 | @@ -310,7 +310,7 @@ |
35 | } |
36 | } |
36 | rpath_in_use |= add_path(rpath, ld_lib_path); |
37 | rpath_in_use |= add_path(rpath, ld_lib_path); |
37 | } |
38 | } |
38 | - |
39 | - |
39 | +#if 0 |
40 | +#if 0 |
40 | if (rpath_in_use) { |
41 | if (rpath_in_use) { |
41 | /* Delete the terminating ':' */ |
42 | /* Delete the terminating ':' */ |
42 | rpath[strlen(rpath) - 1] = 0; |
43 | rpath[strlen(rpath) - 1] = 0; |
43 | @@ -340,6 +340,7 @@ int main(int argc, char **argv) |
44 | @@ -357,6 +357,7 @@ |
44 | #error Unknown method |
45 | #error Unknown method |
45 | #endif |
46 | #endif |
46 | } |
47 | } |
47 | +#endif |
48 | +#endif |
48 | 49 |