Blame | Last modification | View Log | RSS feed
#! /bin/sh /usr/share/dpatch/dpatch-run
## 02_smartlink_rpath.dpatch by <magnus@proffe.kibibyte.se>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Make smartlink not use -rpath
@DPATCH@
--- pike7.3-7.3.51.orig/bin/smartlink
+++ pike7.3-7.3.51/bin/smartlink
@@ -147,9 +147,8 @@
LDOPTS="$LDOPTS -R$RPATH"
;;
Linux\ 2.*)
- if test x$LINKING != xno -a "x$RPATH" != x ; then
- LDOPTS="$LDOPTS -Wl,-rpath,$RPATH"
- fi
+ LD_LIBRARY_PATH="$RPATH"
+ export LD_LIBRARY_PATH
;;
UnixWare\ 7.*)
if test x$LINKING != xno -a "x$RPATH" != x ; then
--- pike7.5-7.5.3/src/smartlink.c.orig 2003-01-17 20:13:38.000000000 +0100
+++ pike7.3-7.5.3/src/smartlink.c 2003-03-20 16:58:02.000000000 +0100
@@ -146,7 +146,7 @@
full_rpath = rpath;
#ifdef USE_Wl
- strcat(rpath, "-Wl,-rpath,");
+ /* strcat(rpath, "-Wl,-rpath,"); */
#elif defined(USE_Wl_R)
strcat(rpath, "-Wl,-R");
#elif defined(USE_R)
@@ -258,7 +258,7 @@
}
rpath_in_use |= add_path(rpath, ld_lib_path);
}
-
+#if 0
if (rpath_in_use) {
/* Delete the terminating ':' */
rpath[strlen(rpath) - 1] = 0;
@@ -305,6 +305,7 @@
#error Unknown method
#endif
}
+#endif
new_argv[new_argc++] = NULL;