Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 3 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
3 magnus 1
#!/bin/sh /usr/share/dpatch/dpatch-run
2
## 10_misplaced_MAXPATHLEN.dpatch by Samuel Thibault <samuel.thibault@ens-lyon.org>
3
##
4
## All lines beginning with `## DP:' are a description of the patch.
5
## DP: Move reserve MAXPATHLEN definition up.
6
 
7
@DPATCH@
62 holmgren 8
diff -urNad pike7.8-7.8.316~/src/modules/files/efuns.c pike7.8-7.8.316/src/modules/files/efuns.c
9
--- pike7.8-7.8.316~/src/modules/files/efuns.c	2009-08-15 01:01:23.000000000 +0200
10
+++ pike7.8-7.8.316/src/modules/files/efuns.c	2009-08-15 01:02:21.000000000 +0200
11
@@ -109,6 +109,10 @@
3 magnus 12
 
62 holmgren 13
 #endif /* __NT__ */
3 magnus 14
 
15
+#ifndef MAXPATHLEN
16
+#define MAXPATHLEN 32768
17
+#endif
18
+
19
 struct array *encode_stat(PIKE_STAT_T *s)
20
 {
21
   struct array *a;
62 holmgren 22
@@ -1443,9 +1447,6 @@
3 magnus 23
     size*=2;
24
   } while (size < 10000);
25
 #else
26
-#ifndef MAXPATHLEN
27
-#define MAXPATHLEN 32768
28
-#endif
29
   tmp=xalloc(MAXPATHLEN+1);
30
   THREADS_ALLOW_UID();
31
   e = getwd(tmp);