Rev 3 | Show entire file | Ignore whitespace | Details | Blame | Last modification | View Log | RSS feed
Rev 3 | Rev 62 | ||
---|---|---|---|
Line 3... | Line 3... | ||
3 | ## |
3 | ## |
4 | ## All lines beginning with `## DP:' are a description of the patch. |
4 | ## All lines beginning with `## DP:' are a description of the patch. |
5 | ## DP: Move reserve MAXPATHLEN definition up. |
5 | ## DP: Move reserve MAXPATHLEN definition up. |
6 | 6 | ||
7 | @DPATCH@ |
7 | @DPATCH@ |
8 | - | ||
- | 8 | diff -urNad pike7.8-7.8.316~/src/modules/files/efuns.c pike7.8-7.8.316/src/modules/files/efuns.c |
|
9 | --- pike7.6-7.6.112.orig/src/modules/files/efuns.c 2007-07-24 23:08:26.932458000 +0000 |
9 | --- pike7.8-7.8.316~/src/modules/files/efuns.c 2009-08-15 01:01:23.000000000 +0200 |
10 | +++ pike7.6-7.6.112/src/modules/files/efuns.c 2007-07-24 23:09:58.626801000 +0000 |
10 | +++ pike7.8-7.8.316/src/modules/files/efuns.c 2009-08-15 01:02:21.000000000 +0200 |
11 | @@ -106,6 +106,10 @@ |
11 | @@ -109,6 +109,10 @@ |
12 | 12 | ||
13 | #endif |
13 | #endif /* __NT__ */ |
14 | 14 | ||
15 | +#ifndef MAXPATHLEN |
15 | +#ifndef MAXPATHLEN |
16 | +#define MAXPATHLEN 32768 |
16 | +#define MAXPATHLEN 32768 |
17 | +#endif |
17 | +#endif |
18 | + |
18 | + |
19 | struct array *encode_stat(PIKE_STAT_T *s) |
19 | struct array *encode_stat(PIKE_STAT_T *s) |
20 | { |
20 | { |
21 | struct array *a; |
21 | struct array *a; |
22 | @@ -1113,9 +1117,6 @@ |
22 | @@ -1443,9 +1447,6 @@ |
23 | size*=2; |
23 | size*=2; |
24 | } while (size < 10000); |
24 | } while (size < 10000); |
25 | #else |
25 | #else |
26 | -#ifndef MAXPATHLEN |
26 | -#ifndef MAXPATHLEN |
27 | -#define MAXPATHLEN 32768 |
27 | -#define MAXPATHLEN 32768 |