Blame | Last modification | View Log | RSS feed
#!/bin/sh /usr/share/dpatch/dpatch-run
## 10_misplaced_MAXPATHLEN.dpatch by Samuel Thibault <samuel.thibault@ens-lyon.org>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Move reserve MAXPATHLEN definition up.
@DPATCH@
--- pike7.6-7.6.112.orig/src/modules/files/efuns.c 2007-07-24 23:08:26.932458000 +0000
+++ pike7.6-7.6.112/src/modules/files/efuns.c 2007-07-24 23:09:58.626801000 +0000
@@ -106,6 +106,10 @@
#endif
+#ifndef MAXPATHLEN
+#define MAXPATHLEN 32768
+#endif
+
struct array *encode_stat(PIKE_STAT_T *s)
{
struct array *a;
@@ -1113,9 +1117,6 @@
size*=2;
} while (size < 10000);
#else
-#ifndef MAXPATHLEN
-#define MAXPATHLEN 32768
-#endif
tmp=xalloc(MAXPATHLEN+1);
THREADS_ALLOW_UID();
e = getwd(tmp);