Rev 193 | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
192 | holmgren | 1 | Bug-Debian: https://bugs.debian.org/750430 |
2 | Description: Fix undefined behaviour/buffer overruns on 64-bit architectures caused by broken redefinition of size_t. |
||
3 | Basically the same change as was made to image_jpeg.c in 2008. |
||
4 | Origin: upstream, http://pike-librarian.lysator.liu.se/piff.xml?module=pike.git&file=src/modules/_Image_JPEG/image_jpeg.c&from=adc0e9374373e1ba10c5984038267f600322099c&to=4e36f92cfa282f0b673b0087e50708a5f41c3e24 |
||
5 | |||
6 | --- a/src/modules/_Image_JPEG/transupp.c |
||
7 | +++ b/src/modules/_Image_JPEG/transupp.c |
||
198 | holmgren | 8 | @@ -35,17 +35,7 @@ |
192 | holmgren | 9 | * of internals, and added inclusion of jerror.h |
10 | */ |
||
11 | |||
12 | -#define FILE void |
||
13 | -#define size_t unsigned int |
||
14 | -/* NOTE: INT32 and INT16 are redefined by <jmorecfg.h>. */ |
||
15 | -#if 0 |
||
16 | -#ifdef INT16 |
||
17 | -#undef INT16 |
||
18 | -#endif /* INT16 */ |
||
19 | -#ifdef INT32 |
||
20 | -#undef INT32 |
||
21 | -#endif |
||
22 | -#endif /* 0 */ |
||
23 | +#include <stdio.h> |
||
24 | |||
25 | #define XMD_H /* Avoid INT16 / INT32 being redefined */ |
||
26 |