Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 193 | Blame | Compare with Previous | Last modification | View Log | RSS feed

Bug-Debian: https://bugs.debian.org/750430
Description: Fix undefined behaviour/buffer overruns on 64-bit architectures caused by broken redefinition of size_t.
 Basically the same change as was made to image_jpeg.c in 2008.
Origin: upstream, http://pike-librarian.lysator.liu.se/piff.xml?module=pike.git&file=src/modules/_Image_JPEG/image_jpeg.c&from=adc0e9374373e1ba10c5984038267f600322099c&to=4e36f92cfa282f0b673b0087e50708a5f41c3e24

--- a/src/modules/_Image_JPEG/transupp.c
+++ b/src/modules/_Image_JPEG/transupp.c
@@ -35,17 +35,7 @@
  *         of internals, and added inclusion of jerror.h
  */
 
-#define FILE void
-#define size_t unsigned int
-/* NOTE: INT32 and INT16 are redefined by <jmorecfg.h>. */
-#if 0
-#ifdef INT16
-#undef INT16
-#endif /* INT16 */
-#ifdef INT32
-#undef INT32
-#endif
-#endif /* 0 */
+#include <stdio.h>
 
 #define XMD_H /* Avoid INT16 / INT32 being redefined */