Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Details | Last modification | View Log | RSS feed

Rev Author Line No. Line
109 holmgren 1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
## cflags.dpatch by Magnus Holmgren <holmgren@debian.org>
3
##
4
## DP: Don't remove the last component from include_prefix before using it in cflags
5
 
6
@DPATCH@
7
 
8
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' trunk~/lib/master.pike.in trunk/lib/master.pike.in
9
--- trunk~/lib/master.pike.in	2009-09-19 12:08:35.000000000 +0200
10
+++ trunk/lib/master.pike.in	2010-07-30 12:29:48.000000000 +0200
11
@@ -2104,7 +2104,7 @@
12
 
13
 #if "#include_prefix#"[0]!='#'
14
   include_prefix = "#include_prefix#";
15
-  cflags = (cflags || "") + " -I" + dirname(include_prefix);
16
+  cflags = (cflags || "") + " -I" + include_prefix;
17
 #endif
18
 
19
 #if "#doc_prefix#"[0]!='#'