Details | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
265 | holmgren | 1 | Description: Don't modify CFLAGS for unclear reasons in GL or GTK2. |
2 | |||
3 | --- a/src/post_modules/GL/Makefile.in |
||
4 | +++ b/src/post_modules/GL/Makefile.in |
||
5 | @@ -5,13 +5,6 @@ MODULE_LDFLAGS=@LDFLAGS@ @LIBS@ |
||
6 | CONFIG_HEADERS=@CONFIG_HEADERS@ |
||
7 | MODULE_CFLAGS=@X_CFLAGS@ |
||
8 | |||
9 | -override: |
||
10 | -# @echo "Original CFLAGS:$(CFLAGS)" |
||
11 | -# @echo "Modified CFLAGS: `echo ' $(CFLAGS) ' | sed -e 's/ -g[^ ]*//g' -e 's/ -W[^ ]*//g' -e 's/ -O[^ ]*//g'` -O `echo ' $(CFLAGS) ' | sed -ne 's/.*\( -gcc-version[^ ]*\).*/\1/p'`" |
||
12 | - @$(MAKE) \ |
||
13 | - CFLAGS="`echo ' $(CFLAGS) ' | sed -e 's/ -g[^ ]*//g' -e 's/ -W[^ ]*//g' -e 's/ -O[^ ]*//g'` -O `echo ' $(CFLAGS) ' | sed -ne 's/.*\( -gcc-version[^ ]*\).*/\1/p'`" \ |
||
14 | - all |
||
15 | - |
||
16 | @dynamic_module_makefile@ |
||
17 | |||
18 | auto.c : $(SRCDIR)/auto.c.in $(SRCDIR)/features.pike $(SRCDIR)/constants.pike $(SRCDIR)/gen.pike |
||
19 | --- a/src/post_modules/GTK2/Makefile.in |
||
20 | +++ b/src/post_modules/GTK2/Makefile.in |
||
21 | @@ -58,10 +58,7 @@ compile1: options |
||
22 | test -f "$$f" || ln -s "$(srcdir)/$$f" "$$f"; \ |
||
23 | done; \ |
||
24 | else :; fi |
||
25 | -# @echo "Original CFLAGS:$(CFLAGS)" |
||
26 | -# @echo "Modified CFLAGS:`echo ' $(CFLAGS) ' | sed -e 's/ -g[^ ]*//g' -e 's/ -W[^ ]*//g'` `echo ' $(CFLAGS) ' | sed -ne 's/.*\( -gcc-version[^ ]*\).*/\1/p'`" |
||
27 | @$(MAKE) OBJS="`cat files_to_compile`" \ |
||
28 | - CFLAGS="`echo ' $(CFLAGS) ' | sed -e 's/ -g[^ ]*/ /g' -e 's/ -W[^ ]*/ /g'` `echo ' $(CFLAGS) ' | sed -ne 's/.*\( -gcc-version[^ ]*\).*/\1/p'`" \ |
||
29 | MAKE_FLAGS='-e $(MAKE_FLAGS)' \ |
||
30 | all |
||
31 |