Subversion Repositories

?revision_form?Rev ?revision_input??revision_submit??revision_endform?

Rev 149 | Details | Compare with Previous | Last modification | View Log | RSS feed

Rev Author Line No. Line
149 holmgren 1
Author: Magnus Holmgren
2
Bug-Debian: http://bugs.debian.org/593436
3
Description: Increase module dumping timeout
4
 The timeout seems to be too short on architectures such as ARM and Geode.
5
 
121 holmgren 6
--- a/lib/modules/Tools.pmod/Standalone.pmod/dump.pike
7
+++ b/lib/modules/Tools.pmod/Standalone.pmod/dump.pike
198 holmgren 8
@@ -330,7 +330,8 @@ void dump_files() {
121 holmgren 9
 
10
 #if constant(alarm)
11
   // Dumping shouldn't take more than a minute per file.
12
-  alarm(60);
13
+  // Except on architectures such as ARM and Geode.
14
+  alarm(300);
15
 #endif
16
 
17
   string file = files[pos++];