Rev 41 | Go to most recent revision | Details | Compare with Previous | Last modification | View Log | RSS feed
Rev | Author | Line No. | Line |
---|---|---|---|
2 | magnus | 1 | #! /bin/sh /usr/share/dpatch/dpatch-run |
2 | ## 05_install.pike.dpatch by <magnus@proffe.kibibyte.se> |
||
3 | ## |
||
4 | ## All lines beginning with `## DP:' are a description of the patch. |
||
61 | holmgren | 5 | ## DP: Allow share_prefix to be separately overridden in install.pike |
2 | magnus | 6 | |
7 | @DPATCH@ |
||
41 | magnus | 8 | diff -urNad pike7.8-7.8.116~/src/Makefile.in pike7.8-7.8.116/src/Makefile.in |
9 | --- pike7.8-7.8.116~/src/Makefile.in 2008-11-18 15:16:56.000000000 -0400 |
||
10 | +++ pike7.8-7.8.116/src/Makefile.in 2009-05-04 21:50:17.000000000 -0300 |
||
11 | @@ -57,7 +57,7 @@ |
||
2 | magnus | 12 | # TESTARGS = -F -a |
13 | |||
14 | # Arguments for install.pike used by the install targets. |
||
15 | -INSTALLARGS = --new-style |
||
16 | +INSTALLARGS ?= --new-style |
||
17 | |||
18 | # |
||
19 | # use bison please, yacc isn't good enough. |
||
41 | magnus | 20 | @@ -658,7 +658,7 @@ |
2 | magnus | 21 | man_prefix="$(man_prefix)" pike_name=$(pike_name) \ |
22 | fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \ |
||
41 | magnus | 23 | cflags="@DYNAMIC_MODULE_FLAGS@" ldflags="" \ |
2 | magnus | 24 | - $(INSTALLARGS) |
61 | holmgren | 25 | + share_prefix="$(share_prefix)" $(INSTALLARGS) |
2 | magnus | 26 | |
41 | magnus | 27 | install_interactive: pike-complete-stamp tools |
2 | magnus | 28 | @$(RUNPIKE) $(TMP_BINDIR)/install.pike --interactive \ |
61 | holmgren | 29 | --- a/bin/install.pike 2009-06-08 23:51:36.000000000 +0200 |
30 | +++ b/bin/install.pike 2009-08-22 15:46:55.000000000 +0200 |
||
31 | @@ -1904,6 +1904,7 @@ |
||
32 | string exec_prefix; |
||
33 | string lib_prefix; |
||
34 | string include_prefix; |
||
35 | +string share_prefix; |
||
36 | string doc_prefix; |
||
37 | string man_prefix; |
||
38 | string cflags; |
||
39 | @@ -1946,6 +1947,8 @@ |
||
40 | lib_prefix=vars->lib_prefix||(prefix+"/lib/pike/"); |
||
41 | include_prefix = |
||
42 | vars->include_prefix || combine_path(prefix,"include","pike"); |
||
43 | + share_prefix = |
||
44 | + vars->share_prefix || lib_prefix; |
||
45 | doc_prefix = |
||
46 | vars->doc_prefix || combine_path(prefix, "doc", "pike"); |
||
47 | man_prefix=vars->man_prefix||(prefix+"/share/man/"); |
||
48 | @@ -2128,7 +2131,7 @@ |
||
49 | lib_prefix = combine_path(prefix, "lib"); |
||
50 | include_prefix = combine_path(prefix,"include","pike"); |
||
51 | make_master("lib/master.pike", "lib/master.pike.in", |
||
52 | - lib_prefix, include_prefix, UNDEFINED, cflags, ldflags); |
||
53 | + lib_prefix, include_prefix, share_prefix, cflags, ldflags); |
||
54 | status1("Installing master done."); |
||
55 | return 0; |
||
56 | |||
57 | @@ -2853,10 +2856,10 @@ |
||
58 | } |
||
59 | else |
||
60 | make_master(combine_path(vars->TMP_LIBDIR,"master.pike"), master_src, |
||
61 | - lib_prefix, include_prefix, UNDEFINED, cflags, ldflags); |
||
62 | + lib_prefix, include_prefix, share_prefix, cflags, ldflags); |
||
63 | |||
64 | install_dir(vars->TMP_LIBDIR,lib_prefix,1); |
||
65 | - install_dir(vars->LIBDIR_SRC,lib_prefix,1); |
||
66 | + install_dir(vars->LIBDIR_SRC,share_prefix,1); |
||
67 | |||
68 | install_header_files(vars->SRCDIR,include_prefix); |
||
69 | install_header_files(combine_path(vars->SRCDIR,"code"), |