?revision_form?Rev ?revision_input??revision_submit??revision_endform?
Rev 3 |
Go to most recent revision |
Blame |
Compare with Previous |
Last modification |
View Log
| RSS feed
#! /bin/sh /usr/share/dpatch/dpatch-run
## 05_install.pike.dpatch by <magnus@proffe.kibibyte.se>
##
## All lines beginning with `## DP:' are a description of the patch.
## DP: Allow include_prefix to be separately overridden in install.pike
@DPATCH@
--- 7.6/bin/install.pike 2005-12-30 14:33:48.450200000 +0100
+++ 7.6.fix/bin/install.pike 2005-12-30 15:14:24.806462750 +0100
@@ -1197,7 +1197,7 @@ int pre_install(array(string) argv)
exec_prefix=combine_path(prefix,"bin");
lib_prefix=combine_path(prefix,"lib");
doc_prefix=combine_path(prefix,"doc");
- include_prefix=combine_path(prefix,"include","pike");
+ include_prefix=vars->include_prefix||combine_path(prefix,"include","pike");
man_prefix=combine_path(prefix,"man");
if (export) {
low_install_file(combine_path(vars->TMP_BINDIR,"install.pike"),
--- 7.6.orig/src/Makefile.in 2005-07-28 01:19:28.618585000 +0200
+++ 7.6/src/Makefile.in 2005-08-16 12:53:13.127535720 +0200
@@ -53,7 +53,7 @@ man_prefix = $(prefix)/man
# TESTARGS = -F -a
# Arguments for install.pike used by the install targets.
-INSTALLARGS = --new-style
+INSTALLARGS ?= --new-style
#
# use bison please, yacc isn't good enough.
@@ -495,7 +495,7 @@ install: pike tools
MANDIR_SRC="$(MANDIR_SRC)" \
man_prefix="$(man_prefix)" pike_name=$(pike_name) \
fakeroot="$(buildroot)" PIKE_MODULE_RELOC="$(PIKE_MODULE_RELOC)" \
- $(INSTALLARGS)
+ include_prefix="$(include_prefix)" $(INSTALLARGS)
install_interactive: pike tools
@$(RUNPIKE) $(TMP_BINDIR)/install.pike --interactive \